Bug 123374 - SDL-devel, libSDL.la, and libasound.so
SDL-devel, libSDL.la, and libasound.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 15:18 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 05:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-05-17 15:18:39 EDT
Version-Release number of selected component: SDL-1.2.7-3

Description of problem:
Some 3rd party package fail to rebuild because of bad informations in
the libSDL.la file.

[root@gruyere /usr/lib]# grep asound libSDL.la
dependency_libs=' -lm -ldl -lasound -L/usr/X11R6/lib -lX11 -lXext
-lpthread'

the "-lasound" is not necessary and linking will report no problem if
I simply remove the -lasound from the libSDL.la. I suggest any of
these 3 fix:

1. Exclude the libSDL.la file from the package
2. Make SDL-devel requires alsa-lib-devel
3. Edit the libSDL.la and remove the -lasound.
Comment 1 Dams 2004-05-17 15:31:35 EDT
*hm* Spoken too soon. It seems only "2." is valid, since if you want
to staticaly link against libSDL.a you will need libasound.a.
Comment 2 Thomas Woerner 2004-05-24 05:29:22 EDT
Fixed in rawhide in rpm SDL-1.2.7-4 or newer.

Note You need to log in before you can comment on or make changes to this bug.