Bug 123382 - [PATCH] Gnome error when logging in with no CD
[PATCH] Gnome error when logging in with no CD
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nautilus (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 16:20 EDT by Rezwanul Kabir
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 08:41:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to nautilus-volume-monitor.c to resolve the issue (656 bytes, patch)
2004-05-17 16:26 EDT, Rezwanul Kabir
no flags Details | Diff
Patch to nautilus.spec in order to build the nautilus rpm (611 bytes, patch)
2004-05-17 16:28 EDT, Rezwanul Kabir
no flags Details | Diff

  None (edit)
Description Rezwanul Kabir 2004-05-17 16:20:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
H010818; .NET CLR 1.0.3705)

Description of problem:
If the cd drive is empty, whenever someone logs into Gnome Dekstop, 
nautilus adds the message "kernel: cdrom: This disc doesn't have any 
tracks I recognize!" to /var/log/messages. Apparently nautilus-volume-
monitor.c code is making ioctl call to find out the type of media 
without properly checking to see if there is one present in the 
drive..I am attaching a patch that resolves the issue.. 


Version-Release number of selected component (if applicable):
nautilus-2.2.4-4.E

How reproducible:
Always

Steps to Reproduce:
1.Keep cd drive empty
2.Log into the Gnome Desktop
3.    

Actual Results:  1.The message "kernel:cdrom: This disc doesn't have 
any tracks I recognize!" is added to /var/log/messages


Expected Results:  1. No such message should be present

Additional info:
Comment 1 Rezwanul Kabir 2004-05-17 16:26:12 EDT
Created attachment 100281 [details]
Patch to nautilus-volume-monitor.c to resolve the issue

This patch basically checks the cd drive for the existence of any media before
attempting to query the type of the media...
Comment 2 Rezwanul Kabir 2004-05-17 16:28:35 EDT
Created attachment 100282 [details]
Patch to nautilus.spec in order to build the nautilus rpm

This is a patch to nautilus.spec for some one interested in rebuilding the
rpm..
Comment 3 Alexander Larsson 2004-08-26 09:32:22 EDT
I fixed this upstream in gnome-vfs (which has the corresponding code
for later versions of gnome). It'll be in the next released version,
going into fc3, and from that into the next rhel release.
Comment 4 Alexander Larsson 2004-10-05 08:06:31 EDT
This is in rawhide/fc3 now.
Comment 5 Rezwanul Kabir 2004-11-16 17:04:56 EST
Reopening since the issue was originally filed with RHEL3.0. I have 
verified that the issue still exists for RHEL3 Update4 beta1.Is there 
a plan to incorporate the fix in RHEL3 Updates? 
Comment 6 Alexander Larsson 2005-01-11 08:41:13 EST
The fix will be in RHEL4, there is currently no plans to incorporate
the fix in a RHEL3 updatate since its quite a minor issue.

Note You need to log in before you can comment on or make changes to this bug.