Bug 123387 - XFree86 Server aborts with signal 11
XFree86 Server aborts with signal 11
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: XFree86 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 17:05 EDT by Russ Weight
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 23:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log showing messages leading up to server crash (46.97 KB, text/plain)
2004-05-17 17:11 EDT, Russ Weight
no flags Details

  None (edit)
Description Russ Weight 2004-05-17 17:05:44 EDT
Description of problem:
During stress testing for RHEL4 A2 re0327 on an IBM X255, the Xserver
crashed. I will attach the XFree86.2.log showing the messages leading
up to the failure. I ran this twice and it failed both times within
about 5 hours. The XFree86.2.log files were essentially the same.

Version-Release number of selected component (if applicable):
X Protocol Version 11, Revision 0, Release 6.6

How reproducible:
With the stress test I am using, it happened 2 out of 2 times.

Steps to Reproduce:
1. Start up multiple Xterms (6 or more) and give each one a repeating
workload (ls of a large directory, or cat of a large file, or "dmesg")
and let it run until it crashes.
  
Actual results:
X Server crashed with Signal 11

Expected results:
X Server should not crash

Additional info:
Comment 1 Russ Weight 2004-05-17 17:11:57 EDT
Created attachment 100283 [details]
XFree86 log showing messages leading up to server crash
Comment 3 Mike A. Harris 2004-09-21 01:52:47 EDT
The initial bug report comment indicates that RHEL4 A2 is being
tested, however this bug is filed against RHEL 3, and we have
replaced XFree86 with X.Org X11 6.8.0 in RHEL 4 development for
quite a while now.

Can you test our latest RHEL4 codebase with X.Org X11, and indicate
wether or not the problem is still reproduceable or not.

Thanks in advance.


Setting bug status to "NEEDINFO"
Comment 4 Chris McDermott 2004-09-21 10:54:26 EDT
Yes, Mike. This should have been filed against RHEL4 Alpha2. When the 
bug was submitted, the reporter did not have access to the 'Red Hat 
Enterprise Linux Beta' Product. That has been rectified. We will test 
this against RHEL4 Beta1 and report our findings.
Comment 5 Russ Weight 2004-09-21 11:42:35 EDT
This has been tested on RHEL4 Beta1, and the failure no longer occurs.
Comment 6 Mike A. Harris 2004-09-21 23:36:06 EDT
Chris, Russ,

Thanks for testing the latest codebase, and providing a
status update.

Setting status to "RAWHIDE" to indicate the issue is resolved in
our current development packages.

Note You need to log in before you can comment on or make changes to this bug.