Bug 123398 - Fails to run. Throws python error.
Summary: Fails to run. Throws python error.
Status: CLOSED DUPLICATE of bug 124800
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-xfree86   
(Show other bugs)
Version: 3.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-18 02:46 UTC by Brad Smith
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xf86Config File (3.24 KB, text/plain)
2004-05-25 02:57 UTC, Brad Smith
no flags Details

Description Brad Smith 2004-05-18 02:46:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
redhat-config-xfree86 fails to run. It used to work just fine, but U
have not run it for a while. This is the result I get:

[root@pico root]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 374, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 143,
in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 272,
in init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 50,
in compare_resolution
    a1 = resolution_area(res1)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 46,
in resolution_area
    (w, h) = resolution_from_string(res)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 43,
in resolution_from_string
    return (string.atoi(w), string.atoi(h))
  File "/usr/lib/python2.2/string.py", line 225, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): 1024_172


Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.7.7-1

How reproducible:
Always

Steps to Reproduce:
1.run tool from menu or terminal
2.get error
3.
    

Actual Results:  python errors
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 374, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 143,
in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 272,
in init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 50,
in compare_resolution
    a1 = resolution_area(res1)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 46,
in resolution_area
    (w, h) = resolution_from_string(res)
  File "/usr/lib/python2.2/site-packages/rhpl/xhwstate.py", line 43,
in resolution_from_string
    return (string.atoi(w), string.atoi(h))
  File "/usr/lib/python2.2/string.py", line 225, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): 1024_172


Expected Results:  the tool to run

Additional info:

this work station is up2date with rhn as of today (17 May 2004)

Comment 1 Brent Fox 2004-05-24 19:55:37 UTC
Can you attach your /etc/X11/XF86Config file and/or the
/etc/X11/xorg.conf file?

Comment 2 Brad Smith 2004-05-25 02:57:34 UTC
Created attachment 100527 [details]
Xf86Config File

As requested.

Comment 3 Brent Fox 2004-06-14 22:15:40 UTC
The underscore in the resolution "1280x1024_172" is causing the
problem.  Is there a reason why you are using that number instead of
"1280x1024"?

Comment 4 Brad Smith 2004-06-16 04:14:33 UTC
Brent - I recall having problems getting the video card to work
correctly with this monitor, and found a solution that involved
creating a custom modeline (possibly using an online tool; it has been
a while). I really cannot recall why the _172 was included (the
monitor is a samsung syncmaster 172T).

I will test this without the _172.

Comment 5 Brent Fox 2004-06-17 14:04:15 UTC

*** This bug has been marked as a duplicate of 124800 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:03:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.