Bug 123408 - linux testproject tests failed with 2.4.21-15 kernel
linux testproject tests failed with 2.4.21-15 kernel
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Peter Martuccelli
: 146023 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-05-18 05:03 EDT by Alex Lyashkov
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-23 10:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
task trace log (12.41 KB, application/x-tar)
2004-05-21 02:44 EDT, Alex Lyashkov
no flags Details

  None (edit)
Description Alex Lyashkov 2004-05-18 05:03:12 EDT
Description of problem:
test abort01 if hang with 2.4.21-15 kernel at amd Athlon.

Version-Release number of selected component (if applicable):

How reproducible:
install LTP test suite and run test.

Steps to Reproduce:
Actual results:
test abort01 is hang.

Expected results:
test suite work ok.

Additional info:
tag=abort01 stime=1084870400
cmdline="ulimit -c 1024;abort01"

16075 pts/8    S      0:00 /bin/sh ./runalltests.sh
16175 pts/8    S      0:00 /root/temp/2/ltp/pan/pan -e -S -a 16075 -n
16075 -f /
16176 pts/8    T      0:00 sh -c ulimit -c 1024;abort01
16177 pts/8    T      0:00 abort01
Comment 1 Peter Martuccelli 2004-05-18 17:11:03 EDT
Please update with the following information:

1 - Version of LTP that you are using to produce the abort01 test hang

2 - Output from "uname -a".

Comment 2 Alex Lyashkov 2004-05-19 00:12:15 EDT
1. LPT is last cvs version, updated yesterday.
2. [root@berloga root]# uname -a
Linux berloga.shadowland 2.4.21-15.EL #1 Wed May 12 16:17:59 EEST 2004
i686 athlon i386 GNU/Linux

PS. hang is in execute any tests group in batch. if run test manualy
test finished ok.
Comment 3 Peter Martuccelli 2004-05-19 15:41:23 EDT
The manual test ran fine on our Athlon test system last night.  Your
hang condition is only when LTP is run in batch, e.g. batch -f
./runalltests.sh, correct?  
Comment 4 Alex Lyashkov 2004-05-19 15:48:43 EDT
yes. but one - i don`t use batch -f.
i direct start runalltests.sh or start via ltpmenu.
Comment 5 Peter Martuccelli 2004-05-19 16:09:08 EDT
Tell me what you mean by direct start please.  You are at the bash
prompt and you enter "./runalltests.sh"?  You run the command as root?

If this is the case then I do not see the hang condition on my Athlon
based system.  I can put the LTP software package I used on a http
site. Would you be interested in using that software to verify your
hang condition?
Comment 6 Alex Lyashkov 2004-05-19 16:30:38 EDT
1. yes - i login as root - start xfree with kde desktop and in
kconsole start ./runalltest.sh

2. ok. put you LTP package at web and i try to run it at my system.
if it not been hanged - it LTP bug. or i can put my LTP directory for
you download.
Comment 7 Peter Martuccelli 2004-05-20 09:56:28 EDT
Please use the LTP software located at
http://people.redhat.com/peterm/ltp/.  Please update bug entry with
the results of your test.
Comment 8 Alex Lyashkov 2004-05-20 11:36:29 EDT
with that lpt distributions tests worked as expected.
Thanks for you work.
Сan I get from you news versions of LTP adapted for RH ?

Comment 9 Peter Martuccelli 2004-05-20 15:30:16 EDT
If the April version meets your requirements then please use it for
the short term.

The next step is for me to use the latest unmodified version from LTP
to see if it hangs on my Athlon system.   

Update with download information so I can get a copy of your exact LPT
version that is hanging.  

I will follow up with my findings.
Comment 10 Alex Lyashkov 2004-05-21 00:41:00 EDT
I try to use last LTP version available at LTP site.
or you can download my cvs snapshot
All of it`s copy's hanged at start tests.
Comment 11 Alex Lyashkov 2004-05-21 02:44:18 EDT
Created attachment 100410 [details]
task trace log
Comment 12 Alex Lyashkov 2004-05-21 02:44:59 EDT
It`s look a strange but today my workstation hanged again.
I tried start you LTP suite and test locked again.
I enable sysrq and record to syslog tasks trace.
Comment 13 Alex Lyashkov 2004-06-22 09:33:14 EDT
What are progress with this bug? You have any patches which i can test?
I found one bug in signal transmit and it fixed in 2.6 (bug in
__kill_pg_info) but can`t see it fix in RH kernel. Why?

Also I found Roland McGrath <roland@redhat.com> posted to
linux-kernel@ mail list "[PATCH] bogus sigaltstack calls by
rt_sigreturn" who affected to RH kernel, but RH distribution not
include it. Why?
Comment 15 Alex Lyashkov 2004-10-13 12:31:50 EDT
I updated my system to RH EL3 update3 via up2date. kernel 2.4.21-20
and  glibc 
# rpm -qa | grep glibc

but bug still here. What information need for fix it ?
Comment 16 Alex Lyashkov 2005-01-19 08:17:25 EST
hm.. know i try use ltp again, and found what is trigered this bug.
If i run ltp tests from bash shell it run ok, but if i start
runtest.sh from mc 4.6.0 i seen this bug. 
Comment 17 Jindrich Novy 2005-01-26 02:52:18 EST
*** Bug 146023 has been marked as a duplicate of this bug. ***
Comment 18 Alex Lyashkov 2005-08-26 07:59:15 EDT
This bug exist at last RH EL4 kernel - 2.6.9-11. 
Comment 19 Peter Martuccelli 2007-01-23 10:00:27 EST
Closing out this request as notabug for RHEL3, ltp from bash works properly.

Note You need to log in before you can comment on or make changes to this bug.