Bug 1234507 - vioser.sys driver causing windows 2012 R2 server to crash
Summary: vioser.sys driver causing windows 2012 R2 server to crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: x86_64
OS: Windows
urgent
urgent
Target Milestone: pre-dev-freeze
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-22 16:57 UTC by Robert McSwain
Modified: 2019-09-12 08:34 UTC (History)
19 users (show)

Fixed In Version: virtio-win-prewhql-0.1-107
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:51:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Robert McSwain 2015-06-22 16:57:28 UTC
Description of problem:
We have a Windows 2012R2 server that will periodically crash and reboot.  Microsoft has analyzed the core dump and come back with the following response:

We have got the Dump analyzed and again we have found that it is the same driver (vioser.sys) which has caused the crash.
 
Cause
=====
Here the KMDF Verifier has caught a possible race condition issue in "Red Hat VirtIO Serial driver (vioser.sys)"
Here this driver vioser.sys is completing a cancellable WDFRequest. This driver has a cancellation routine set for the request and it should have called WdfRequestUnmarkCancelable() before calling WdfRequestComplete(). But here the driver hasn't done so. So, after calling WdfRequestUnmarkCancelable() it has to check for the return  status from the same routine and do a completion accordingly.
 
Please refer this msdn document => https://msdn.microsoft.com/en-us/library/windows/hardware/ff549983(v=vs.85).aspx

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 

Last occurrence was on  6/1/2015 at 9:27 AM Eastern from within the Windows guest.  RHEV logs will be in UTC.


Version:
vioser.sys version 62.71.104.8600

Comment 14 lijin 2015-07-31 04:39:30 UTC
Hi Gal,

Could you provide a method for QE to reproduce and verify?

Comment 15 Gal Hammer 2015-08-02 06:50:27 UTC
(In reply to lijin from comment #14)
> Hi Gal,
> 
> Could you provide a method for QE to reproduce and verify?

Sorry, but I don't know how to reproduce it. The patch that should fix this issue is based only on a code review.

Comment 16 lijin 2015-08-05 10:29:53 UTC
Hi Robert,

Could you give us a feedback once customer try the fixed version?So that we can make sure this issue is fixed and we may ship it in next official virtio-win package.

Thanks a lot.

Comment 17 Robert McSwain 2015-08-31 13:09:56 UTC
lijin,

From the customer:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
We haven't had this issue again since we've updated the driver so it's probably safe to say it was a successful fix at this point.  Can we keep this ticket open until this fix makes it into the official driver?

Thanks for your help on this case.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

It looks like it was a success. Thank you and let's see about including this in official package.

Comment 22 errata-xmlrpc 2015-11-24 08:51:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.