Bug 123481 - SCSI sg driver doesn't recognize devices in kernel 2.6.6
SCSI sg driver doesn't recognize devices in kernel 2.6.6
Status: CLOSED DUPLICATE of bug 123876
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-05-18 16:56 EDT by Jeff Jennings
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Jennings 2004-05-18 16:56:24 EDT
Description of problem:
SCSI generic driver (sg) doesn't recognize SCSI devices.  Trying to
open /dev/sg? results in "No such device or address". 
/proc/scsi/sg/devices is empty.  /proc/scsi/scsi shows 2 devices, both
tape drives.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.cat /proc/scsi/sg/devices
2.mtx -f /dev/sg?
3.tapeinfo -f /dev/sg?
Actual results:
cat /proc/scsi/sg/devices:
<no output>

mtx -f /dev/sg0
cannot open SCSI device '/dev/sg0' - No such device or address

tapeinfo -f /dev/sg0
cannot open SCSI device '/dev/sg0' - No such device or address

Expected results:
0       0       4       0       1       1       1       0       1
0       0       5       0       1       1       1       0       1
or something like that

Additional info:
This hasn't worked on Fedora Core since kernel version 2.6.3.  It
works with Mandrake Linux 10 kernel 2.6.6-1mdk.
Comment 1 Jeff Jennings 2004-05-19 10:12:46 EDT
reading some kernel comments, in kernel 2.6.6 the SG ioctls have been
added to the ST driver, so sg commands now work on devices like
/dev/st0.    /proc/scsi/sg/devices still doesn't show devices as being
present, which is confusing.

i attached a tape autoloader and it shows up as the first SG device. 
the tape drive in the autoloader is not an SG device.

i'm thinking i should move this to the kernel bugzilla, but Mandrake
10 with kernel 2.6.6 has tapes show up as SG devices.  and the sg
commands work with /dev/st0 also.
Comment 2 Alan Cox 2004-05-21 20:06:11 EDT
This is a bug in the Fedora kernel

*** This bug has been marked as a duplicate of 123876 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.