Bug 123510 - cdrecord locks up writing a DVD image to an ATAPI DVD-R
cdrecord locks up writing a DVD image to an ATAPI DVD-R
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 18:32 EDT by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.6.5-1.358
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 13:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2004-05-18 18:32:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
When trying to write a DVD to an ATAPI drive, cdrecord hangs
permanently in D state with the following output.

Since the ide-scsi module is no longer provided, it's not possible to
bypass this problem by using the ide-scsi interface.

: tazenda 13 ; dvdrecord -v FC2-x86_64-DVD.iso
INFO: dvdrecord's functionality is now replaced by cdrecord
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01a27-dvd (--) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
<warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATAPI:0,0,0'
devname: 'ATAPI'
scsibus: 0 target: 0 lun: 0
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'HP      '
Identifikation : 'DVD Writer 300c '
Revision       : '9h04'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0010
Profile: 0x0010 (current)
Profile: 0x0008
Profile: 0x001B
Profile: 0x001A
Profile: 0x0009
Profile: 0x000A
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96R RAW/R16 RAW/R96R
Drive buf size : 1245184 = 1216 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  4075 MB
Total size:     4680 MB (463:39.66) = 2086475 sectors
Lout start:     4680 MB (463:41/50) = 2086475 sectors



Version-Release number of selected component (if applicable):
cdrecord-2.01-0.a27.3-x86_64

How reproducible:
Always

Steps to Reproduce:
1. Write a DVD image to an ATAPI DVD recorder.
2.
3.
    

Additional info:
Comment 1 Harald Hoyer 2004-05-24 06:43:44 EDT
which kernel version? I had several hangups with kernels < 2.6.5-1.358
Comment 2 H. Peter Anvin 2004-05-27 01:44:39 EDT
Kernel version 2.6.5-1.327 (stock FC2t3 install.)  I have since
upgraded to FC2 final (2.6.5-1.358) and I will try this again tomorrow.
Comment 3 H. Peter Anvin 2004-05-27 19:00:28 EDT
Seems to work with kernel 2.6.5-1.358.  Closing bug.
Comment 4 H. Peter Anvin 2004-05-28 21:04:12 EDT
I take that back.  I can write CDs with 2.6.5-1.358, but not DVDs!
Comment 5 Harald Hoyer 2004-06-01 05:01:39 EDT
does it work with cdrecord-prodvd, the commercial version of cdrecord?
Comment 6 Harald Hoyer 2004-06-01 05:46:41 EDT
and did you try growisofs to write DVDs?
Comment 7 H. Peter Anvin 2004-06-02 00:47:32 EDT
I didn't use growisofs (I used the FC2-i386-DVD iso image); I'll try
cdrecord-prodvd tomorrow, although I gather it only supports -dummy
mode without a license key (shouldn't affect the procedure as far as
the host is concerned.)
Comment 8 Harald Hoyer 2004-06-02 04:35:32 EDT
growisofs can burn predefined DVD iso images also.
you can get a licence key for educational and private use without any
problem (is on ftp)
Comment 9 Harald Hoyer 2004-06-04 06:21:19 EDT
ping?
Comment 10 H. Peter Anvin 2004-06-04 17:52:35 EDT
I tried this with Cdrecord-ProDVD-Clone 2.01a27 compiled for i686
(there is no x86-64 version.)  It simply refuses to talk to the drive:

: tazenda 78 ; sudo ./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu
dev=ATAPI:0,0,0 ~/fedora/2/FC2-i386-DVD.iso
./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu: No write mode specified.
./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu: Asuming -tao mode.
./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu: Future versions of
cdrecord may have different drive dependent defaults.
./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu: Continuing in 5 seconds...
Cdrecord-ProDVD-Clone 2.01a27 (i686-pc-linux-gnu) Copyright (C)
1995-2004 Jörg Schilling
Unlocked features: ProDVD Clone
Limited  features:
This copy of cdrecord is licensed for:
private/research/educational_non-commercial_use
scsidev: 'ATAPI:0,0,0'
devname: 'ATAPI'
scsibus: 0 target: 0 lun: 0
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'HP      '
Identifikation : 'DVD Writer 300c '
Revision       : '9h04'
Device seems to be: Generic mmc2 DVD-ROM.
./cdrecord-prodvd-2.01a27-i686-pc-linux-gnu: Sorry, no supported
CD/DVD-Recorder found on this target.
Comment 11 H. Peter Anvin 2004-06-04 18:01:15 EDT
This is what growisofs reports:

: tazenda 3 # ./growisofs -dvd-compat -Z
/dev/hdc=/home/hpa/fedora/2/FC2-i386-DVD.iso
:-[ READ DISC INFORMATION failed with SK=3h/ASC=30h/ACQ=01h]: Wrong
medium type
: tazenda 4 # cat /proc/ide/hdc/model
HP DVD Writer 300c
Comment 12 H. Peter Anvin 2004-06-04 18:02:14 EDT
More info:

: tazenda 8 # ./dvd+rw-mediainfo /dev/hdc
INQUIRY:                [HP      ][DVD Writer 300c ][9h04]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         10h, DVD-ROM
GET [CURRENT] PERFORMANCE:
 Write Performance:     0.0x1385=0KB/s@[0 -> 0]
:-[ READ DVD STRUCTURE#0 failed with SK=5h/ASC=24h/ACQ=00h]:
Input/output error
:-[ READ DISC INFORMATION failed with SK=3h/ASC=30h/ACQ=01h]: Wrong
medium type


((NOTE: The disc in the drive is DVD-R))
Comment 13 Harald Hoyer 2004-06-07 04:44:01 EDT
hmm, seems like the new ATAPI interface has problems with your writer...

did you try the new version of the dvd+rw-tools-5.19-1.4.9.7, too??
Comment 14 D. Chantrain 2004-11-05 16:35:53 EST
I stumbled across this bug while googling for a similar error (I could
burn CDs but not DVDs with an HP 400c, on Gentoo, running 2.6.9).
growisofs would report: :-[ READ DISC INFORMATION failed with
SK=3h/ASC=30h/ACQ=01h]: Wrong medium type

It appears that the problem was that I was using a DVD-R, but my drive
can only burn DVD+R/RW. It seems this is also the case for the HP 300
(http://h10025.www1.hp.com/ewfrf/wc/genericDocument?lc=en&cc=us&docname=lpg40564#N100BA)

HTH
Comment 15 Gordon Jones 2005-02-03 20:02:11 EST
I filed a lock-up bug myself and I have found something interesting.
Will add notes to my case.

Signed,

gbj@tomorrowsys.com
Comment 16 Edmond Hui 2006-02-09 01:18:27 EST
I am encounter this as well on FC4, with latest kernel.

My setup is a AMD Athlon 64 3000+, MSI RS480M2-IL m/b, 1GB dual channel DDR RAM,
2xSATA HDD, 2xATA HDD, 1xDVD burner

I saw on the /var/log/message sometimes with a DMA timeout error

ymehui at yahoo dot com
Comment 17 Raphael Clifford 2006-03-09 06:25:19 EST
I have exactly the same motherboard as comment 16. I simply had to enable dma
for the dvd drive using hdparm as it was not enabled by default.  (Drive is 
BENQ    DVD DD DW1640 )

hdparm -d1 /dev/dvd
Comment 18 John Thacker 2006-04-21 13:21:56 EDT
So, it seems that the original reporter's problem may be having a DVD-R disk in
a drive, the HP-300, that only supports DVD+R/W.

The DMA timeout error reported by another person is generally from DMA not being
enabled by default and is also not a fixable bug.

Note You need to log in before you can comment on or make changes to this bug.