Bug 123513 - parse error in member template method
parse error in member template method
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 19:07 EDT by Wes Perdue
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 05:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wes Perdue 2004-05-18 19:07:07 EDT
Description of problem:
Known template parse error in gcc exists in at least 2.95 thru 3.3;
fixed in 3.4.  Fix should probably be backported.

This is the exact bug we're experiencing:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=11501

gcc maintainers have marked it a duplicate of this bug:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=795

Version-Release number of selected component (if applicable):
[wes@lab-wkstn2 wes]$ rpm -q gcc
gcc-3.2.3-24
[wes@lab-wkstn2 wes]$ gcc --version
gcc (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-24)
Copyright (C) 2002 Free Software Foundation, Inc.

How reproducible:
see:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=11501

Steps to Reproduce:
1.
2.
3.
  
Actual results:
product_model.h:183: syntax error before `)' token

Expected results:
no error

Additional info:
[root@lab-wkstn2 linux-2.4.7]# uname -a
Linux lab-wkstn2 2.4.21-9.0.1.EL #1 Thu Feb 19 20:23:14 CST 2004 i686
i686 i386 GNU/Linux
Comment 1 Jakub Jelinek 2004-05-25 05:27:11 EDT
Many C++ parser bugs which were fixed by the C++ parser rewrite
in GCC 3.4 are really hard to backport and this one is one of them.
This will be fixed in RHEL4 which will use GCC 3.4.

Note You need to log in before you can comment on or make changes to this bug.