Bug 123519 - up2date crashes out of the box.
up2date crashes out of the box.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: 124619
  Show dependency treegraph
 
Reported: 2004-05-18 19:58 EDT by Richard Allen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 14:59:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2004-05-18 19:58:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Installed my Fedora Core 2 box and noticed the red exclamation mark
and ran up2date:

[root@xo root]# up2date -u 
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-2
using mirror: http://ftp.dulug.duke.edu/pub/fedora/linux/core/2/i386/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc2
using mirror: http://sunsite.mff.cuni.cz/pub/fedora/updates/2/i386/

Fetching Obsoletes list for channel: fedora-core-2...

Fetching Obsoletes list for channel: updates-released-fc2...

Fetching obsoletes list for
http://sunsite.mff.cuni.cz/pub/fedora/updates/2/i386/...

Fetching
http://sunsite.mff.cuni.cz/pub/fedora/updates/2/i386//headers/header.info...
########################################
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1271, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 799, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1147, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 62, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 101, in
__findPackagesToUpdate
    plist.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 128, in run
    progressCallback = self.progressCallback )
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 404, in
obsoletesList
    progressCallback = progressCallback )        
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 112, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 27, in
getObsoletes
    return self.handlers[channel['type']].getObsoletes(channel,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 249, in
getObsoletes
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
318, in getObsoletes
    baseFileName = "%s-%s-%s.%s.hdr" % (pkg[0], pkg[1], pkg[2], pkg[4])
IndexError: list index out of range


Version-Release number of selected component (if applicable):
up2date-4.3.19-1

How reproducible:
Always

Steps to Reproduce:
1.  run "up2date -u"
    

Additional info:
Comment 1 Ron Jenkins 2004-05-20 12:18:54 EDT
Same issue on clean install. Yum works fine.
Comment 2 Adrian Likins 2004-05-27 18:26:54 EDT
try cleaning up /var/spool/up2date:
       rm -rf /var/spool/up2date/*

and see if it shows the same error
Comment 3 Richard Allen 2004-05-27 19:36:18 EDT
The error magicly went away for me shortly after I reported.
Now I cant reproduce it.
Comment 4 Jos Vos 2005-05-04 17:35:59 EDT
See bug #143339.  It really *is* a bug and in bug #143339 I've described the
solution.

Note You need to log in before you can comment on or make changes to this bug.