Bug 123523 - File->Open File doesn't work
File->Open File doesn't work
Status: CLOSED DUPLICATE of bug 124341
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 20:17 EDT by Andy Wallace
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Wallace 2004-05-18 20:17:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The Open File option of the File menu does not work when the program
is first run.

It displays a filesystem browser, but when you select a ks.cfg file
and click Open, nothing happens. The Cancel button does not work
either - you have to kill the window with the X in the top-right corner.

However, it does work if you first type in a root password, select
File->Preview, then Cancel and then try to open the original ks.cfg file.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.5.11-1

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-kickstart
2. Select File->Open File
3. Try to load a previously-existing ks.cfg file
    

Actual Results:  Nothing. File browser window stays open, neither Open
nor Cancel buttons have any effect.

Expected Results:  File should be loaded into Kickstart Configurator.

Additional info:

Workaround - type in a root password, select File->Preview, then
Cancel. The File->Open File option will now work normally.
Comment 1 Brent Fox 2004-05-25 22:34:12 EDT
As a non-root user, try starting the program from a command line and
see if there is any debug output when you click the OK or Cancel buttons.
Comment 2 Andy Wallace 2004-05-26 18:18:28 EDT
OK, this is the debug output when clicking OK after selecting
File->Open File and highlighting a ks.cfg file:

[andy@pavonis andy]$ /usr/sbin/system-config-kickstart

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 270,
in on_activate_open
    self.fillData()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 301,
in fillData
    self.basic_class.fillData()
  File "/usr/share/system-config-kickstart/basic.py", line 318, in
fillData
    if "--emulthree" in mouseLine:
TypeError: iterable argument required

If I click Cancel first, it works correctly. Cancel only fails to work
after OK has failed.

I also tried specifying the file on the command-line and got a similar
traceback:

[andy@pavonis andy]$ /usr/sbin/system-config-kickstart ks.cfg
Traceback (most recent call last):
  File
"/usr/share/system-config-kickstart/system-config-kickstart.py", line
81, in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 164,
in __init__
    self.fillData()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 301,
in fillData
    self.basic_class.fillData()
  File "/usr/share/system-config-kickstart/basic.py", line 318, in
fillData
    if "--emulthree" in mouseLine:
TypeError: iterable argument required

Comment 3 Brent Fox 2004-06-16 16:18:07 EDT
Can you attach the kickstart file that you are using?
Comment 4 Brent Fox 2004-06-16 16:21:26 EDT
Nevermind, I just realized that I fixed this bug a few weeks ago. 
This is a duplicate of bug 124341.

*** This bug has been marked as a duplicate of 124341 ***
Comment 5 Jaime Ventura 2004-07-14 08:47:34 EDT
Hello!
I have the same problem. I have my system updated and its not working,
not even using the "Workaround" sugested on "Additional info".

# system-config-kickstart /mnt/floppy/ks.cfg
Traceback (most recent call last):
  File
"/usr/share/system-config-kickstart/system-config-kickstart.py", line
81, in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 164,
in __init__
    self.fillData()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 307,
in fillData
    self.firewall_class.fillData()
  File "/usr/share/system-config-kickstart/firewall.py", line 211, in
fillData
    self.firewallCustomizeRadio.set_active(gtk.TRUE)
AttributeError: 'NoneType' object has no attribute 'set_active'

Comment 6 Red Hat Bugzilla 2006-02-21 14:03:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.