Bug 123525 - [PATCH] Kernel fails with kernel parameter apm=power-off on SMP System.
[PATCH] Kernel fails with kernel parameter apm=power-off on SMP System.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
: 129498 (view as bug list)
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-05-18 20:59 EDT by Fuchi Hideshi
Modified: 2015-04-19 20:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:55:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fuchi Hideshi 2004-05-18 20:59:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.2)
Gecko/20040301

Description of problem:
During system boot, kernel fails with kernel parameter apm=power-off
on SMP System. During boot an error message will be reported by the
kernel.

-------------[ cut here ]--------------
kernel BUG at apm.c:1743!
invalid operand: 0000

CPU:	2
EIP:	0060:[<c011b94e>]	Not tainted
EFLAGS:	00010202

EIP is at apm [kernel] 0x33e (2.4.21-15-ELsmp/i686)
eax:   00000002	       ebx:  c179c000	ecx:	c0435280	edx:	ffffffff
esi:   c02b09ab	       edi:  c179c552	ebp:	00000000	esp:	c179dfd0
ds:    0068	       es:   0068	ss:	0068
Process kapmd (pid: 7, stackpage=c179d000)
Stack: 00000000 00000000 00000000 00000000 00000068 c011b610 00000000
00000000
       c010958d 00000000 00000000 00000000
Call Trace:	[<c011b610>] apm [kernel] 0x0 (0xc179dfe4)
[<c010958d>] kernel_thread_helper  [kernel] 0x5 (0x179dff0)

Code: 0f 0b cf 06 fd 08 2b c0 e9 03 fd ff ff 90 8d 74 26 00 83 ec

Kernel panic: Fatal exception 


Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-15.EL

How reproducible:
Always

Steps to Reproduce:
1. System boot with kernel parameter apm=power-off
2. Kerlen panic
    

Actual Results:  
kernel panic during system boot.

Expected Results:  
No kernel panic.

Additional info:

P4 smp system and single Xeon(with HT) system work fine, But Dual Xeon
system with HT does not work fine.
Comment 2 Rik van Riel 2004-05-18 22:59:27 EDT
Assigning to Ingo since his name appears inside the patch ;)

Ingo, I know that APM isn't SMP safe due to BIOS restrictions, but if
the above patch is harmless enough I guess we could merge it into
RHEL3 to fix the issue NEC is running into.
Comment 5 Jeff Needle 2004-08-09 21:18:02 EDT
*** Bug 129498 has been marked as a duplicate of this bug. ***
Comment 11 Ernie Petrides 2004-09-11 01:14:39 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.5.EL).
Comment 15 John Flanagan 2004-12-20 15:55:17 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.