Bug 123536 - Segfault when starting TuxRacer
Segfault when starting TuxRacer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tuxracer (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 02:44 EDT by Craig Marshall
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-20 04:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file for Dell D800 with ATI 9600 Pro (5.28 KB, text/plain)
2004-05-23 11:33 EDT, Edward Clark
no flags Details

  None (edit)
Description Craig Marshall 2004-05-19 02:44:24 EDT
Description of problem:
When starting TuxRacer from the KDE menu, it does absolutely nothing.
When starting it from the CLI, I get a segfault and the following
notification: "(SDL Parachute Deployed)".

Version-Release number of selected component (if applicable):
0.61

How reproducible:
Click the tuxracer icon in KDE menu, or type "tuxracer" at the prompt.

Actual results:

---8<---
[craig@fedora craig]$ tuxracer
Tux Racer 0.61 -- a Sunspire Studios Production
(http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

Fatal signal: Segmentation Fault (SDL Parachute Deployed)
[craig@fedora craig]$
--->8---

Additional info:

This is a brand new install. It's a Dell Dimension XPS T450, P3-450,
384M RAM. I installed Fedora Core 2 from the four isos I just
downloaded, it was a full install, nothing was left out. I have made
no configuration changes since the default installation, other than
shutting down extraneous services (chkconfig xyz off, service xyz
stop, etc).
Comment 1 Alan Cox 2004-05-21 19:46:13 EDT
What video card does the system have. Also after the tuxracer crash
does "dmesg" show any kernel "oops" message ?

Comment 2 Edward Clark 2004-05-23 11:33:31 EDT
Created attachment 100475 [details]
xorg.conf file for Dell D800 with ATI 9600 Pro
Comment 3 Edward Clark 2004-05-23 11:35:13 EDT
Attachment #100475 [details] is for my Dell D800 with ATI 9600 Pro Video.
I am running FC 2.
When I launch tuxracer, my screen fades to white. I hear music.
I press ESC to ge tout since I am afraid that the screen is going to
burn out my LCD from the brightness of the white screen.
Running ATI drivers from ATI website.
Any ideas?
Comment 4 Nathan 2004-06-10 19:47:39 EDT
I have the exact same prob- fresh install on an asus a7n8x mobo with
Nvidia 5700 gfx card-  When I run from the menu the screen goes black,
and reverts to the desktop, when I try from the console I get the
"Fatal signal: Segmentation Fault (SDL Parachute Deployed)" the kicked
is that I re-installed the rpm, worked from the console, but as soon
as I ran it from the menu- it died again.  but now it runs
intermittently form the console. and about 1/2-2/3 of the time gives
me the seg fault.  
                          
Comment 5 Alan Cox 2004-06-10 22:50:31 EDT
What drivers is the nvidia one using.  Problems involving ATI binary
drivers or Nvidia binary drivers should go to ATI or Nvidia. We can
only practically look at problems with the open source setups.
Comment 6 Erich Hoover 2004-07-30 01:11:47 EDT
I'm getting the same problem (FC3T1 x86-64) with an NVIDIA GeForce
6800, though I don't get the "SDL Parachute Deployed" part. I also got
it when I was using an ATI card with the default drivers (since ATI
has no 64-bit drivers this was my only choice).

tuxracer-0.61-26
kernel-2.6.7-1.494

This is what I get from dmesg:
tuxracer[24883]: segfault at 0000000000000000 rip 00000034c106b2a2 rsp
0000007fbffff390 error 6
Comment 7 Matthew Miller 2005-04-26 12:07:15 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 8 Marius Andreiana 2005-08-20 04:06:10 EDT
tuxracer has been replaced by ppracer in extras

Note You need to log in before you can comment on or make changes to this bug.