Bug 123553 - rpmdb: Encrypted checksum: no encryption key specified
rpmdb: Encrypted checksum: no encryption key specified
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 07:14 EDT by Joerg Sippel
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 07:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joerg Sippel 2004-05-19 07:14:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040510

Description of problem:
up2date and yum fails because of a missing encryption key ?

here the failure when trying to rebuild rpm-db

[root@localhost root]# rpmdb --rebuilddb
rpmdb: Encrypted checksum: no encryption key specified
rpmdb: /var/lib/rpm/Packages: pgin failed for page 5237
Fehler: db4 error(22) from dbcursor->c_get: Das Argument ist ung�ltig
[root@localhost root]#

here the error messages while trying to use up2date:

rpmdb: Encrypted checksum: no encryption key specified
rpmdb: /var/lib/rpm/Packages: pgin failed for page 5237
error: db4 error(22) from dbcursor->c_get: Invalid argument
rpmdb: Encrypted checksum: no encryption key specified
rpmdb: /var/lib/rpm/Packages: pgin failed for page 5237
error: db4 error(22) from dbcursor->c_get: Invalid argument


Version-Release number of selected component (if applicable):
rpm-4.3.1-0.3

How reproducible:
Always

Steps to Reproduce:
1. new install of fedora Core 2
2. try to update (up2date) or try to rebuild database
3.
    

Additional info:
Comment 1 Joerg Sippel 2004-05-19 07:57:21 EDT
it seems that there is something wrong with my installation. it runs 
on an other pc without problems

Note You need to log in before you can comment on or make changes to this bug.