Bug 123558 - bcm4401 won't come up
Summary: bcm4401 won't come up
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 123435 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-19 12:15 UTC by David Juran
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-08 23:30:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
b44-update.patch (6.99 KB, patch)
2004-06-22 13:55 UTC, John W. Linville
no flags Details | Diff
b44-update-U2.patch (8.25 KB, patch)
2004-06-23 15:02 UTC, John W. Linville
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:433 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 3 Update 3 2004-09-02 04:00:00 UTC

Description David Juran 2004-05-19 12:15:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
My BCM4401 NIC won't come up. I've booted into rescue mode with my
RHEL 3 U2 CD. Now when I try to get a IP# from DHCP it fails. ifconfig
-a shows me the NIC, but when i run 
ifconfig eth0 192.168.101.38 I get
SIOCSIFFLAGS: Device or resource busy

Do note that this works fine with FC2.
Also, bug 105787 ssems very similar to this one.

Version-Release number of selected component (if applicable):
kernel2.4.21-15.ELBOOT

How reproducible:
Always

Steps to Reproduce:
1.boot into rescue mode with RHEL 3 U2 CD
2.try to activate the network from DHCP
3.watch it fail
4.ifconfig -a shows you the existence of the NIC
5.ifconfig eth0 192.168.101.38 fails with the error message
SIOCSIFFLAGS: Device or resource busy
    

Additional info:

Comment 1 David Juran 2004-06-17 15:07:58 UTC
*** Bug 123435 has been marked as a duplicate of this bug. ***

Comment 2 John W. Linville 2004-06-22 13:55:59 UTC
Created attachment 101333 [details]
b44-update.patch

Backport of b44 driver from upstream (2.4.27-rc1); seems not to have problem as
described; got DHCP'ed address on startup w/o problems...

Comment 3 Ernie Petrides 2004-06-23 11:24:01 UTC
A fix for this problem has just been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.16.EL).


Comment 4 David Juran 2004-06-23 14:50:55 UTC
I just tried to apply this patch to kernel-2.4.21-15.0.2.EL (putting
it in the end of the patch list) but then the rpm would not build. I'm
getting the error
b44.c: In function `b44_init_one':
b44.c:1758: warning: implicit declaration of function `SET_NETDEV_DEV'
b44.c:1758: structure has no member named `dev'


Comment 5 John W. Linville 2004-06-23 15:02:27 UTC
Created attachment 101358 [details]
b44-update-U2.patch

version of patch for applying to U2 kernel (add SET_NETDEV_DEV() definition)...

Comment 6 David Juran 2004-06-24 12:40:15 UTC
This time the kernel builds, but I'm still getting the same error and
the network doesn't work )-:

Comment 7 John W. Linville 2004-06-24 13:28:50 UTC
Are you still booting from a CD?  If so, did you re-create the CD to
boot w/ the new kernel & modules?

Assuming you are booting from HD, make sure you are booting the kernel
and using the modules that were built w/ the patch.  I am running a
RHEL3 U2 box right here that is getting its IP address via DHCP on a
BCM4401, so I'm pretty sure this code should be working. 

Comment 8 David Juran 2004-06-24 18:13:33 UTC
I applied the patch by adding it to the end of the list of patches in
the spec-file and the I transferred the rpm to the computer using a
USB disk and rebooted and I'm quite certain I'm using the right kernel (-:
Could there be several varieties of cards that identify themselves as
a BCM4401? The computer is a ASUS Punit (
http://www.asus.com/products/desktop/pundit/overview.htm ) with an
integrated NIC. Is there any other debug information you would like?
Do note that I will be on vacation for a week so I will not be able to
test anything until the 6:th of July

Comment 9 David Juran 2004-08-08 23:30:09 UTC
Since I no longer have access to this system, I'm closing this bug...

Comment 10 John Flanagan 2004-09-02 04:31:36 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html



Note You need to log in before you can comment on or make changes to this bug.