Bug 123569 - Crashes on install. Never reaches cd3
Crashes on install. Never reaches cd3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 09:08 EDT by Amadeus
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amadeus 2004-05-19 09:08:32 EDT
Description of problem:
When installing FC2 on my IBM ThinkPad 600 (laptop), the installer
exits before reaching cd3.

[custom install]
When it happens the screen gets blue for awhile, and then shots down
the processes nicely (displaying the usual Some_program_name .....
[OK]), and then resets after a perfect shot down.
When the computer boots it reaches Grub in textmode, and that's it
when using a Custom install.

When I boot in rescue mode from the CD, and look in /root/install.log
I can see that the last line is:
Installing gok-0.10.2-1.i386.


[workstation install]
When it happens the screen gets blue for awhile, and then shots down
the processes nicely (displaying the usual Some_program_name .....
[OK]), and then resets after a perfect shot down.

If I use a Workstation install there is written GRUB GRUB GRUB all
over the screen when the computer starts again after the reboot.

When I boot in rescue mode from the CD, and look in /root/install.log
I can see that the last two lines are:
Installing gok-0.10.2-1.i386.
Installing gnome-terminal-2.6.0-2.i386.


Version-Release number of selected component (if applicable):
Original FC2 CD's.



How reproducible:
Everytime.

Steps to Reproduce:
1.0. Generic LDC Display -> LCD Panel 1024x768
1.1. Installing a fresh fc2, not upgrade.
1.2. Choosing Workstation.
1.3. Chooses not to modify the default selected packages.

or

2.0. Generic LDC Display -> LCD Panel 1024x768
2.1. Installing a fresh fc2, not upgrade.
2.2. Choosing Custom.

Actual results:


Expected results:


Additional info:
* I have checked the md5sum using "md5sum /dev/cdrom" on all the cd's
and they are correct accoring to www.fedora.redhat.com

* While it shows down the processes I can see that it writes something
about an unknown monitor or display.
Comment 1 Amadeus 2004-05-19 10:09:11 EDT
I now managed to get past gok in a Custom install, but rebooted less
then 2 minutes later.

Before I installed FC2 had I FC1 on it, which worked perfect.
Comment 2 Amadeus 2004-05-19 18:28:04 EDT
A minimal install works however. Perhaps because it doesn't require
disc 2, as the problem occures on disc 2 with the workstation/custum
install.

I have btw. tested disc 2 with the build-in test before the install
begins and it passed.
Comment 3 Jeremy Katz 2004-05-19 22:23:01 EDT
Can you try booting with 'linux ide=nodma' and see if that helps?
Comment 4 Amadeus 2004-05-20 07:26:23 EDT
No, it is the same although it installed about 5 more packages than
normal.
Comment 5 Amadeus 2004-05-27 09:57:13 EDT
I have just tried installing using "linux ide=nodma text" and that worked!

"linux ide=nodma" gives the same failure as mentionen.

Haven't tried "linux text".

If you can make me a sudo installer, so my current installation won't
be  deleted, I would like to help locate the bug.

Comment 6 Jeremy Katz 2004-06-08 14:50:17 EDT
Could you boot from the CD with 'memtest' and run memtest86 to see if
it passes?  This is really sounding like moderately hardware related.
Comment 7 Amadeus 2004-06-08 17:25:27 EDT
I have just tested it with 2 passes (took ~90 minuts) without any errors.

Note You need to log in before you can comment on or make changes to this bug.