Bug 123587 - X doesn't start after Dell BIOS upgrade
X doesn't start after Dell BIOS upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 10:46 EDT by Paul Black
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 12:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file (36.68 KB, text/plain)
2004-05-19 10:47 EDT, Paul Black
no flags Details
xorg.conf (2.74 KB, text/plain)
2004-05-19 10:47 EDT, Paul Black
no flags Details
Syslog message obtained when trying to start X (4.26 KB, text/plain)
2004-05-19 10:48 EDT, Paul Black
no flags Details

  None (edit)
Description Paul Black 2004-05-19 10:46:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I have a Dell Optiplex SX270. After upgrading the BIOS from A02 to A03
(hoping to fix other issues), X will no longer start. No kernel
messages are generated.

Xorg.log mentioned about dodgy BIOSes and to try putting
Option "DisplayInfo" "FALSE"
into xorg.conf. This had no effect.

Downgrading BIOS causes stuff to work again.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Upgrade BIOS
2. Boot machine
3. Wait for X to try to start
    

Actual Results:  X doesn't start

Expected Results:  X should start.


Additional info:
Comment 1 Paul Black 2004-05-19 10:47:18 EDT
Created attachment 100334 [details]
X log file
Comment 2 Paul Black 2004-05-19 10:47:38 EDT
Created attachment 100335 [details]
xorg.conf
Comment 3 Paul Black 2004-05-19 10:48:00 EDT
Created attachment 100336 [details]
Syslog message obtained when trying to start X
Comment 4 Paul Black 2004-05-21 12:22:18 EDT
Would appear that the issue is to do with the BIOS not reporting the
correct amount of video RAM. The following should help people in the
meantime: http://www.chzsoft.com.ar/855patch.html

Note You need to log in before you can comment on or make changes to this bug.