Bug 123610 - Upgrade from RHEL 3 to RHEL 4 throws an warning message
Upgrade from RHEL 3 to RHEL 4 throws an warning message
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 12:53 EDT by Asha Appalaraju
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 18:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asha Appalaraju 2004-05-19 12:53:18 EDT
Description of problem:
Upgrading from RHEL3 to RHEL 4 on a 32 bit throws the following error
message.
"upgrade for this version of RHEL AS are only supported from RH linux
6.2 or higher. This appears to be an older system. Do you wish to
continue the upgrade?"
If this is not a supported feature, than the upgrade button should be
disabled.
Version-Release number of selected component (if applicable):
RHEL 3 to RHEL 4 alpha 2

How reproducible:
This is very easily reproducible.Install RHEL3 on a system. Insert an
RHEL4 update 2 CD and choose to upgrade instead of a fresh install.

Steps to Reproduce:
1.Install RHEL3 on a system.
2.Insert an RHEL4 update 2 CD and choose to upgrade instead of a fresh
install.
3. You see an warning message.
  
Actual results:
"upgrade for this version of RHEL AS are only supported from RH linux
6.2 or higher. This appears to be an older system. Do you wish to
continue the upgrade?"

Expected results:
The upgrade button should be disabled if upgrade is not supported or
it should upgrade without complaining.

Additional info:
Comment 1 Tim Powers 2004-05-19 13:10:59 EDT
There is no RHEL 4 right now. 
Comment 2 Jeremy Katz 2004-06-09 18:29:39 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.