Bug 123617 - /dev/snd/pcmC0D0p failed: Device or resource busy
/dev/snd/pcmC0D0p failed: Device or resource busy
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 13:58 EDT by Troy Henderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 09:44:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Henderson 2004-05-19 13:58:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.14

Description of problem:
After working fine for a little while, suddenly /dev/snd/pcmC0D0p
shows up as "busy".  The output from, say, `ogg123` is:

#######################################################################
ALSA lib pcm_hw.c:1056:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p
failed: Device or resource busy
=== Could not load default driver and no driver specified in config
file. Exiting.
#######################################################################

This problem never happened when I was using FC1 with my own built
alsa-lib + kernel 2.6.6  All audio devices (even OSS emulation through
ALSA) stop working.  It seems as of now that a reboot is the only fix
(since I have ALSA built into my kernel).

Version-Release number of selected component (if applicable):
alsa-lib-1.0.3a-2

How reproducible:
Didn't try

Steps to Reproduce:
Just leaving the machine idle for a bit (sometimes as little as 12
hours) causes this to happen.  I can't intentionally reproduce it.


Additional info:
Comment 1 Troy Henderson 2004-05-21 02:12:33 EDT
Well, the problem seemed to be with `ogg123` trying to play a OGG file
with sampling rate of 11025Hz.  This sound file is the sound that's
played when someone on my Buddy List (in GAIM) comes online.  ogg123
wouldn't crash, it would just lock up.  After 32 people came online
(throughout the day), that's what caused the problem.  As long as < 32
instances of this ogg123 were running, everything was fine.  But as
soon as the 32nd copy of ogg123 came into being, I got the above error
when trying to use ogg123 again.

My sound card is a SB Live.  It seems that the bug is with ogg123
(because it can't play these 11025Hz sampled OGG's).  This bug did not
exist before FC2 (because I had no such issues in FC1 and I was using
ALSA then as well).  Perhaps the ogg123 that came with FC1 didn't use
ALSA though.  It probably used OSS, and I just emulated OSS with ALSA
in my 2.6 kernel.
Comment 2 Need Real Name 2004-05-24 14:34:31 EDT
I am also having this problem, with an nvidia board with onboard audio
(MCP2-T - think this is an intel chip). I didn't have any problems
with sound in RH9. I have had strange crashes of xmms, while playing
ogg files, and grip, while ripping an audio cd, (in both cases, being
unable to kill the process but without the process becoming
"<defunct>"), in both cases getting this message. Other programs
(firefox, for example) seem to crash from time to time with this
message too.
Comment 3 Martin Stransky 2005-01-05 07:11:47 EST
Is this problem still actual? What sound device do you use? hw, plughw
or default?

Note You need to log in before you can comment on or make changes to this bug.