Bug 123620 - NFS quota reporting fails with 'Invalid argument'
NFS quota reporting fails with 'Invalid argument'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: quota (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
: 131052 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 14:10 EDT by Pete Harvey
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 14:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for NFS quota checking (1.51 KB, text/plain)
2004-06-14 09:47 EDT, Simon Thompson
no flags Details
srpm based on the released fc2 quota package, updated to quota-tools-3.12 (220.13 KB, application/octet-stream)
2004-07-13 13:17 EDT, Ben Poliakoff
no flags Details

  None (edit)
Description Pete Harvey 2004-05-19 14:10:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1

Description of problem:
Trying to get quota information for NFS mounted filesystems fails, eg:

quota: Error while getting quota from fileserv:/home/homedirpath for 0: Invalid argument

NFS server is running Solaris 9.

Version-Release number of selected component (if applicable):
quota-3.10-2

How reproducible:
Always

Steps to Reproduce:
1.  Mount NFS share, either manually or via automounter.
2. Run "quota"
    

Additional info:
Comment 1 Eric Doutreleau 2004-05-26 09:12:13 EDT
I guess it s a problem of firewall on the NFS server.

Stop the iptables and u will see that it works.

The problems now is that i can't make bind the rpc.rquotad to a
specific port

i modified the /etc/init.d/nfs file
to launch rpc.rquotad on a specific port as it s writtent in the man
pages but it didn't work :(
Comment 2 Pete Harvey 2004-05-27 03:46:14 EDT
None of the NFS servers have firewalls or filtering running.  I've 
also tried temporarily switching off the iptables filtering on the 
client box but still no change.
Comment 3 Eric Doutreleau 2004-05-27 06:15:54 EDT
Then have u checked that the rpc.rquotad is running on the server

what does the rpcinfo -p servername give?
Comment 4 Pete Harvey 2004-05-28 12:58:58 EDT
   program vers proto   port
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100007    3   udp  32774  ypbind
    100007    2   udp  32774  ypbind
    100007    1   udp  32774  ypbind
    100007    3   tcp  32771  ypbind
    100007    2   tcp  32771  ypbind
    100007    1   tcp  32771  ypbind
    100024    1   udp  32778  status
    100024    1   tcp  32772  status
    100133    1   udp  32778
    100133    1   tcp  32772
    100021    1   udp   4045  nlockmgr
    100021    2   udp   4045  nlockmgr
    100021    3   udp   4045  nlockmgr
    100021    4   udp   4045  nlockmgr
    100021    1   tcp   4045  nlockmgr
    100021    2   tcp   4045  nlockmgr
    100021    3   tcp   4045  nlockmgr
    100021    4   tcp   4045  nlockmgr
    100005    1   udp  32791  mountd
    100005    2   udp  32791  mountd
    100005    3   udp  32791  mountd
    100005    1   tcp  32773  mountd
    100005    2   tcp  32773  mountd
    100005    3   tcp  32773  mountd
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100227    2   udp   2049  nfs_acl
    100227    3   udp   2049  nfs_acl
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100227    2   tcp   2049  nfs_acl
    100227    3   tcp   2049  nfs_acl
    100011    1   udp  55201  rquotad
Comment 5 Ben Poliakoff 2004-06-09 14:09:56 EDT
I'm seeing the exact same behavior with a NetApp NFS filer.  "rquotad"
is present in the output of "rpcinfo -p".  All iptables rules have
been flushed on the client machine and there is no firewall in between
the client and the NFS server.

NFS quota reporting in this environment (using the NetApp filer)
worked properly with all previous RedHat distributions.  I'll be
rolling out FC2 to a number of our labs soon.  I'd love to figure out
a fix for this problem.
Comment 6 Simon Thompson 2004-06-14 09:47:47 EDT
Created attachment 101105 [details]
Fix for NFS quota checking

Looks like its a bug in the quota-tools 3.10 release, if you download and
compile 3.11 or later it goes away ...

From 3.11's changelog:
"quota-tools should again use old RPC protocol when needed" (Jan Kara)

Attached patch backports changes from the 3.11 release and appears to work
correctly with our Solaris 9 fileserver
Comment 7 Luc Lalonde 2004-07-07 22:22:26 EDT
Tried Simon Thompson's patch FC2 client, SGI Irix 6.5.24 NFS server:

Before patch:
> quota
quota: Error while getting quota from
zeus:/store/homes/students/llalonde for 7262: Invalid argument
Disk quotas for user llalonde (uid 7262): none

After patch:
> quota -v
Disk quotas for user llalonde (uid 7262): none

Here's the quota information from a RedHat 9 client:
> quota
Disk quotas for user llalonde (uid 7262):
     Filesystem  blocks   quota   limit   grace   files   quota  
limit   grace
zeus:/store/homes/students/llalonde
                 759984  7500000 8000000            9609       0       0

All is still not right with suggested patch...
Comment 8 Luc Lalonde 2004-07-07 22:32:16 EDT
quota-tools version 3.12 works with FC2 and IRIX 6.5.24 NFS server:

> quota llalonde
Disk quotas for user llalonde (uid 7262):
     Filesystem  blocks   quota   limit   grace   files   quota  
limit   grace
zeus:/store/homes/students/llalonde
                 759984  7500000 8000000            9609       0       0
Comment 9 Luc Lalonde 2004-07-07 22:35:51 EDT
Forgot to add myself to CC list
Comment 10 Ben Poliakoff 2004-07-13 13:17:23 EDT
Created attachment 101866 [details]
srpm based on the released fc2 quota package, updated to quota-tools-3.12 

This is an srpm based on the released fc2 quota package, updated to
quota-tools-3.12.  quota-tools-3.12 fixes the quota reporting problem seen in
quota package that was release with fc2.

Works well for me, YMMV.

Ben
Comment 11 Nils Marving 2004-09-02 05:57:48 EDT
We had the same problem using a Tru64 nfs server, but the attachment 
id=101866 fixed it. Why is this not in Fedora Core 2 updates, it 
seems to harm a lot of people? 
Comment 12 Jay Hilliard 2004-09-10 15:30:42 EDT
Yes, please get this into updates.  We have the same problem with
Solaris8, Solaris9, and NetApp filers.

-J
Comment 13 Jay Hilliard 2004-09-10 15:40:20 EDT
*** Bug 131052 has been marked as a duplicate of this bug. ***
Comment 14 David Jansen 2004-10-07 09:36:23 EDT
I had the same problem with Soalris nfs servers; the quota 3.12 update
seems to fix it. Thanks! Would be nice if this would make it into the
official updates.
Comment 15 Steve Dickson 2004-10-11 06:25:00 EDT
This whould be fixed in the quota-3.12-5 rpm available in rawhide.
Comment 16 Matthew Miller 2004-10-11 09:50:29 EDT
Thanks Steve. Can we get that package from rawhide released as an update?
Comment 17 Matthew Miller 2006-07-07 14:22:40 EDT
So, again, a problem fixed in rawhide that probably should have been released as
an update but wasn't. Marking as resolved:rawhide, though.

Note You need to log in before you can comment on or make changes to this bug.