Bug 123634 - missing build-requires for flex in tcpdump source rpm
missing build-requires for flex in tcpdump source rpm
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcpdump (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 15:19 EDT by Chris Stankaitis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 12:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stankaitis 2004-05-19 15:19:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
rebuilding tcpdump from source on RHEL-3 box, produces following error:

configure: error: Your operating system's lex is insufficient to
compilelibpcap.  flex is a lex replacement that has many advantages,
including being able to compile libpcap.  For more information, see
 http://www.gnu.org/software/flex/flex.html .

Instlling flex package from RHN solves problem.

Spec file should be updated to reflect the missing build-requires.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild --target=i686 tcpdump-3.7.2-7.E3.1.src.rpm
2. watch it build
3. watch it bomb without flex installed
    

Actual Results:  got above listed error message

Expected Results:  build should not start if flex is missing on the system

Additional info:
Comment 1 Rik van Riel 2004-09-28 12:45:05 EDT
Hmmm, I don't think we should build an errata and make all of our
RHEL3 users download and upgrade the package due to a missing
buildrequires.

This is something we may want to add in if we have to rebuild the
package for another reason, but otherwise it's probably not worth the
pain.  Remember that some sysadmins are required to write a report
about every package they upgrade on their production systems, they'll
hate an errata for just this...

Note You need to log in before you can comment on or make changes to this bug.