Bug 123636 - LTC10336-error testing NETWORK using ctc device
LTC10336-error testing NETWORK using ctc device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: net (Show other bugs)
2
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
: 129081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 15:22 EDT by Brock Organ
Modified: 2007-04-18 13:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 14:07:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhr2-IBM_9111_520-3_results-1.noarch.rpm (29.41 KB, application/octet-stream)
2004-09-02 08:44 EDT, IBM Bug Proxy
no flags Details
rhrifup fix (347 bytes, patch)
2004-09-07 13:57 EDT, Rob Landry
no flags Details | Diff

  None (edit)
Description Brock Organ 2004-05-19 15:22:50 EDT
* RHEL3 U2 s390-as
* rhr certification testing
* using rhr2-tests-0.9-14.2, rhr2-externals-0.9-14.2, rhr2-0.9-14.2
* testing NETWORK (with ctc device)
 
when testing NETWORK (using ctc device), an error testing occurs:

> Cleaning scratch space (/tmp/rhr).
> Checking/configuring environment...
> WARNING: ctc0 could not read 10.0.21.104.
> Prep stage completed.
> Press return to continue or control-c to quit
>
> Starting interactive tests... Interactive stage completed.
>  Starting NETWORK test... root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> root@10.0.21.104's password:
> (checking results)                                         [ERROR]
> Press return to continue or control-c to quit

this issue seems to be worked around with the following patch (from
rlandry):
 
--- /usr/share/rhr/tests/NETWORK.orig   2004-05-19 06:48:39.000000000
-0400
+++ /usr/share/rhr/tests/NETWORK        2004-05-19 07:30:36.000000000
-0400
@@ -38,6 +38,7 @@
  for nic in $@; do
   parse_interface $nic
   if ifup $interface; then
+   sleep 5
    if ping -Ac1 $SERVER; then
     if ${installed_keys:-install_ssh_keys}; then
      local installed_keys=true
Comment 1 Rob Landry 2004-07-22 10:35:47 EDT
should be addressed in 0.9-14.8k available on
people.redhat.com/rlandry/rhr2/test; but this really needs some
testing to verify
Comment 2 Rob Landry 2004-08-04 14:53:11 EDT
*** Bug 129081 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2004-08-04 21:51:24 EDT
----- Additional Comments From zhouwu@cn.ibm.com  2004-08-04 21:52 -------
No machines available to try the new version now. Maybe we can try this two 
days later. 

But one problem confused me is that why it didn't fail on POWER4 machines and 
JS20. Trying the above script in comment #2 on two p630 shows that no package 
get lost at all. This is really odd. 
Comment 4 Rob Landry 2004-08-05 11:50:23 EDT
It's in dealing with static and linkup race condition.  When using
DHCP (for which these were mostly tested); linkup is required by ifup
as you can't send a DHCP request packet without it thus no problem was
noticed.  With static; linkup is not required by ifup; thusly ifup
could return before linkup had been established depending.  If that
happened you would run into problems.  The newer packages simply wait
for linkup or the timeout on ifup's.
Comment 5 IBM Bug Proxy 2004-08-06 05:36:54 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-06 05:37 -------
    I run the new rhr2 test script on box bacchuslp3, but NETWORK is [ERROR] 
yet!So I modify NETWORK to "delay=100", but it is still failed. 
    I try to use the old version RHR2 TEST RPM PACKET! After I add a 
line "sleep 100" between the two lines, it run OK!
   40   if ifup $interface; then
     41    if ping -Ac1 $SERVER; then
change to 
  40   if ifup $interface; then
    sleep 100
     41    if ping -Ac1 $SERVER; then

    BTW, the GUI of redhat-ready don't display "[ ]INFO" select button! I only 
select "[X]NETWORK"! But the script consider I have selected both them! it 
seems that it is a default select! I suspect that there have some wrong! 
Comment 6 IBM Bug Proxy 2004-08-06 05:46:53 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-06 05:43 -------
Sorry, I forget to provide the version number! packet 0.9-14.8k is the new I 
use,but failed! the old ver is 0.9-14.2. after been modified, it is ok! 
Comment 7 Rob Landry 2004-08-06 11:24:44 EDT
can I get /var/log/rhr/debug and
/var/log/rhr/tests/NETWORK/X/error.log from running the tests with
"redhat-ready -d".  As for no longer seeing "INFO" that's correct.  It
is now run by default.  If you only want to run a single test then you
can still use the CLI mode; though it's less documented than the rest
of the test suite.
Comment 8 IBM Bug Proxy 2004-08-12 01:04:44 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-12 01:01 -------
I got rhr2-0.9-15 from people.redhat.com/rlandry/rhr2. NETWORK test still 
error. after adding a "sleep 50" as the following, and re-runing the NETWORK 
test will report success.FYI

===================================================================
-- NETWORK.BAK 2004-08-11 22:40:28.000000000 -0400
+++ /usr/share/rhr/tests/NETWORK        2004-08-11 22:41:43.000000000 -0400
@@ -36,6 +36,7 @@
  for nic in $@; do
   parse_interface $nic
   if ifup $interface; then
+sleep 50
    if ping -Ac1 $SERVER; then
     ${checked_server:-check_server}
    else

After testing, the ethernet interface which I have used to test NETWORK down. 
Comment 9 Rob Landry 2004-08-12 11:32:17 EDT
-15 will have the same problem; 0.9-14.8k on the other hand should
resolve.  The patch above doest not tak into account the 8k changes. 
If I could get either feedback on changes that work to 8k or a
"redhat-ready -d" run on 8k to attempt to figure out where it's
failing that would help.
Comment 10 IBM Bug Proxy 2004-08-13 07:05:10 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-13 07:01 -------
we failed to NETWORK test on version rhr2-0.9-15 on abassi.upt.austin.ibm.com
(p615). Test server is indralp2.upt.austin.ibm.com(ip:9.3.111.125).


fyi:   
Cleaning scratch space (/tmp/rhr).
Checking/configuring environment... root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
nfsd: last server has exited
nfsd: unexporting all filesystems
root@9.3.111.125's password: 
ip_tables: (C) 2000-2002 Netfilter core team
Prep stage completed.
Press return to continue or control-c to quit

Starting interactive tests... Interactive stage completed.
 Starting NETWORK test... ip_tables: (C) 2000-2002 Netfilter core team
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
root@9.3.111.125's password: 
Comment 11 IBM Bug Proxy 2004-08-13 07:40:05 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-13 07:37 -------
I found that the file "authorized_keys" on client and server is different. 
Just FYI:

on client abassi:
=========================================================
[root@abassi root]# ls -l .ssh/
total 8
-rw-------    1 root     root          616 Aug 13 04:36 authorized_keys
-rw-r--r--    1 root     root          672 Aug 13 04:27 known_hosts

on server indralp2:
=========================================================
[root@indralp2 root]# ls -l .ssh/authorized_keys 
-rw-r--r--    1 root     root          242 Aug  4 07:06 .ssh/authorized_keys 
Comment 12 Rob Landry 2004-08-13 10:38:19 EDT
-15 will fail the static race condition as stated above.  Simply
cleaning ~/.ssh for the RHRUSER should correct the password issue.
Comment 13 IBM Bug Proxy 2004-08-16 02:30:49 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-16 02:27 -------
1. install rhr2-server on one box which been used as server
2. run NETWORK test on one box as client.
3. the client request user to input password more times.
I check the file "NETWORK". FYI

==================================================
 check_server(){
  if ssh_command "rpm -q rhr2-server"; then
   net_cleanup
  checked_server=true
 else
   message "rhr2-server package not found on server; trying alternate code  
path"
   install_ssh_keys
   check_server_release || message "$SERVER is not running a supported  
release"
   net_cleanup
  checked_server=true
 fi
} 
Comment 14 IBM Bug Proxy 2004-08-16 02:50:50 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-16 02:48 -------
I run NETWORK test on version rhr2-0.9-15 on jord.upt.austin.ibm.com (GA1). 
Test server is zeus.upt.austin.ibm.com.

1. run NETWORK test on one box as client.(Attention: the box which be used as 
server do NOT install rhr2-server).
2. NETWORK test report [error].
3. install rhr2-server on box which been used as server
4. run NETWORK test on client again.
5. Needn't input password more times, the test report [OK] 
Comment 15 IBM Bug Proxy 2004-08-16 04:20:59 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-16 04:20 -------
I open another bug#10609 to track the problem:Requesting user to input 
password many times.
Made a few errors in my previous post four comments(From comment#12 to 
comment#15), they are relate with bug10609.Sorry for that.because I think 
inputting password many times is a different problem. 

Comment#11 is the last one about this problem. 
Comment 16 IBM Bug Proxy 2004-08-17 16:06:17 EDT
----- Additional Comments From khoa@us.ibm.com  2004-08-17 16:05 -------
Luciano - any update on this bug ? 
Comment 17 IBM Bug Proxy 2004-08-18 05:51:31 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-18 05:48 -------
I run NETWORK test version rhr2-0.9-15 on cupidlp1.upt.austin.ibm.com(power5 
L4, RHEL3 U3 Beta, Released at 08/13). Test server is 
apollolp2.upt.austin.ibm.com. 
NETWORK test still error. after adding a "sleep 50" as the following, and re-
runing the NETWORK test will report success.FYI

===================================================================
-- NETWORK.BAK 2004-08-11 22:40:28.000000000 -0400
+++ /usr/share/rhr/tests/NETWORK        2004-08-11 22:41:43.000000000 -0400
@@ -36,6 +36,7 @@
  for nic in $@; do
   parse_interface $nic
   if ifup $interface; then
+sleep 50
    if ping -Ac1 $SERVER; then
     ${checked_server:-check_server}
    else

After testing, the ethernet interface which I have used to test NETWORK down. 
Comment 18 IBM Bug Proxy 2004-08-21 07:01:52 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-21 07:00 -------
The firmware of fsp-neptoon is updated to fips220/b0819a_0434.220. Running 
rhr2-0.9-15 NETWORK test on neptoonlp1(SF4, ISO0813: 2.4.21-19.EL).
NETWORK test still error. after adding a "sleep 50" as above, and re-
runing the NETWORK test will report success. 
Comment 19 IBM Bug Proxy 2004-08-24 12:42:24 EDT
----- Additional Comments From marksmit@us.ibm.com  2004-08-24 12:38 -------
CSDL, I got these email instructions from Rob Landry:

>If adding sleeps is resolving you're problem then -14k is the test package
>to use (available on people.redhat.com/rlandry/rhr2/test).  If this does
>not resolve the problem I'd like to get a copy of the debug output.  
>Debug output can be gathered by adding "-d" flag to redhat-ready and in
>this case running adventure; only enabling the NETWORK test; then running
>resolution; the resulting package will include the debug out required.  
>As a note I should mention that using the "-d" flag due to the additional
>logging will cause all tests to show failure regardless of actual outcome.
>Feel free to use the Red Hat bugzilla; I'm not certain of the LTC
>interconnects but if it's the same bug it would be helpful to track this
>all in one place.
>
>-Rob 
Comment 20 IBM Bug Proxy 2004-08-24 23:37:36 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-08-24 23:35 -------
we run NETWORK test(version 0.9-14.2) on cupidlp1(ISO0813, 2.4.21-19.EL). The 
server is cupidlp2. it report error firstly. it report [ok] after add two 
line "sleep 50" after line 41 and line 145 as:
40   if ifup $interface; then
     41    if ping -Ac1 $SERVER; then
sleep 50
     42     if ${installed_keys:-install_ssh_keys}; then
     43      local installed_keys=true
     44      service nfs start
     45      net_cleanup
     46     fi
     47    else
     48     warn "$interface could not read $SERVER."
    140 remove_ssh_keys(){
    141  parse_interface $1
    142  until ifup $interface || [ -z $@ ]; do
    143   shift
    144   parse_interface $1
    145  done
sleep 50
    146  ssh -l $RHRUSER -x $SERVER "rm -f ~/.ssh/authorized_keys"
    147  rm -f ~/.ssh/id_dsa ~/.ssh/authorized_keys
    148 }
Because of it's success after modifying the scripts. I don't do debug(-d). If 
you need debug info, Please let me know. I am glad to do it. 
Comment 22 Rob Landry 2004-08-25 13:43:52 EDT
No other release other than -14.8k has any code to handle this
situation.  There's a reference above that -14.8k did not resolve the
problem; can someone who has a machine that demonstrates this problem
please run -14.8k with the "-d" flag and attach the resulting package?
Comment 23 IBM Bug Proxy 2004-09-01 13:39:23 EDT
----- Additional Comments From marksmit@us.ibm.com  2004-09-01 13:40 -------
CSDL, we discovered today that RH has been putting in comments on their side, 
but we are not seeing them here in the "mirror".  That should be fixed today 
and we will get some 8/25 comments. 
Comment 24 IBM Bug Proxy 2004-09-02 08:44:39 EDT
Created attachment 103388 [details]
rhr2-IBM_9111_520-3_results-1.noarch.rpm
Comment 25 IBM Bug Proxy 2004-09-02 08:45:07 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-09-02 08:43 -------
 
network test -d 

    we run NETWORK test(version 0.9-14.8) on bacchuslp3(ISO0813, 2.4.21-19.EL).
The server is minervalp1 twice. firstly we run NETWORK test normally. It's
rusult is directory "0" in packet rpm. Secondly we run test with -d. it's
result is directory "1" in packet rpm. The two test all report [error]. 
Comment 26 IBM Bug Proxy 2004-09-06 04:59:59 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-09-06 04:59 -------
The defect had not been fixed.
    we run NETWORK test(version 0.9-15) on cupidlp1(RHEL3 Update 3 GM ISOs, 
2.4.21-20.EL).The server is cupidlo2. The test report [error]. the following 
is the file error.log:
=====================================================================
[root@cupidlp1 NETWORK]# cat 5/error.log 
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.

WARNING: eth0 could not reach 9.3.117.158.
125+0 records in
125+0 records out
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
Connection to 9.3.117.158 closed.
[root@cupidlp1 NETWORK]# 
Comment 27 Rob Landry 2004-09-07 13:57:18 EDT
Created attachment 103550 [details]
rhrifup fix

Removes extra "return 0"; should enable second stage connection testing for
drivers which report running when infact they are not.
Comment 28 Rob Landry 2004-09-07 13:58:53 EDT
Thanks for the -d run.  The above patch applies to
/usr/share/rhr/tests/NETWORK included in the -14.8k package.
Comment 29 IBM Bug Proxy 2004-09-08 02:05:35 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-09-08 02:02 -------
rlandry, you are welcome.
I applied the above patch to 0.9-14.8k. It works well now. 
    we do NETWORK on neptoonlp2. cupidlp1 is the test server. NETWORK report 
[OK]. we also do NETWORK test on cupidlp1 and cupidlp2. They all report [OK] 
too. I believed that the defect has been fixd. I am waiting a formal rhr2 test 
suite to close this. 
Comment 30 IBM Bug Proxy 2004-09-08 22:05:35 EDT
----- Additional Comments From marksmit@us.ibm.com  2004-09-08 22:07 -------
CSDL, in today's phone conference with RedHat, they explained that a formal 
release of rhr2 with this fix will not come soon.  They did explain that they 
would accept the certification test results when run on the patched rhrifup 
provided by RedHat.  Please proceed to run the certification suite. 
Comment 31 IBM Bug Proxy 2004-09-09 01:45:50 EDT
----- Additional Comments From wangzyu@cn.ibm.com  2004-09-09 01:42 -------
    In 0.9-14.8k, the GUI of redhat-ready don't display "[ ]INFO" option! I 
only select "[X]NETWORK"! But the script consider I have selected both of 
them! it seems that it is a default selected! I suspect that there have some 
wrong! 
    There have NOT the problem in 0.9-15. 
Comment 32 Rob Landry 2004-09-14 10:50:03 EDT
INFO has been integrated into the automated runs (noted in the Release
Notes); this was done to avoid getting results without a supporting
hardware description.
Comment 35 IBM Bug Proxy 2005-03-24 16:41:23 EST
---- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2005-03-24 16:35 EST -------
Can someone update this bug as to where this problem is? Can we move the state
of the bug to ACCEPTED or FIXAWAITINGTEST or close it if the fix has been
delivered in an official release? Thanks. 
Comment 36 IBM Bug Proxy 2005-03-25 02:06:22 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|OPEN                        |ASSIGNED
             Impact|------                      |Functionality




------- Additional Comments From bujunhui@cn.ibm.com  2005-03-25 02:04 EST -------
I looked through the above comments. and I also did the rhr test on a RHEL3 
U4GM kernel. As a result, I didn't met similar problems mentioned. 
So I would like to close this bug. If we recreate this issue in later testing, 
we should reopen this bug. 

------------------------------------------------
MachineName: plinuxt8b.cn.ibm.com
RHEL3 U4 kernel: 2.4.21-27.EL
RHR Version: rhr2-0.9-14.2 
Comment 37 Rob Landry 2005-04-14 14:07:55 EDT
closing based on previous comment

Note You need to log in before you can comment on or make changes to this bug.