Bug 123673 - gpdf very slow
gpdf very slow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpdf (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 18:33 EDT by Gérard Milmeister
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 09:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2004-05-19 18:33:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.13

Description of problem:
For most documents gpdf takes very long to display (> 20s). Sometimes
the document isn't displayed at all, gpdf simply hangs. xpdf display
almost immediately (< 2s), and also Acrobat Reader is much faster.

Version-Release number of selected component (if applicable):
gpdf-0.131-2

How reproducible:
Always

Steps to Reproduce:
Use gpdf to open a pdf of size > 1M.

Additional info:
Comment 1 Zack Cerza 2004-06-30 16:18:55 EDT
gpdf-0.131-2 took about 5s to open a 15M pdf here. xpdf and ggv took
about the same. Didn't try acroread.
Comment 2 Rudi Chiarito 2004-07-21 19:19:13 EDT
I see the same problem. The initial page of a 2.4MB document of 168
pages renders in one second when loaded with xpdf, while gpdf shows a
blank window for a whole four seconds. Ggv is somewhere inbetween
(maybe with a larger and more complex file it would be clearer where
it really stands)

In case anyone wants to reproduce the problem, here is the document:

http://ptolemy.eecs.berkeley.edu/papers/03/ptIIDesignSoftware/ptIIdesign2-software.pdf

There is a bug upstream which might be related, along with a
preliminary patch in CVS:

http://bugzilla.gnome.org/show_bug.cgi?id=137439
Comment 3 Marco Pesenti Gritti 2004-10-13 09:48:32 EDT
ptIIdesign2-software.pdf is displayed very quickly with 2.8.0 (~1
sec). I think that's because part of the work (bookmarks and
thumbnails) is now done async.

If you still see the issue feel free to reopen this.

Note You need to log in before you can comment on or make changes to this bug.