Bug 123682 - K Menu cannot be edited
K Menu cannot be edited
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 123857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 19:38 EDT by Flavio Cardone
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-05 06:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Cardone 2004-05-19 19:39:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I just installed Fedora Core 2 and I am using KDE. When I right click
on the "K" icon (bottom, left) I can open the "Menu Editor". If I try
to add another program to the "internet" menu, it shows that the
program is being added. After the Menu Editor is closed and the
options saved, the program does not show on the list. Tried adding the
program and then manually saving before closing. Program still was not
added. However, if I *edit* an already existing program - changing the
icon, the name, and the command - then the change is saved.

Version-Release number of selected component (if applicable):


How reproductible:
Always

Steps to Reproduce:
1.open menu editor
2.add a new program
3.close medu editor and save
4.access the menu - the program will not be there
    

Actual Results:  The program was not added to the menu

Expected Results:  The program should been added to the menu

Additional info:
Comment 1 Flavio Cardone 2004-05-20 07:59:17 EDT
duplicate bug of another bug - solution is deleting the .config
directory in one's home directory. However, since the problem comes
with the installation of FC2, IMHO it's still something that ought to
be solved
Comment 2 Ngo Than 2004-05-20 08:50:23 EDT
it looks like there are some broken xml files under $HOME/.config,
which caused this problem.

Yes, deleting of .config directory is a workaround for that.

I don't think it's a bug in KDE, but perhaps i guess it could be in
some gnome applications, which could created some broken xml files there.

Have you started any gnome applications before? It would be nice if
you could give me a testcase, how i can reproduce this problem


Comment 3 Flavio Cardone 2004-05-20 09:41:32 EDT
You see, the K Menu was working OK until I installed FC2, it was only
after that install that it stopped working. The only way to reproduce
it would be to have a computer with FC1 and then install on that FC2.
But IMHO as you know, that install takes almost four hours... The FC2
install, however, does change the start menu (I had originally FC1
with the newest KDE - I think it's 3.2) so probably the broken XML
files come from the FC2 install disks...
Comment 4 Flavio Cardone 2004-05-20 09:42:55 EDT
... and BTW, no, I didn't start any gnome application, I just
installed FC2, noticed that Firefox was no longer in the K Menu, tried
to add it, and it was impossible...
Comment 5 Ngo Than 2004-05-21 10:17:46 EDT
*** Bug 123857 has been marked as a duplicate of this bug. ***
Comment 6 Marcus Willander 2004-05-25 07:18:29 EDT
When you add the program whos supose to be in the internet category  
or some were else it's placed in $/HOME/.local/share/applications  
move it from there to $/HOME/.kde/share/applnk/Internet and it works.  
I have no .config directory and i have done a fresh install of core2 
so that's not the case of the bug.   
Comment 7 André Johansen 2004-06-09 03:12:32 EDT
I've experienced the same problem; the K menu system is really 
fubared in FC2.  My machine has a fresh FC2 install, but the home 
directory is old. 
 
Not only doesn't new applications show up; if you move some 
applications, they disappear... 
 
I don't have Gnome installed, but might have run applications using 
Gnome libraries. 
 
If the workarounds mentioned doesn't work, I assume installing a 
vanilla KDE version will work, as I've been running 3.2.2 without 
trouble in FC1. 
 
(Bug 124515 and bug 124719 are probably duplicates of this one.) 
 
Comment 8 Ngo Than 2004-07-05 06:02:44 EDT
it seems that it's fixed in KDE 3.3 Beta1. It works fine for me with
3.3 Beta 1.
Comment 9 Alexey Neyman 2004-07-23 13:04:10 EDT
Running FC2 "as it is" (3.2.2). 
 
I just found that the .desktop file for a newly added icon in K-Menu 
is created, for example, as 
 
"~/.local/share/applications/Acrobat Reader.desktop" 
 
while the expected location is, apparently 
 
"~/.kde/share/applnk/Office/Acrobat Reader.desktop" 
 
Moving the .desktop file to .kde/share/applnk/.... and rerunning 
kbuildsycoca makes the icon appear in the K Menu. 
 
Ngo, could you indicate where the .desktop file is created by KDE 
3.3b1? 
Comment 10 Ngo Than 2004-07-27 04:43:03 EDT
Alexey, the desktop files should be installed in
/usr/share/applications/kde/
Comment 11 Alexey Neyman 2004-07-27 04:51:07 EDT
Nope, I meant private (non system-wide) settings. If a user edits 
his own KDE settings, system-wide directory (/usr/share/...) is not 
affected). 
Comment 12 Ngo Than 2004-07-28 05:52:23 EDT
kde looks for the non system-wide settings in
~/.local/share/applications/, but ~/.kde/share/applnk/ still works
with 3.3

Note You need to log in before you can comment on or make changes to this bug.