Bug 123684 - setting up logical volume management: vgscan status code
setting up logical volume management: vgscan status code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 20:39 EDT by Marco Varanda
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 13:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Varanda 2004-05-19 20:39:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When starting up a system in a default configuration the
following shows up:
.....
Activating swap partitions:                                [  OK  ]
Remounting root filesystem in read-write mode:             [  OK  ]

Setting up Logical Volume Management: No volume groups found
  No volume groups found
  Reading all physical volumes.  This may take a while...
                                                           [FAILED]


Version-Release number of selected component (if applicable):
lvm2-2.00.15-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 with Raid1 (logical)
2. First boot will happen
3.
    

Actual Results:  The boot message error

Additional info:

Athlon XP 2000+
Soyo KT 266A
512 MB RAM
02 HDs RAID1 - 120 GB
Comment 1 Stephen Tweedie 2004-05-20 08:24:43 EDT
I'm not quite sure where the problem is here --- initscripts shouldn't
be trying to do an LVM scan if there's no LVM in use, but the loading
of the initial LVM module is mkinitrd's decision so there could be
trouble there too.
Comment 2 Alasdair Kergon 2004-05-20 08:53:32 EDT
vgscan returns an error code if there are no volume groups present...
reported on the linux-lvm mailing list a few days ago

I'll fix it
Comment 3 Alasdair Kergon 2004-05-26 11:34:13 EDT
Fixing in 2.00.15-3
Comment 4 Jarkko 2004-06-23 00:21:20 EDT
Jep, it no longer says FAILED. It says "setlocale failed" though. I'm
using version: lvm2-2.00.15-5

What setlocale? Can you fix that?
Comment 5 Marco Varanda 2004-06-23 09:20:23 EDT
I run yum update, but don't fix this problem, than I comment many
lines with "lvm" in /etc/rc.d/rc.sysinit
I don't know if this process is better, but stop the error.
Comment 6 Marco Varanda 2004-09-28 00:09:41 EDT
------- Additional Comment #2 From Alasdair Kergon (agk@redhat.com) 
on 2004-05-20 08:53 ------- 

vgscan returns an error code if there are no volume groups present...
reported on the linux-lvm mailing list a few days ago

I'll fix it

=====================================================================
Thanks Alasdair Kergon, but not yet corrected (09/27/2004)
I update all packages (with yum) inclusive initscripts

I installed FC2 (Raid1 - 2HDs 120 GB) on the 1st boot
I can see the error, than I upgrade all packages, but
continued display error message




Comment 7 Alasdair Kergon 2004-09-28 08:46:40 EDT
Specifically with what package versions?
And what disk configuration?

(I can't reproduce the problem.)
Comment 8 Marco Varanda 2004-09-28 12:55:39 EDT
First of all, thanks for your job and help


initscripts 7.55.1-1.i386
kernel 2.6.8-1.521.i686

  LVM version:     2.00.15 (2004-04-19)
  Library version: 1.00.14-ioctl (2004-04-06)
  /dev/mapper/control: open failed: No such device
  Is device-mapper driver missing from kernel?

note: I think lvm2-2.00.15-5 - is not available from
yum upgrade
(which packages do you need ?)

Hardware:
Athlon XP 2000+ (motherboard Soyo DragonPlus KT266A)
2 HDs Seagate 120 GB IDE

Personalities : [raid1]
md1 : active raid1 hda2[0] hdc2[1]
      116101632 blocks [2/2] [UU]

md2 : active raid1 hda3[0] hdc3[1]
      1011968 blocks [2/2] [UU]

md0 : active raid1 hda1[0] hdc1[1]
      104192 blocks [2/2] [UU]

unused devices: <none>

=====================================

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   fd  Linux raid 
autodetect
/dev/hda2              14       14467   116101755   fd  Linux raid 
autodetect
/dev/hda3           14468       14593     1012095   fd  Linux raid 
autodetect


=========================================================

   Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1          13      104391   fd  Linux raid 
autodetect
/dev/hdc2              14       14467   116101755   fd  Linux raid 
autodetect
/dev/hdc3           14468       14593     1012095   fd  Linux raid 
autodetect
Comment 9 Alasdair Kergon 2004-09-28 13:19:59 EDT
So you're running an LVM2 version from before it got fixed:-)

http://download.fedora.redhat.com/pub/fedora/linux/core/test/
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

Note You need to log in before you can comment on or make changes to this bug.