Bug 123722 - nfs-utils has no_acl patch turned off in FC2
nfs-utils has no_acl patch turned off in FC2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 06:26 EDT by Mukund
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-20 07:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mukund 2004-05-20 06:26:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The nfs-utils package has the patch to disable ACLs for older NFSv3
clients turned off. There's an if statement in the spec file which
only enables it for RHEL3.

Is there any technical reason why this was enabled only for RHEL3
builds and is disabled in FC2? If so what is the issue related to it?
We build the Openfiler project on top of FC2 and while we do supply
replacement RPMS, it'd be nice to have the upstream itself
incorporating this.

On speaking to Arjan he said I should file a bug because it may have
been an oversight.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The following is from the .spec file

%if %{rhel3build}
%patch4 -p1 -b .aclexp
%endif



Additional info:
Comment 1 Steve Dickson 2004-05-20 07:27:10 EDT
No... this was not an oversight... 

It came down to 1) I didn't think the NFSACL would be fully
baked at release time 2) I simply didn't have time to test it.

Note You need to log in before you can comment on or make changes to this bug.