Bug 123723 - Broken Build-Tools
Broken Build-Tools
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: automake (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 06:27 EDT by Jochen Witte
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 11:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configue.in used by aclocal (10.96 KB, text/plain)
2004-05-22 05:46 EDT, Jochen Witte
no flags Details

  None (edit)
Description Jochen Witte 2004-05-20 06:27:21 EDT
Description of problem:
The build-tools are broken:

---snip---
$ sh reconf
- aclocal.
/usr/share/aclocal/vorbis.m4:9: warning: underquoted definition of
XIPH_PATH_VORBIS
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending%20aclocal
/usr/share/aclocal/pkg.m4:5: warning: underquoted definition of
PKG_CHECK_MODULES
/usr/share/aclocal/pilot-link.m4:1: warning: underquoted definition of
AC_PILOT_LINK_HOOK
/usr/share/aclocal/ogg.m4:8: warning: underquoted definition of
XIPH_PATH_OGG
/usr/share/aclocal/oaf.m4:4: warning: underquoted definition of
AM_PATH_OAF
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of
AM_PATH_NSPR
/usr/share/aclocal/linc.m4:1: warning: underquoted definition of
AM_PATH_LINC
/usr/share/aclocal/librsvg.m4:11: warning: underquoted definition of
AM_PATH_LIBRSVG
/usr/share/aclocal/libole2.m4:18: warning: underquoted definition of
AM_PATH_LIBOLE2
/usr/share/aclocal/libmikmod.m4:11: warning: underquoted definition of
AM_PATH_LIBMIKMOD
/usr/share/aclocal/libguppi.m4:11: warning: underquoted definition of
AM_PATH_LIBGUPPI
/usr/share/aclocal/libglade.m4:7: warning: underquoted definition of
AM_PATH_LIBGLADE
/usr/share/aclocal/libart.m4:11: warning: underquoted definition of
AM_PATH_LIBART
/usr/share/aclocal/libIDL.m4:6: warning: underquoted definition of
AM_PATH_LIBIDL
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of
AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of
AM_PATH_GDK_IMLIB
/usr/share/aclocal/gtk.m4:7: warning: underquoted definition of
AM_PATH_GTK
/usr/share/aclocal/glib.m4:8: warning: underquoted definition of
AM_PATH_GLIB
/usr/share/aclocal/gdk-pixbuf.m4:12: warning: underquoted definition
of AM_PATH_GDK_PIXBUF
/usr/share/aclocal/gconf-2.m4:8: warning: underquoted definition of
AM_GCONF_SOURCE_2
/usr/share/aclocal/gconf-1.m4:4: warning: underquoted definition of
AM_PATH_GCONF
/usr/share/aclocal/gconf-1.m4:71: warning: underquoted definition of
AM_GCONF_SOURCE
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of
AM_PATH_AUDIOFILE
/usr/share/aclocal/ORBit.m4:4: warning: underquoted definition of
AM_PATH_ORBIT
Can't locate object method "path" via package "Request" at
/usr/share/autoconf/Autom4te/C4che.pm line 69, <GEN1> line 112.
aclocal: autom4te failed with exit status: 1
- autoconf.
Can't locate object method "path" via package "Request" at
/usr/share/autoconf/Autom4te/C4che.pm line 69, <GEN1> line 112.
- autoheader.
Can't locate object method "path" via package "Request" at
/usr/share/autoconf/Autom4te/C4che.pm line 69, <GEN1> line 112.
autoheader: /usr/bin/autom4te failed with exit status: 1
- automake.
Can't locate object method "path" via package "Request" at
/usr/share/autoconf/Autom4te/C4che.pm line 69, <GEN1> line 112.
automake: autoconf failed with exit status: 1

---snip---

Version-Release number of selected component (if applicable):
automake 1.8.3
autoconf 2.59

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jens Petersen 2004-05-21 02:57:36 EDT
Can you please explain exactly how to reproduce this?

What program/package are you trying to build when this happens?
Comment 2 Jochen Witte 2004-05-22 05:46:48 EDT
Created attachment 100449 [details]
configue.in used by aclocal
Comment 3 Jochen Witte 2004-05-22 05:48:27 EDT
OKOK this was a quckshot while upgrading from FC1. But the warnings
with aclocal resist:

---snip---
- aclocal.
/usr/share/aclocal/wxwin.m4:36: warning: underquoted definition of
AM_OPTIONS_WXCONFIG
  run info '(automake)Extending aclocal'
  or see
http://sources.redhat.com/automake/automake.html#Extending%20aclocal
/usr/share/aclocal/wxwin.m4:59: warning: underquoted definition of
AM_PATH_WXCONFIG
/usr/share/aclocal/vorbis.m4:9: warning: underquoted definition of
XIPH_PATH_VORBIS
/usr/share/aclocal/pkg.m4:5: warning: underquoted definition of
PKG_CHECK_MODULES
/usr/share/aclocal/pilot-link.m4:1: warning: underquoted definition of
AC_PILOT_LINK_HOOK
/usr/share/aclocal/ogg.m4:8: warning: underquoted definition of
XIPH_PATH_OGG
/usr/share/aclocal/oaf.m4:4: warning: underquoted definition of
AM_PATH_OAF
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of
AM_PATH_NSPR
/usr/share/aclocal/lqt.m4:14: warning: underquoted definition of
AC_PATH_LQT
/usr/share/aclocal/linc.m4:1: warning: underquoted definition of
AM_PATH_LINC
/usr/share/aclocal/libole2.m4:18: warning: underquoted definition of
AM_PATH_LIBOLE2
/usr/share/aclocal/libmikmod.m4:11: warning: underquoted definition of
AM_PATH_LIBMIKMOD
/usr/share/aclocal/libglade.m4:7: warning: underquoted definition of
AM_PATH_LIBGLADE
/usr/share/aclocal/libfame.m4:6: warning: underquoted definition of
AM_PATH_LIBFAME
/usr/share/aclocal/libart.m4:11: warning: underquoted definition of
AM_PATH_LIBART
/usr/share/aclocal/libIDL.m4:6: warning: underquoted definition of
AM_PATH_LIBIDL
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of
AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of
AM_PATH_GDK_IMLIB
/usr/share/aclocal/gtk.m4:7: warning: underquoted definition of
AM_PATH_GTK
/usr/share/aclocal/glib.m4:8: warning: underquoted definition of
AM_PATH_GLIB
/usr/share/aclocal/gconf-2.m4:8: warning: underquoted definition of
AM_GCONF_SOURCE_2
/usr/share/aclocal/gconf-1.m4:4: warning: underquoted definition of
AM_PATH_GCONF
/usr/share/aclocal/gconf-1.m4:71: warning: underquoted definition of
AM_GCONF_SOURCE
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of
AM_PATH_AUDIOFILE
/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of
AM_PATH_AALIB
/usr/share/aclocal/ORBit.m4:4: warning: underquoted definition of
AM_PATH_ORBIT
---snip---
Comment 4 David Nečas 2004-05-22 16:55:43 EDT
> OKOK this was a quckshot while upgrading from FC1.

One has to

rm -r autom4te.cache

where it already exists to fix the errors, am I correct?
Comment 5 Jochen Witte 2004-05-24 01:55:58 EDT
Tried this, but it didn't help.
Comment 6 David Nečas 2004-05-24 02:18:01 EDT
I meant just the errors (seem caused by a change in cache data
structures), not the warnings (they should be fixed by properly
quoting the definitions in the m4 files, IMHO). But I might clean also
something else before removing autom4te.cache... make maintainer-clean
should be the right thing to do.
Comment 7 Jochen Witte 2004-05-27 08:18:03 EDT
This is correct. I can now use the build-system...
Comment 8 Jens Petersen 2004-06-06 11:10:59 EDT
Yes that is correct, the warnings are harmless I believe - just
due to underquoting in various older m4 files.

Note You need to log in before you can comment on or make changes to this bug.