Bug 123797 - mozilla 1.6 fails to open when java plugin (part of j2re-1.4.2_04) is registered with web browser
mozilla 1.6 fails to open when java plugin (part of j2re-1.4.2_04) is registe...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 12:42 EDT by Nigel Binns
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-28 04:02:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Binns 2004-05-20 12:42:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Mozilla 1.6 fails to open after the java plugin (part of Sun's Java
Runtime Environment j2re-1.4.2_04) is registered with the web browser.

Registering the plugin is the cause of the problem, as deletion of the
libjavaplugin_oji.so symbolic link from: 

/usr/lib/mozilla-1.6/plugins

/usr/java/j2re1.4.2_04/plugin/i386/ns610/libjavaplugin_oji.so

allows Mozilla to open normally. Java Web Start works fine after its
mime type has been registered in Preferences > Helper Applications.


Version-Release number of selected component (if applicable):
mozilla-1.6-8

How reproducible:
Always

Steps to Reproduce:
1. Install j2re-1_4_2_04-linux-i586-rpm from Sun web site.
2. Register java plugin with Mozilla according to Sun's instructions.
3. Try to open Mozilla.
    

Actual Results:  After clicking on Mozilla via the task bar (beside
the Red Hat icon), the egg timer spins for some time, but Mozilla
fails to open.

Expected Results:  Mozilla should open.

Additional info:

This bug was first encountered by myself in Fedora Core 1 with Mozilla
1.4.1. I had hoped that it would have been resolved with the release
of Fedora Core 2. However, the bug still persists.

This problem does not occur with Red Hat v9.0 running Mozilla v1.2.1
and j2re-1.4.2_04. Java applets open okay from within Mozilla with
this configuration.
Comment 1 Joseph Kelch 2004-05-21 10:15:14 EDT
Having similar problem.  Encountering any page with java causes 
Mozilla to shut down immediately.  Trying to run any java apps from 
the command line also fails, with a problem starting the VM.  Simply 
installed the sun java 1.4.2_04 sdk by rpm, then symlinked 
libjavaplugin_oji.so.  Mozilla about plugins reports its there and 
enabled, but doesn't work.  Fedora Core 2 test 3 with all current 
up2date releases installed.
Comment 2 Eric Hedström 2004-05-24 17:50:11 EDT
You need the plugin from the ns610-gcc32 directory, not the ns610
directory, for newer versions of Mozilla.
Comment 3 Didier 2004-05-26 03:33:35 EDT
Immediate shutdown reproduced with FC2, mozilla-1.6-8, with both
mozilla-j2re-1.4.2-5.1.fc2.dag and Sun's j2re-1.4.2_02-fcs.

Testcase (from a shell) :

$  mozilla https://postbox.be/_login/showLogin.do?language=nl

yields :

INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
 
** (Gecko:24314): WARNING **: Serious fd usage error 19
 
** (Gecko:24314): WARNING **: Serious fd usage error 17
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable



Note 1 : firefox-0.8-0.fdr.11.2 with JRE plugin works fine.
Note 2 : about 1 out of 10 attempts with Mozilla JRE plugin succeeds.

Could this be related to bug #121902 ?
Comment 4 Ben Smith 2004-05-27 22:13:03 EDT
Is this resolved?

As it states clearly in the release notes (since FC1), you must use
the Java plugin from the ns610-gcc32 directory as Fedora is compiled
with gcc-3.2.

If this does not fix the problem, can you please provide more info?
Comment 5 Didier 2004-05-28 03:13:03 EDT
I am using the ns610-gcc32 plugin (manually, through the Sun rpm, and
automatically by using the DAG FC2 repository rpm).

Wat extra info would you like to see ? A 'trace=file' strace ? A full
strace ?

As noted in my comment #3, firefox with plugin seems to work fine.
Comment 6 Nigel Binns 2004-05-28 04:02:31 EDT
Comment #2 resolves this issue: You need the plugin from the ns610-
gcc32 directory, not the ns610 directory, for newer versions of 
Mozilla.

Comment #4 (As it states clearly in the release notes (since FC1), 
you must use the Java plugin from the ns610-gcc32 directory as Fedora 
is compiled with gcc-3.2.) indicates that I should have already known 
this. However, I just followed the manual installation instructions 
for the plugin from Sun's Java site (see extract below), and they 
seem to suggest to me that one should use the plugin from the ns610 
directory - at best it is not unequivocal. Perhaps someone from Sun 
could clarify their documentation.

-----------------------------------------------------------------
From: Manual Installation/Registration of Java Plug-in—Linux (Sun)
-----------------------------------------------------------------

3. For Netscape 6/7 and Mozilla browsers, create a symbolic link to 
the Plug-in in the Netscape plugins directory. 

Create a symbolic link to the Java Plug-in libjavaplugin.so file in 
the Netscape 6/7 or Mozilla plugins directory.

cd <Netscape 6/7 | Mozilla>/plugins
ln -s <JRE>/plugin/i386/ns610/libjavaplugin_oji.so .

For the SuSE 8.1 or higher Mozilla browser, replace ns610 with ns610-
gcc32 in the ln command line above. 

Be sure to include the period at the end.

Note You need to log in before you can comment on or make changes to this bug.