This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123801 - (VM VFS)kswapd0: page allocation failure and ENOMEM in journal_alloc_journal_head messages
(VM VFS)kswapd0: page allocation failure and ENOMEM in journal_alloc_journal_...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 13:02 EDT by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-07 13:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2004-05-20 13:02:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Found the following messsages in /var/log/messages:

May 19 15:51:58 coop00 kernel: kswapd0: page allocation failure.
order:0, mode:0x50
May 19 15:51:58 coop00 kernel:
May 19 15:51:58 coop00 kernel: Call
Trace:<ffffffff80152834>{__alloc_pages+706} <ffffffff8
0152899>{__get_free_pages+76}
May 19 15:51:58 coop00 kernel:       
<ffffffff80155c12>{cache_grow+202} <ffffffff80156131
>{cache_alloc_refill+394}
May 19 15:51:58 coop00 kernel:       
<ffffffff801563aa>{kmem_cache_alloc+52} <ffffffffa00
0728a>{:jbd:journal_alloc_journal_head+18}
May 19 15:51:58 coop00 kernel:       
<ffffffffa0007319>{:jbd:journal_add_journal_head+31}

May 19 15:51:58 coop00 kernel:       
<ffffffffa0001176>{:jbd:journal_dirty_data+48} <ffff
ffffa00154b8>{:ext3:ext3_journal_dirty_data+15}
May 19 15:51:58 coop00 kernel:       
<ffffffffa0015342>{:ext3:walk_page_buffers+94} <ffff
ffffa001579d>{:ext3:journal_dirty_data_fn+0}
May 19 15:51:58 coop00 kernel:       
<ffffffffa00158c7>{:ext3:ext3_ordered_writepage+280}

May 19 15:51:58 coop00 kernel:       
<ffffffff80158aed>{shrink_list+869} <ffffffff80158fb
6>{shrink_cache+712}
May 19 15:51:58 coop00 kernel:       
<ffffffff801585e7>{shrink_slab+132} <ffffffff801325f
a>{autoremove_wake_function+0}
May 19 15:51:58 coop00 kernel:       
<ffffffff80159c9b>{balance_pgdat+385} <ffffffff80159
ede>{kswapd+303}
May 19 15:51:58 coop00 kernel:       
<ffffffff801325fa>{autoremove_wake_function+0} <ffff
ffff801325fa>{autoremove_wake_function+0}
May 19 15:51:59 coop00 kernel:        <ffffffff80111ce7>{child_rip+8}
<ffffffff80159daf>{k
swapd+0}
May 19 15:52:00 coop00 kernel:        <ffffffff80111cdf>{child_rip+0}
May 19 15:52:00 coop00 kernel: ENOMEM in journal_alloc_journal_head,
retrying.

The kswapd0 message and stack trace repeats several times.

The system seems to continue to work fine afterwards.

I think these were triggered by running the bonnie++ benchmark on an
ext3 filesystem.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.358

How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Orion Poplawski 2004-06-07 13:44:22 EDT
Bad hardware - apparently a strange memory issue on a dual processor
Opteron

Note You need to log in before you can comment on or make changes to this bug.