Bug 123835 - KDE 3.2.2 won't start due to shared library error
KDE 3.2.2 won't start due to shared library error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 17:39 EDT by Brian Wright
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 05:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upgrade log that was created before anaconda froze (32.67 KB, text/plain)
2004-05-20 21:24 EDT, Brian Wright
no flags Details
This is the second upgrade log (50.84 KB, text/plain)
2004-05-20 21:27 EDT, Brian Wright
no flags Details

  None (edit)
Description Brian Wright 2004-05-20 17:39:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.13

Description of problem:
Whenever I try to start KDE, I get the following error in my
~/.xession-error file.  This happens for all users on the system:

/etc/X11/xdm/Xsession: line 55: [: too many arguments
XIM DEBUG: xset:  bad font path element (#96), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...
ksplash: error while loading shared libraries:
/usr/lib/qt-3.3/lib/libqt-mt.so.3: undefined symbol:
XkbSetPerClientControls
kdeinit: error while loading shared libraries:
/usr/lib/qt-3.3/lib/libqt-mt.so.3: undefined symbol:
XkbSetPerClientControls
startkde: Could not start kdeinit. Check your installation.
xmessage: error while loading shared libraries:
/usr/X11R6/lib/libXaw.so.7: undefined symbol: XmuCvtGravityToString
Warning: connect() failed: : No such file or directory
ksmserver: error while loading shared libraries:
/usr/lib/qt-3.3/lib/libqt-mt.so.3: undefined symbol:
XkbSetPerClientControls
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.

The correct version of qt is installd for FC2, along with the
xorg-libs package.  No KDE app will start.

GNOME will start up just fine.

When trying to start xterm in failsafe mode (run level 5), I get the
following:

xterm: error while loading shared libraries:
/usr/X11R6/lib/libXaw.so.7: undefined symbol: XmuCvtGravityToString

I'm guessing that there's a package that needs to be installed that
failed to install.




Version-Release number of selected component (if applicable):
kdebase-3.2.2-4

How reproducible:
Always

Steps to Reproduce:
1. Start KDE with startx
2. 
3.
    

Actual Results:  X will start up, but then will crash with the above

Expected Results:  KDE should have started up.

Additional info:

I'm suspecting that a package may not have installed correctly.  When
I did my upgrade to FC2, the anaconda installer froze, and I had to
reboot my system.  It got stuck on the e2progs-devel program.

After I restarted the upgrade, anaconda was able to pick up where it
left off, but it may not have upgraded/installed all the packages that
are needed.

apt-get reported no broken packages though.
Comment 1 Ngo Than 2004-05-20 18:25:07 EDT
yes, it looks like that many packages are not correctly upgraded on
your machine!

First you have to find out which packages are not correctly installed
and then upgrade them with --force.

anyway it's not a bug in KDE


Comment 2 Brian Wright 2004-05-20 21:24:02 EDT
Created attachment 100407 [details]
Upgrade log that was created before anaconda froze

This was the first upgrade log that was created before the anaconda installer
froze and hung the machine.
Comment 3 Brian Wright 2004-05-20 21:27:57 EDT
Created attachment 100408 [details]
This is the second upgrade log

This is the upgrade log that was created after I had to reboot the machine.
Comment 4 Ngo Than 2004-05-21 05:56:12 EDT
as i have said before, there are some packages, which have not been
correctly installed on your machine. That caused this problem.

to fix this problem, first you have to find out which packages are not
correctly installed and then upgrade them with --force.

for example: xorg.x11 and all qt/KDE packages

if anaconda froze on your machine, it's a anaconda bug, but not KDE!

Note You need to log in before you can comment on or make changes to this bug.