Bug 123839 - (PATCH)autorun on FC2 CDs looks for redhat-cdinstall-helper
(PATCH)autorun on FC2 CDs looks for redhat-cdinstall-helper
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-release (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 122112 124874 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 17:57 EDT by Brian Wheeler
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 18:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Wheeler 2004-05-20 17:57:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
The autorun file on the FC2 cds specified redhat-cdinstall-helper and
this package provides system-cdinstall-helper - the redhat variation
isn't on the system.



Version-Release number of selected component (if applicable):
system-config-packages-1.2.12-1

How reproducible:
Always

Steps to Reproduce:
1.  Place FC2 cd into drive
2.  click on autorun
3.
    

Actual Results:  Nothing

Expected Results:  the cd helper should start.

Additional info:

I suspect that autorun script should be updated to be:
---------------------------------------------
#!/bin/sh
#
# Autorun script for Red Hat Linux
# Copyright (c) 1999-2002 Red Hat, Inc.
 
dir=$(echo $0 |sed 's/autorun//')
cd $dir
tree=$(pwd)
 
# Change directories so we can unmount the CD-ROM Drive
cd /
if [ -e /usr/sbin/system-cdinstall-helper $tree ] ; then
    exec /usr/sbin/system-cdinstall-helper $tree
else
    exec /usr/sbin/redhat-cdinstall-helper $tree
fi
-------------------------------
Or perhaps redhat-cdinstall-helper should be a symlink to
system-cdinstall-helper.
Comment 1 Miloslav Trmac 2004-05-21 10:31:44 EDT
*** Bug 122112 has been marked as a duplicate of this bug. ***
Comment 2 Elliot Lee 2004-05-26 18:34:05 EDT
Fixed in the CVS for future redhat-release/fedora-release packages.
Comment 3 Miloslav Trmac 2004-06-02 09:39:37 EDT
*** Bug 124874 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.