Bug 123841 - Unable to burn cd's with USB-2.0 CD-Writer
Unable to burn cd's with USB-2.0 CD-Writer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 18:04 EDT by Brian Pepple
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 08:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Systme log from cdrecord -scanbus (3.84 KB, text/plain)
2004-05-20 18:05 EDT, Brian Pepple
no flags Details

  None (edit)
Description Brian Pepple 2004-05-20 18:04:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Unable to burn cd's with external USB-2.0 Pacific Digital X-Treme-16
cd-rewriter.  This cd-burner worked fine with the 2.4 kernels on prior
Redhat installs.  I'm able to mount the drive, while it has data  cd's
in it, but am unable to burn with it.  I've attemped to burn a cd with
cdrecord, and using the Nautilus CD-Creator.  The hardware browser
recogizes this cd-burner as:

Device = Lite-on LTR-16102B
Manufacturer = Lite-on
Driver = none or built-in
Device = /dev/scd0

When I connect the drive I get the following message in my system log:

May 20 15:55:38 hp kernel: usb 1-2: new high speed USB device using
address 3
May 20 15:55:38 hp kernel: scsi1 : SCSI emulation for USB Mass Storage
devices
May 20 15:55:39 hp kernel:   Vendor: LITE-ON   Model: LTR-16102B     
  Rev: OS0E
May 20 15:55:39 hp kernel:   Type:   CD-ROM                          
  ANSI SCSI revision: 02
May 20 15:55:43 hp kernel: sr0: scsi3-mmc drive: 50x/40x writer cd/rw
xa/form2 cdda tray
May 20 15:55:43 hp scsi.agent[9195]: cdrom at
/devices/pci0000:00/0000:00:1e.0/0000:01:0e.2/usb1/1-2/1-2:2.0/host1/1:0:0:0

cdrecord -scanbus output the following:
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Warning: Using badly designed ATAPI via /dev/hd* interface.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c       
1.80 04/03/08 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'SAMSUNG ' 'CD-ROM SC-140   ' 'FT02' Removable CD-ROM
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *

My internal cd drive (Non-writable) in the hardware browser is (if
this helps):

Device: Samsung CD-ROm CD-140
Manufacturer: Samsung
Driver: None
Device: /dev/hdc

This drive hasn't been recognized under Redhat, since around RH-7.x. 
When I run cdrecord -scanbus, the first time I get some system log
errors which deal with my internal cd drive.  Please refer to the
attachment.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect drive, and turn on.
2. Use cdrecord, or Nautilus CD-Creator to attempt to burn a disc.
3.
    

Actual Results:  When using the Nautilus CD-Creator, I get the folling
error message:

cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: No such file or directory. Cannot open '/dev/sg*'. Cannot
open SCSI driver.
scsibus: 1 target: 0 lun: 0
scsidev: '1,0,0'
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
cdrecord: Continuing in 5 seconds...
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Asuming -tao mode.
cdrecord: No write mode specified.

It looks like that Nautilus is attempting to burn a disc with my
internal cd-drive (based on the SCSI id), even though it's not a
cd-writer.

Expected Results:  Burns the cd.

Additional info:
Comment 1 Brian Pepple 2004-05-20 18:05:16 EDT
Created attachment 100395 [details]
Systme log from cdrecord -scanbus
Comment 2 Harald Hoyer 2004-05-24 06:39:44 EDT
does 
# cdrecord dev=/dev/scd0
work?
Comment 3 Brian Pepple 2004-05-24 07:45:20 EDT
I'm able to burn a disc using:

cdrecord dev=/dev/cdrom1

I'm still unable to play audio cd's with either drive, though.

Note You need to log in before you can comment on or make changes to this bug.