Bug 123859 - Anaconda forces reboot upon error
Anaconda forces reboot upon error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 20:11 EDT by An. N
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-08 14:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description An. N 2004-05-20 20:11:17 EDT
Description of problem:
Anaconda forces the user to reboot upon encountering a problem (ie.
with package intallation). Often though, the problem can be resolved
from the console and the installation might continue upon retrying the
failed installation.

Version-Release number of selected component (if applicable):
Fedora Core 2 installer

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
User has to restart installation all over again

Expected results:
Dialog box offering at least the options to retry the failed
installation or to reboot (possibly also "view error messages")

Additional info:
A real-life example: there were some links to non-exisant man files on
my system (they served a purpose). Anaconda tried to install some man
pages, didn't find the dirs, failed. I removed the empty links from
the console, but had to reboot and start from the beginning anyway.
Comment 1 Luke Reeves 2004-05-25 06:05:58 EDT
This same problem just hit me, although I saw no actual error message
on screen - how did you know what the problem was (the man links)?
Comment 2 An. N 2004-05-25 07:05:54 EDT
I noticed a failed package in the upgrade log (when I rebooted back to
Fedora 1). I tried to install it manually off the CD and either rpm
reported an error or I straced rpm, I don't remember. I fixed the
link, installed the new package and rebooted to start the upgrade over
again.
Comment 3 Ben Klaas 2004-06-07 15:46:56 EDT
I'm running into this bug repeatedly, and it's fairly infuriating.
Personally, I think not having a "continue installation" option after
a package install failure is terrible and soooo un-linux like.

I'm not alone in this feeling...
http://www.fedoraforum.org/forum/showthread.php?s=&postid=17814#post17814

I'd love to see this bug at a higher severity and priority.


Comment 4 Jeremy Katz 2004-06-08 14:56:47 EDT
Unfortunately, with the way that transaction handling works, this
isn't really very viable.  Additionally, *not* halting the
installation could leave you in a much worse situation than the
current case.
Comment 5 Ben Klaas 2004-06-09 14:05:23 EDT
>Additionally, *not* halting the installation could leave you in a much
>worse situation than the current case.

Respectfully, I must disagree. How can I have a worse situation than a
machine with no working OS and no ability to get through the install?
Previous to trying to put FC2 on my machine, I had a fully working RH9
install. Now, after a dozen+ attempts, I have nothing.

If I can't install the postgres-test rpm (for example), this means
that the installer can't continue? Wowzer.



Comment 6 An. N 2004-06-09 14:31:09 EDT
While I deeply trust that the Fedora team knows very well what it's
doing, I have to say I agree with Ben Klaas. It is important for many
users who customize their systems to have at least the opportunity to
retry the failed rpm installation, leave alone the "don't install it
at all" option. Often the issue can be resolved with one or two
commands from the console, and I certainly hope that the way anaconda
is built will make such a simple operation possible.
Comment 7 Michael De La Rue 2004-09-02 12:11:17 EDT
Whilst I agree with the comments that an installation shouldn't be
allowed to go forward since there is a very high risk that something
went wrong for a reason which has already caused many problems, it's a
complete pain to lose the ability to easily troubleshoot why a problem
may have happened.  E.g. did the swap come on correctly; is there lots
of free memory, is there disk space free; is some process running out
of control etc.

Note You need to log in before you can comment on or make changes to this bug.