Bug 123865 - Symlink missing for libelf.so
Symlink missing for libelf.so
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-20 21:01 EDT by Chris Colohan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 07:41:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Colohan 2004-05-20 21:01:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The installed library libelf.so.1 is missing a symlink which allows
you to compile new programs which link against it.

In particular, if I compile a program foo.c, the following will fail:

  gcc foo.c -lelf

A workaround can be done as follows:

  cd /usr/lib
  ln -s libelf.so.1 libelf.so

...but it would be much nicer if the RPM for this installed properly
in the first place.  :-)

Version-Release number of selected component (if applicable):
elfutils-libelf-0.95-2

How reproducible:
Always

Steps to Reproduce:
1.  Install Fedora Core 2
2.  Try to compile any program that links to libelf with -lelf

    

Actual Results:  Compile fails due to missing library.

Expected Results:  Compile should work.

Additional info:
Comment 1 Jeff Johnson 2004-08-23 07:41:43 EDT
The symlink is in the elfutils-libelf-devel-0.96-1 package.

Install elfutils-libelf-devel.

Note You need to log in before you can comment on or make changes to this bug.