Bug 123884 - (RFE) allow user to specify RPM package version to install to yum
(RFE) allow user to specify RPM package version to install to yum
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 07:05 EDT by Sitsofe Wheeler
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 22:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-05-21 07:05:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I have added the jpackage yum repository to my Fedora Core 2
installation so that I may use their version of ant. However, since
ant is provided by the base yum repository I am now left with a
problem since that is the version of ant that will be installed by
default. I would like to specify the version of ant I want to install
but the yum man page is not clear on how to do this:

yum install ant#1.5.4-2jpp
yum install ant-0-1.5.4
yum install ant-0-1.5.4-2jpp.noarch
yum install ant-1.5.4-2jpp

all failed.

yum knows there are two versions since a yum list ant shows both of them.

Version-Release number of selected component (if applicable):
yum-2.0.7-2.fc.fr

How reproducible:
Always

Steps to Reproduce:
(As root) 
1. Add the following to your yum.conf
[jpackage]
name=Jpackage
baseurl=http://mirrors.sunsite.dk/jpackage/1.5/generic/free
2. yum update
3. Try and use yum and install the jpackage ant rather than the fedora
version. 
    

Actual Results:
Even after reading the yum man page I could not work out how to do this.

Expected Results:  To be able to use yum to install a particular
version of an RPM when more than one is available. Otherwise people
like jpackage are going to be forced to rename RPMs each time Fedora
releases an RPM with the same name :(
Comment 1 Seth Vidal 2004-05-21 10:59:26 EDT
it's not possible to specify a version one the command line in yum.

Comment 2 Jeff Johnson 2004-06-09 22:14:55 EDT
That sounds like WONTFIX to me. You can always download
a specific version of a package and install using rpm.
Comment 3 Sitsofe Wheeler 2004-06-10 03:31:24 EDT
Why was this closed WORKSFORME? If you add the jpackage yum source and
then try and install the jpackage ant I'm sure you won't find it
doesn't WORKFORYOU! It sounds like you mean WONTFIX...

Yes, it is possible to use RPM by hand to do this but solving the
dependency tree by hand wasn't fun (I downloaded the RPM, tried to
install, found the requires line, found more RPMs, tried to install
etc). I'm fairly sure apt for RPM did allow you to specify versions
and without it it's a real pain for jpackage users.
Comment 4 Seth Vidal 2004-06-23 01:41:49 EDT
it is something that I am working on for a future release but it won't
be immediate and it's not in the 2.0.X timeline at all.

the reality is that handling specific version selection AND globs is
incredibly difficult to parse sanely, especially when you're not
selecting from a commandline and counting on the shell matching but
when you're selecting from a remote repository and then must do the
'best thing' given what you're asked to do.


Comment 5 Sitsofe Wheeler 2004-06-23 03:14:24 EDT
Thanks for the explanation Seth.

Can't enhancement or (RFE) bugs stick around indefinitely? I'm not
asking for it to be added in the next year but having a bug open means
that other people can be pointed at this one / or closing it WONTFIX
acknowledges that yum doesn't do this rather than brushing it under
the carpet and saying it's not a problem.
Comment 6 Seth Vidal 2004-06-23 09:02:03 EDT
you can put an RFE in yum bugzilla, then, not in red hat's.
https://devel.linux.duke.edu/bugzilla/


Note You need to log in before you can comment on or make changes to this bug.