Bug 1238879 - [abrt] php-fpm: zend_std_object_get_class_name(): php-fpm killed by SIGSEGV
Summary: [abrt] php-fpm: zend_std_object_get_class_name(): php-fpm killed by SIGSEGV
Keywords:
Status: CLOSED DUPLICATE of bug 1152738
Alias: None
Product: Fedora
Classification: Fedora
Component: php-xcache
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b4f06cdffb67ab94e280b615a6b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-02 21:38 UTC by Mikhail
Modified: 2015-07-04 07:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-04 07:53:34 UTC


Attachments (Terms of Use)
File: backtrace (19.43 KB, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: cgroup (194 bytes, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: core_backtrace (264 bytes, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: dso_list (11.02 KB, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: environ (663 bytes, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2015-07-02 21:38 UTC, Mikhail
no flags Details
File: maps (57.22 KB, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details
File: mountinfo (4.55 KB, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details
File: namespaces (81 bytes, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details
File: open_fds (480 bytes, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details
File: proc_pid_status (961 bytes, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details
File: var_log_messages (307 bytes, text/plain)
2015-07-02 21:39 UTC, Mikhail
no flags Details

Description Mikhail 2015-07-02 21:38:46 UTC
Version-Release number of selected component:
php-fpm-5.6.10-1.fc22

Additional info:
reporter:       libreport-2.6.0
backtrace_rating: 4
cmdline:        'php-fpm: pool localhost' '' '' '' '' '' '' '' ''
crash_function: zend_std_object_get_class_name
executable:     /usr/sbin/php-fpm
global_pid:     32288
kernel:         4.0.7-300.fc22.x86_64+debug
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 zend_std_object_get_class_name at /usr/src/debug/php-5.6.10/Zend/zend_object_handlers.c:1539
 #1 zend_print_zval_r_ex at /usr/src/debug/php-5.6.10/Zend/zend.c:420
 #2 print_hash at /usr/src/debug/php-5.6.10/Zend/zend.c:184
 #3 zend_print_zval_r_ex at /usr/src/debug/php-5.6.10/Zend/zend.c:409
 #4 zend_print_zval_r at /usr/src/debug/php-5.6.10/Zend/zend.c:395
 #5 zif_print_r at /usr/src/debug/php-5.6.10/ext/standard/basic_functions.c:5535
 #6 dtrace_execute_internal at /usr/src/debug/php-5.6.10/Zend/zend_dtrace.c:97
 #7 zend_do_fcall_common_helper_SPEC at /usr/src/debug/php-5.6.10/Zend/zend_vm_execute.h:560
 #8 execute_ex at /usr/src/debug/php-5.6.10/Zend/zend_vm_execute.h:363
 #9 dtrace_execute_ex at /usr/src/debug/php-5.6.10/Zend/zend_dtrace.c:73

Potential duplicate: bug 1152738

Comment 1 Mikhail 2015-07-02 21:38:49 UTC
Created attachment 1045640 [details]
File: backtrace

Comment 2 Mikhail 2015-07-02 21:38:51 UTC
Created attachment 1045641 [details]
File: cgroup

Comment 3 Mikhail 2015-07-02 21:38:52 UTC
Created attachment 1045642 [details]
File: core_backtrace

Comment 4 Mikhail 2015-07-02 21:38:54 UTC
Created attachment 1045643 [details]
File: dso_list

Comment 5 Mikhail 2015-07-02 21:38:56 UTC
Created attachment 1045644 [details]
File: environ

Comment 6 Mikhail 2015-07-02 21:38:58 UTC
Created attachment 1045645 [details]
File: limits

Comment 7 Mikhail 2015-07-02 21:39:00 UTC
Created attachment 1045646 [details]
File: maps

Comment 8 Mikhail 2015-07-02 21:39:01 UTC
Created attachment 1045647 [details]
File: mountinfo

Comment 9 Mikhail 2015-07-02 21:39:02 UTC
Created attachment 1045648 [details]
File: namespaces

Comment 10 Mikhail 2015-07-02 21:39:04 UTC
Created attachment 1045649 [details]
File: open_fds

Comment 11 Mikhail 2015-07-02 21:39:05 UTC
Created attachment 1045650 [details]
File: proc_pid_status

Comment 12 Mikhail 2015-07-02 21:39:06 UTC
Created attachment 1045651 [details]
File: var_log_messages

Comment 13 Mikhail 2015-07-02 21:46:57 UTC
This bug marked as fixed here: http://xcache.lighttpd.net/ticket/342
But seems that it is not fixed.

Comment 14 Remi Collet 2015-07-04 07:53:34 UTC
Re-affecting to XCache and closing as duplicate.
Upstream is aware of this issue, but doesn't seems they want to fix it.

*** This bug has been marked as a duplicate of bug 1152738 ***

Comment 15 Mikhail 2015-07-04 07:55:44 UTC
(In reply to Remi Collet from comment #14)
> Upstream is aware of this issue, but doesn't seems they want to fix it.

Upstream said that it fixed in http://xcache.lighttpd.net/changeset/71888ba/git


Note You need to log in before you can comment on or make changes to this bug.