Bug 123891 - RFE: vim-minimal should require vim-common to prevent user problems
RFE: vim-minimal should require vim-common to prevent user problems
Status: CLOSED DUPLICATE of bug 123205
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 09:10 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-05-21 09:10:32 EDT
Description of problem:
Red Hat removed the dependence from vim-minimal to vim-common (see
bug #109819), but this causes the "problem", that vim-common isn't
installed by default and vim-minmal (which is VI) has the native/
original VI behaviour (that means for e.g., you've to type "I" again, 
if you navigate using the cursor keys...). 

That original native behaviour of VI is hard to handle, because VIM 
(vim-enhanced) is very user-friendly and most of the Red Hat/Fedora 
Core users only know vim behaviour (from vim-enhanced/-common). This 
change caused already confusions at the users as you can see it the 
fedora-list, too.

I know, that vi isn't vim and that this requirement isn't really 
needed, but it would be better if Fedora Core (and the masses of 
users) get the normal (for years) known vim behaviour as default
back again.

Version-Release number of selected component (if applicable):
vim-6.2.457-1

How reproducible & Steps to Reproduce:
Everytime, see above.
  
Actual results/Expected results:
Requirement in vim-minimal to vim-common, to get the "normal" vim
behaviour. Hopefully you decide to do this requirement for any 
further Fedora Core and RHEL versions - thank you :-)

Additional info:
http://www.redhat.com/archives/fedora-list/2004-May/msg05122.html
http://www.redhat.com/archives/fedora-list/2004-May/msg05114.html
Comment 1 Karsten Hopp 2004-05-21 09:26:32 EDT
The vim-common requirement has been deleted on purpose to reduce 
the base install size and I won't put it back in. 
A better solution would be to find out which files from vim-common 
are required for /bin/vi to work as expected and to move them to  
vim-minimal. vim-enhanced would need to require vim-minimal then,  
but that should be no problem. 
I'll close this report as 'duplicate' and use bug #123205 instead. 

*** This bug has been marked as a duplicate of 123205 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.