Bug 123894 - Add/Remove Applications keeps asking for the same CD
Add/Remove Applications keeps asking for the same CD
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-21 09:31 EDT by Ricky Crocker
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 07:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot of error (295.52 KB, image/png)
2004-05-24 15:24 EDT, Ricky Crocker
no flags Details
package manager output (32.22 KB, text/plain)
2004-05-24 15:26 EDT, Ricky Crocker
no flags Details

  None (edit)
Description Ricky Crocker 2004-05-21 09:31:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):
redhat-config-packages-1.2.9.2-1


How reproducible:


Steps to Reproduce:
1. Click Main Menu - System Settings - Add/Remove Applications

2. Entered Root Password. Under Development I tried to add X software
  Development and Gnome software Development. I clicked update

3. I was asked to insert CD3
  
Actual results:
I inserted CD3 then pressed OK. CD ran about 3 sec. then my cd
unmounted and I was asked for CD3 once more. I tried this 3 times with
the same result. I tried to mount the cd from the command line and
then click the OK button when asked for CD3. Same result my cd
unmounted and I was asked for CD3.

Expected results: 
My development packages to install.

Additional info:
I wanted to install the development packages so I can compile MPlayer
and Plugger. At this point my Redhat WS3 only has pacages from the WS3
CDs and from the up2date site. My WS3 only has supported apps at this
time. I know MPlayer and Plugger are not supported (they are not
installed yet) apps under WS3 but I need them to use our Company's web
page. It has java, flash and streming media from time to time.
Comment 1 Suzanne Hillman 2004-05-24 11:35:00 EDT
This looks like something for which you want to go through support,
presuming you have an up to date entitlement for your system. Support
is here: https://www.redhat.com/apps/support/
Comment 2 Ricky Crocker 2004-05-24 14:56:11 EDT
there are times the package manager tells me it can not find
XFree86-libs-4.3.0-62.EL I did rpm -q --all. and the out put showed
XFree86-libs-4.3.0-62.EL was installed so I ran rpm -qs
XFree86-libs-4.3.0-62.EL everything reported normal. I know the
XFree86-libs-4.3.0-62.EL package is installed so I ran rpm --rebuilddb.
I have seen this bug and the bug that keeps asking for the same cd
over and over but they where for fedora. One other thing I installed
cd one after I ran rpm --rebuilddc and installed KDE packages with no
problems. I am at a lose.
Comment 3 Ricky Crocker 2004-05-24 15:16:30 EDT
Sorry, I forgot to add the package netpbm-0:9.24-11.i386 shows as
missing by package manager. 
Comment 4 Ricky Crocker 2004-05-24 15:24:48 EDT
Created attachment 100516 [details]
Screen Shot of error
Comment 5 Ricky Crocker 2004-05-24 15:26:12 EDT
Created attachment 100517 [details]
package manager output

I thought this may help
Comment 6 Suzanne Hillman 2004-05-24 16:40:51 EDT
Do you have an up to date entitlement? I'm asking because you seem to
not have noticed my suggestion to go through support.
Comment 7 Ricky Crocker 2004-05-25 08:21:34 EDT
Hummm I see,
I saw where Fedora was having the same problem as me and I thought
this may be a bug on professional wrokstation as well after all it
worked before I installed the new Red Hat updates. Sorry to wast your
time.
Comment 8 Suzanne Hillman 2004-05-25 16:51:46 EDT
I think you are misunderstanding me. 

I'm not telling you that the bug report is not helpful; I'm simply
mentioning that this might be something you will be better off going
through support for. If you have no urgency for getting help with
this, then this method is fine.
Comment 9 Ricky Crocker 2004-05-26 08:58:13 EDT
PLS except my apology I did not intend for my comments to sound rude.
I thought you were telling me that my problem was not a bug and I had
submitted my problem to the wrong place. This was the reason for  the
comment (Sorry to wast your time). I did go to support but I did not
find any answers. Most everything was for fedora and very little for
Enterprise WS. I removed package firstboot-1.1.19-2 ,
redhat-config-packages-1.2.9.2-1 , and redhat-rpm-config-8.0.28-2.
after removing the packages I downloaded the above packages from
RedHat and reinstalled them with the command 
   rpm -ihv  --replacepkgs --allfiles <package name>
No luck I have the same problem. My next step will be to try an older
package. I will let you know what happens
Comment 10 Suzanne Hillman 2004-05-26 10:36:46 EDT
"I did go to support but I did not find any answers."

You were unable to find a phone number to call? Was one provided with
your system?
Comment 11 Elliot Lee 2004-05-26 18:25:28 EDT
Reassigning bug to redhat-config-packages owner.
Comment 12 Ricky Crocker 2004-05-27 07:12:41 EDT
I removed package firstboot-1.1.19-2 ,
redhat-config-packages-1.2.9.2-1 , and redhat-rpm-config-8.0.28-2.
After I removed the above packages I installed older ver. of each
package. The Problem was the same. I was asked for the same cd over
and over. Hummm, I am at stumped. I was sure it was the upgrade but
now I am not sure of anything. I will try support one more time. 
Comment 13 Ricky Crocker 2004-06-01 07:37:41 EDT
My system log had no errors this morning so I thought I would try to 
add any program by using Add/Remove programs. After I keep getting
asked for cd 2 over and over I checked my system log and found this.

++++++++++++++++++++++++++++++++++++++++++
Jun  1 07:29:38 LinuxWS userhelper: pam_timestamp: timestamp file
`/var/run/sudo/rcrocker/unknown:root' is only 95 seconds old, allowing
access to redhat-logviewer for UID 500
Jun  1 07:30:33 LinuxWS userhelper: pam_timestamp: timestamp file
`/var/run/sudo/rcrocker/unknown:root' is only 55 seconds old, allowing
access to redhat-config-packages for UID 500
Jun  1 07:31:01 LinuxWS kernel: cdrom: open failed.
Jun  1 07:31:18 LinuxWS kernel: udf: registering filesystem
Jun  1 07:31:36 LinuxWS userhelper: pam_timestamp: timestamp file
`/var/run/sudo/rcrocker/unknown:root' is only 63 seconds old, allowing
access to redhat-logviewer for UID 500
++++++++++++++++++++++++++++++++++++++++++++++

cdrom: open failed. Could this be my problem.
I mounted the cd from the command line and read the cd fine so I know
my cd-drive is working. Anyway hope this info helps.
Comment 14 Suzanne Hillman 2004-06-01 10:07:38 EDT
Could easily be the problem, yes. As I recall, there is a tool at the
very beginning of an install which can check the install media. You
might want to use that to check your CD. Just because you can mount
and read the CD does not mean the entire CD is fine.
Comment 15 Ricky Crocker 2004-06-01 15:16:13 EDT
How do I access and use this Tool?
Comment 16 Suzanne Hillman 2004-06-02 10:19:46 EDT
I believe that all you need to do is boot from the CD, and the very
first thing, after booting, that it will do is ask if you want to test
your media. 
Comment 17 Ricky Crocker 2004-06-02 13:01:45 EDT
I ran the media test on all 4 installation CD and everyone passed.
Crap, I thought that was the problem.
Comment 18 Ricky Crocker 2004-06-03 07:09:45 EDT
OK, I have a new twist to my problem. After I ran the media I thought
I would try to install mysql. Same problem it keep asking for CD 3
over and over. I put my CD 1 in my cdrom and let it auto mount.
Package manager started as expected. I tried to install mysql and it
worked.
Everything I tried to install wile using CD 1 to launch Package
manager worked except Gnome and X development. When trying to install
Gnome and X development a box poped up telling me some packages could
not be found. See my screen shot that was uploaded (comment 4).
Comment 19 Ricky Crocker 2004-06-07 14:09:26 EDT
This is my last Comment so please close this bug. I did a full
reinstall of Redhat professional Workstation. I tested my add remove
programs and everyting worked. I ran the 172 updates on redhat. BOOM
back to the same problem asking for the same CD over and over. That is
all I can take of the add remove programs. I installed Synaptic and it
is working fine.
I was a hardcore Redhat only man but Synaptic is a very cool program,
I think I will stick with it for a time.

Thanks for the Help that everyone gave me. I hope your able to fix
this bug soon.
Comment 21 Mike Weis 2004-06-19 03:16:10 EDT
Try this: put in CD 1, decline the autorun.

Then from a terminal:
rpm -ivh --force /mnt/cdrom/RedHat/RPMS/comps-3ws-*

This will reset the Add/Remove programs "component list" to the same
set which came with your CDROMs.

Of course, up2date will sense this and offer to (re-)upgrade "comps".
You probably want to decline.
Comment 22 Mike Weis 2004-06-19 03:32:37 EDT
... or add "comps" to the ignored packages list.
Comment 24 Daniel Gutierrez 2004-12-01 19:45:47 EST
Well just FYI I have had the exact same issue attempting to install 
the rh-postgresql-server package from Add Remove Applications.  It 
kept asking for disk 3 even though I was providing it and the media 
was OK.  I attempted comment #21's procedure resulting with the 
server disappearing from my update list and re-applying the comps (es 
version) package from up2date got me back to square one.

The thing that bothered me was that it kept unmounting the CD the 
moment I said OK to have it read the disk.  I even put the disk in 
use and it successfully stayed mounted, however, still did not get 
whatever it wanted.

I finally found the article in the knowledge base with the 
issue "Where are the MySQL and PostgreSQL server packages for Red Hat 
Enterprise Linux version 3?" which gave me directions to get the 
package manually which obviously solved immediate need.

If anyone has any insight to this bug I'd love to know.  I would have 
also liked to have found any documentation on 
the /etc/sysconfig/installinfo file or a document describing how to 
change the installation source used by Add Remove Applications.

Hope my notes and experience help someone.

-Daniel Gutierrez
Comment 25 Laura Ramirez 2005-01-14 23:39:05 EST
So frustrating.  I am a Windows System Admin and this made me feel
like I was stuck on stupid.  I am glad to hear I am not the only one
with the problem.  I did not install OpenOffice during the inital
install.  When I tried to install it through Add/Remove Applications,
after being prompted for CD 2, my mounted CD would disappear.  I can
not install application using Add/Remove Applications.  (My media is
fine!)
Comment 26 Rick Clow 2005-06-24 19:58:28 EDT
This is a bug that is affecting a LOT of us and it does not seem that anyone at
RedHat support has a clue or an interest in fixing this.  All I was given as a
"work around" was the address to this thread and NOTHING was solved in this
thread.  Have an idea that a lot of us long time RedHat fans are rethinking this
distribution....I certainly am.
Comment 29 Rich Painter 2005-12-12 15:03:37 EST
I have the SAME problem with RH ES 4.  If I do an Add/Remove after initial
instalation I receive the instruction to "insert cd x".  Once I do it reports
"unable to access disk".  If I manually mount the cd I can see that it is OK,
yet it still complains.  Besides, I just installed the system from the cd set! 
It does not matter which cd is requested to be inserted.  The Add/Remove
complains the same for all of them and it ALWAYS complains... it NEVER works.

I have reviewed the linux formus for redhat and fedora and find that this
complaint has existed for over a year and on various releases for both RH and
fedora.

It is long overdue to be fixed by RH.  What's the hold up?

Note You need to log in before you can comment on or make changes to this bug.