Bug 123931 - rdistd can't create symlinks due to switch from mktemp to mkstemp
rdistd can't create symlinks due to switch from mktemp to mkstemp
Status: CLOSED DUPLICATE of bug 128173
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rdist (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 127380 (view as bug list)
Depends On:
Blocks: 113479
  Show dependency treegraph
 
Reported: 2004-05-21 15:45 EDT by Andrew Sydelko
Modified: 2015-03-04 20:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from bug #123833 (434 bytes, patch)
2004-05-24 13:46 EDT, Suzanne Hillman
no flags Details | Diff

  None (edit)
Description Andrew Sydelko 2004-05-21 15:45:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040413 Galeon/1.3.14 (Debian package 1.3.14a-1)

Description of problem:
This bug is a duplicate of 123833, but I have no idea how to let
the bug system know that it affects RHEL as well.

The fix noted in that bug also fixes it under the version
provided in RHEL.

Version-Release number of selected component (if applicable):
6.1.5-34.30.1

How reproducible:
Always

Steps to Reproduce:
1. Try to rdist a symlink
2.
3.
    

Actual Results:  laid: REMOTE ERROR: /usr/local/bin/rdistIQu9Mm ->
/opt/tetex/2.0.2/bin/outocp: symlink failed: File exists

Additional info:
Comment 2 Suzanne Hillman 2004-05-24 13:46:30 EDT
Created attachment 100513 [details]
Patch from bug #123833

Run from rdist-6.1.5 directory, patch -Np1 < symlink.patch
Should fix the problem.
Comment 3 Phil Knirsch 2004-05-25 08:22:24 EDT

*** This bug has been marked as a duplicate of 123833 ***
Comment 4 Bastien Nocera 2004-06-07 08:01:21 EDT
Reopen to track against RHEL3 U3.
Comment 5 Phil Knirsch 2004-07-02 09:11:58 EDT
Packages and errata have been created, awating QA and release.

Read ya, Phil
Comment 6 Phil Knirsch 2004-07-07 10:12:31 EDT
*** Bug 127380 has been marked as a duplicate of this bug. ***
Comment 7 Phil Knirsch 2004-07-20 05:23:39 EDT

*** This bug has been marked as a duplicate of 128173 ***
Comment 8 Kyle Powell 2004-07-20 15:06:54 EDT
Phil, why was this closed as a duplicate and not the other way around?
Shouldn't the bug report filed at the later date be closed as a
duplicate of the earlier bug report?
Comment 9 Red Hat Bugzilla 2006-02-21 14:03:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.