Bug 123996 - XVideo extension fails to initialise (seems xmms related)
XVideo extension fails to initialise (seems xmms related)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
http://freedesktop.org/bugzilla/show_...
:
: 124398 126475 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 13:14 EDT by Andrew Clayton
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 16:14:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.13 KB, text/plain)
2004-05-22 13:15 EDT, Andrew Clayton
no flags Details
Xorg.0.log (39.66 KB, text/plain)
2004-05-22 13:20 EDT, Andrew Clayton
no flags Details
Output of xvinfo (5.98 KB, text/plain)
2004-05-22 13:21 EDT, Andrew Clayton
no flags Details
output from xvinfo command (1.93 KB, text/plain)
2004-05-23 16:22 EDT, Mikael Lindberg
no flags Details
My xorg.conf (3.10 KB, text/plain)
2004-05-23 16:24 EDT, Mikael Lindberg
no flags Details

  None (edit)
Description Andrew Clayton 2004-05-22 13:14:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I have just upgraded from FC1 --> FC2

I am now seeing a strange problem involving xv.

If I start Ogle or mplayer wihout xmms started they will work 
as before. Howver if I start xmms (not playing anything) and then 
try to start ogle I will get the following error.

X Error of failed request:  BadAlloc (insufficient resources for
operation)
  Major opcode of failed request:  141 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  58
  Current serial number in output stream:  58

mplayer will give the following the error also (depending on what it
is trying to play)

X11 error: BadAlloc (insufficient resources for operation)


MPlayer interrupted by signal 6 in module: flip_page
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't and
  won't help unless you provide this information when reporting a
possible bug.
Successfully enabled DPMS
Xlib: unexpected async reply (sequence 0x68)!


Exit xmms and then Ogle and mplayer will start working again.


xine also seems to kind of have this behaviour but doesn't seem
entirely related to xmms and it's behaviour is a bit more erratic. It
worked fine under FC1 and will work fine using Shm rather then xv for
the video driver. It seems sometimes switching to Shm then switching
back to Xv will sometime make Xv work but this is not 100% the case.


My machine is an Athlon XP 1800+ 512MB RAM with a Matrox G550 with
32MB RAM. I'm using DRI, running in 16bpp @ 1280x1024 (all the same 
as I was with FC1)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start xmms
2. Start ogle --> open disc or mplayer with a movie file of size 
640x480
3.
  

Actual Results:  Ogle and mplayer will fail with the error messages
listed above.

Expected Results:  Ogle should play teh dvd and mplayer should play
the movie file.

Additional info:

I'll attach my xorg.conf, Xorg.0.log and the output of xvinfo.

Let me know if you'd like any other info.

Cheers,
Comment 1 Andrew Clayton 2004-05-22 13:15:45 EDT
Created attachment 100458 [details]
xorg.conf
Comment 2 Andrew Clayton 2004-05-22 13:20:18 EDT
Created attachment 100459 [details]
Xorg.0.log
Comment 3 Andrew Clayton 2004-05-22 13:21:40 EDT
Created attachment 100460 [details]
Output of xvinfo
Comment 4 Andrew Clayton 2004-05-22 13:39:47 EDT
OK, so I logged out and back into (Enlightenment) and now Ogle and
mplayer are working as expected whether xmms is running or not.

Xine is still not working with XV but is ok with XShm.

Ah, play a few files through mplayer and try Ogle a couple more times
and now Ogle and mplayer are failing again with the same errors.

Except if I kill off xmms, they are both back to working. Xine still
won't work with Xv.


Quite bizzare!



Comment 5 Andrew Clayton 2004-05-22 18:28:38 EDT
I'm trying GNOME and the problem is a lot harder to hit. In fact I
think I've only seen xmms + xine misintersction. I did see evolution
cause xine not to work with Xv but can't seemingly reproduce that.
Xine is actually working with Xv under GNOME when xmms isn't running.
My previous reports where from running under Enlightenment, which had
been compiled under FC1.

But xmms is still causing some problem. And my Enlightenment seems to
not be helping. I think I should try recompilling Enlightenment some time.

I'm going to rebuild xmms to see if that helps.


Still, I didn't have any of these problems under FC1.

Comment 6 Andrew Clayton 2004-05-22 19:00:06 EDT
Recompiling xmms-1.2.20 from the .src.rpm at xmms.org didn't fix anything.


More detial on the xine + xmms thing..

If you have xmms running, then start xine (using Xv) xine will come up
with a bright blue screen. If you start a dvd playing, you will still
just have the bright blue screen. If you leave it playing, then kill
xmms then Xine will after a few seconds shows the dvd picture.

Also if you start xine and play a dvd then startup xmms, xine will
continue to work ok.

I should also note that I rebuilt xine since upgrading to FC2.

Since running under GNOME, I haven't managed to get the BadAlloc error
from either ogle or mplayer, with or without xmms running, that must
have been a Enlightenment issue?

Comment 7 Andrew Clayton 2004-05-22 19:30:24 EDT
Spoke to soon. mplayer is playing up again giving the 

X11 error: BadAlloc (insufficient resources for operation)

message again, but only on certain files.

This is under GNOME without xmms running.

Xine and Ogle are both now unhappy again :( heres the error from Ogle

X Error of failed request:  BadAlloc (insufficient resources for
operation)
  Major opcode of failed request:  141 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  57
  Current serial number in output stream:  57


This will require a restart of X to fix.

Comment 8 Andrew Clayton 2004-05-22 20:18:36 EDT
Perhaps some progress.


I checked on my laptop (running FC2) to see if I could run xine (with
Xv) at the same time xmms was running (this seems the best test case)
and I could.

That is using the Savage driver.


So on my workstation, I've moved the mga_drv.so driver out the way an
put in the mga_drv.so and mga_hal_drv.so drivers that I had to hand
the from the mga 3.0 drivers package from the Matrox site. These
drivers were for XFree86 4.3 but seem to be working ok here and I can
now have xine (with Xv) and xmms running at the same time. I'll have
to wait and see if it clears up the BadAlloc problem. But certainly
there is already an improvement!.


Cheers,


Comment 9 Andrew Clayton 2004-05-23 09:06:08 EDT
Hmm... these problems are back again (using the Matrox mga driver).

Xine wont work with Xv full stop and mplayer and Ogle wont work with
Xv if xmms is running.



Comment 10 Andrew Clayton 2004-05-23 10:14:12 EDT
It seems to be the same kind of thing as described in this bug report

http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=474

And indeed disabling dri makes Xine work again. Of course, now Quake3
is unplayabale :(
Comment 11 Andrew Clayton 2004-05-23 14:43:23 EDT
Seems disabling DRI only temporarily suspended the problem...
Comment 12 Mikael Lindberg 2004-05-23 16:22:14 EDT
Created attachment 100482 [details]
output from xvinfo command
Comment 13 Mikael Lindberg 2004-05-23 16:23:13 EDT
I have the same problem, only always (no matter if xmms is on or off).
Attached results from my xvinfo above. Will add my xorg.conf in a few
secs. 
Comment 14 Mikael Lindberg 2004-05-23 16:24:45 EDT
Created attachment 100483 [details]
My xorg.conf
Comment 15 Andreas Thienemann 2004-05-25 15:41:27 EDT
Same problem here.
System is a matrox g400. Everything worked just great with XFree but
breaks with x.org.
However, the problem is also partly color-depth dependant.
running mplayer on 24bit depth gives the following error:

"VO: [xv] 352x240 => 352x264 Planar YV12
X11 error: BadAlloc (insufficient resources for operation)  0.0% 2 0 39%
MPlayer interrupted by signal 6 in module: flip_page"

running in 16bit colordepth makes mplayer able to play movies.

however, opening xmms, mozilla or any other application that uses a
lot of pixmaps prevents mplayer from playing the files in 16bit
colordepth.


Billy Riggs from tvtime adds the following:

<vektor_wrk> i suspect someone broke the memory allocator with dri somehow
<vektor_wrk> xmms must be using a lot of pixmaps.
<vektor_wrk> Like, the problem is that XVIDEO should preempt any
pixmaps in video memory, I think.
<vektor_wrk> Since pixmaps can be stored in system RAM, but XVIDEO
surfaces cannot.
<vektor_wrk> XVIDEO must take priority.
Comment 16 Marius Andreiana 2004-05-26 09:25:42 EDT
*** Bug 124398 has been marked as a duplicate of this bug. ***
Comment 17 Marius Andreiana 2004-05-26 09:27:46 EDT
If mozilla is not running, tvtime works fine. xmms doesn't matter.
The problem does not exist for them with the xfree server.

Should this be marked as RESOLVED - UPSTREAM?
http://freedesktop.org/bugzilla/show_bug.cgi?id=474
Comment 18 Billy Biggs 2004-05-26 09:54:06 EDT
This has not been resolved, so that does not sound correct.
Comment 19 Mike A. Harris 2004-05-26 12:09:43 EDT
Hi Marius, others;

We will track this issue in the upstream bugzilla from now on, as
it is easier to track it in one place.  I will provide any future
followups and/or status changes in the upstream report.  Once the
issue is closed, I will reflect that status here as well.

In the mean time, I recommend anyone who experiences this problem
with any video hardware and drivers, to add comments to the upstream
bug report, so that all information is present in one location.

Thanks.
Comment 20 Motor 2004-06-25 18:42:24 EDT
*** Bug 126475 has been marked as a duplicate of this bug. ***
Comment 21 Mike A. Harris 2004-09-01 08:04:43 EDT
Status update:  The upstream bug report indicates that a fix has
been checked into CVS.  I'm setting the status of this back to
"ASSIGNED" now, pending review of the changes for potential
inclusion in a future xorg-x11 update release for FC2.
Comment 22 Mike A. Harris 2005-03-06 16:14:55 EST
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".
Comment 23 Gary Lerhaupt 2005-04-29 15:19:21 EDT
I don't like being told I need to upgrade my OS to get video working.  Seems
silly.  Has this problem been resolved?  I'd like to know how to patch up my
current OS.
Comment 24 Marius Andreiana 2005-05-02 12:43:49 EDT
You don't need to upgrade the OS. RHEL has a lifespan of 5-7 years, available at
$350/year. You can use it too.

Note You need to log in before you can comment on or make changes to this bug.