Bug 124018 - AdvanSys SCSI Card Still Not Probed on Install
AdvanSys SCSI Card Still Not Probed on Install
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-05-22 19:04 EDT by Jeff Means
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-08 15:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Means 2004-05-22 19:04:59 EDT
Description of problem:
I feel that a piece of hardware that the redhat HCL lists as supported
and is included by default for versions of RedHat Linux _MUST_ be
included in the Fedora Core releases.  Go check the
http://hardware.redhat.com/hcl/ and search for advansys for
confirmation of it being a supported device with ease of install
listed as '4. Install an RPM from the Red Hat Linux Installation CD
during installation.'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot System with advansys card
2. advansys card not detected
3. Can not install to SCSI devices attached to card
Actual results:
No hard drive available to install onto

Expected results:
Having hard drive to install onto

Additional info:
Comment 1 Jeremy Katz 2004-05-23 22:36:33 EDT
Does the driver exist/get loaded?
Comment 2 Jeff Means 2004-05-23 23:35:33 EDT
driver does exist in module form after instal but is not available
during install procudure, so it is required that you have an alternate
supported hard drive for install to proceed. (i.e. IDE harddisk or
SCSI card with attached harddisk that is supported in install initrd
Comment 3 Jeremy Katz 2004-06-08 15:22:24 EDT
Added back.

Note that hardware being previously supported in releases of Red Hat
Linux doesn't automatically mean it will be in Fedora -- there is a
dependence on someone caring enough to maintain the driver, etc (and
for a while, the driver was gone, which is why I nuked it from
module-info to begin with).  

You should be able to make a driver disk with the module to be able to
install FC2
Comment 4 Jeff Means 2004-06-10 11:31:30 EDT
How about telling us users how to make a driver disk (every howto I
have found is not even remotely current).
Comment 5 Paul Howarth 2004-09-10 08:17:37 EDT
I have a workaround for this issue (custom FC2 boot.iso that includes
the advansys driver) at:


I believe that driver disks for SCSI modules in FC2 simply don't work
at all - see Bug #122952
Comment 6 Paul Howarth 2005-06-21 13:30:34 EDT
The advansys.ko module is shipped in the FC4 installer initrd (i386) but the
card is not auto-detected. I believe this is because the pcitable file does not
include the necessary information:

0x10cd  0x1200  "advansys"      "Advanced System Products|ASC1200 [(abp940) Fast
0x10cd  0x1300  "advansys"      "Advanced System Products|ABP940-U / ABP960-U"
0x10cd  0x2300  "advansys"      "Advanced System Products|ABP940-UW"
0x10cd  0x2500  "advansys"      "Advanced System Products|ABP940-U2W"

I don't know if data in the modules.pcimap file is also necessary for
autodetection or not.

I have been able to install FC4 on an Advansys-based system using a driver disk
that provides the missing information, which is available from the URL given in
Comment #5.

Note You need to log in before you can comment on or make changes to this bug.