Bug 124027 - USB Compact Flash Fails (usb-storage: probe ... failed with error -5)
USB Compact Flash Fails (usb-storage: probe ... failed with error -5)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-22 20:32 EDT by Manuel Morales
Modified: 2015-01-04 17:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 09:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A snippet of relevant output from dmesg (1.24 KB, text/plain)
2004-05-24 04:34 EDT, Thomas Kirby
no flags Details
Output from /var/log/messages during connect and mount (1.94 KB, text/plain)
2004-05-25 20:03 EDT, Ed Holden
no flags Details

  None (edit)
Description Manuel Morales 2004-05-22 20:32:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have been unable to mount my Lexar Media (Jumpshot) Compact Flash
card. I've setup the following in my /etc/fstab file:

/dev/sda1 /mnt/usbstick vfat user,noauto,umask=0   0 0

But I get the following error message when I try to mount it:

mount: /dev/sda1 is not a valid block device

The following error is in my system log:

usb 1-2.3: new full speed USB device using address 5
usb-storage: probe of 1-2.3:1.0 failed with error -5


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Plug in Flash Card
2. Regardless of what is in fstab file, I get the "system log" error
above.
3.
    

Actual Results:  Can not mount device

Additional info:
Comment 1 Thomas Kirby 2004-05-24 02:10:58 EDT
Same problem, this time with Creative Nomad MuVO on my i686. It 
worked on FC1, but now seems to be broken. If you folks want my dmesg 
output, then drop me a line, cause I don't have it handy right now.
Comment 2 Thomas Kirby 2004-05-24 04:34:16 EDT
Created attachment 100486 [details]
A snippet of relevant output from dmesg
Comment 3 Ed Holden 2004-05-25 20:03:14 EDT
Created attachment 100566 [details]
Output from /var/log/messages during connect and mount
Comment 4 Ed Holden 2004-05-25 20:05:46 EDT
I have had a similar issue with a compact flash card in my USB HP
camera.  This happens:

  $ mount /dev/sda1 /mnt/camera
  mount: /dev/sda1: can't read superblock

Butthe media is fine.  I tried reformatting the card without success,
and I have successfully mounted this card on both RH Enterprise Linux
3 and Windows.

So I downloaded kernel 2.6.6, the latest stable on kernel.org, and
compiled it with a modified version of the RH .config (I removed some
unnecessary hardware support).  Same issue persists.  So I suspect
that this issue might not be specific to Fedora Core, but might be
common to all 2.6 kernels.

Attached is what happens in /var/log/messsages when I turn on the
camera and Linux notices it, followed by what happens as I try to
mount it.  It is a bit different than the existing dmesg attachment.

In addition to the mount errors and the inability to use the media,
when I run a parted on /dev/sda it hangs.  Not even a kill -9 stops
the parted process.  When I run parted on the camera's media in RHEL 3
it suggests the geometry might be inconsistent with the BIOS, but it
displays the partition table fine.  So perhaps this is a case of the
kernel not liking a poorly-made filesystem or partition map.
Comment 5 Thomas Kirby 2004-05-26 04:33:05 EDT
There seem to be a large-ish number of USB fixes going into the 2.6.6
kernel. Maybe they might fix the problem?
Comment 6 Thomas Kirby 2004-05-26 05:54:25 EDT
Having upgraded to the 2.6.6-1.383 kernel from testing, I still get
the same problem. Here is the appropriate syslog output:

May 26 10:44:43 za kernel: ohci_hcd 0000:00:02.2: remote wakeup
May 26 10:44:43 za kernel: usb 1-1: new full speed USB device using
address 2
May 26 10:44:44 za kernel: Initializing USB Mass Storage driver...
May 26 10:44:44 za kernel: scsi0 : SCSI emulation for USB Mass Storage
devices
May 26 10:44:44 za kernel:   Vendor: CREATIVE  Model: NOMAD_MUVO     
  Rev: 0001
May 26 10:44:44 za kernel:   Type:   Direct-Access                   
  ANSI SCSI revision: 02
May 26 10:44:44 za kernel: usbcore: registered new driver usb-storage
May 26 10:44:44 za kernel: USB Mass Storage support registered.
May 26 10:44:44 za kernel: SCSI device sda: 256001 512-byte hdwr
sectors (131 MB)
May 26 10:44:44 za kernel: sda: assuming Write Enabled
May 26 10:44:44 za kernel: sda: assuming drive cache: write through
May 26 10:44:44 za kernel:  sda:end_request: I/O error, dev sda,
sector 256000
May 26 10:44:44 za kernel: Buffer I/O error on device sda, logical
block 256000
May 26 10:44:45 za scsi.agent[2722]: disk at
/devices/pci0000:00/0000:00:02.2/usb1/1-1/1-1:1.0/host0/0:0:0:0
May 26 10:45:44 za kernel: usb 1-1: reset full speed USB device using
address 2
May 26 10:45:45 za kernel: usb 1-1: device not accepting address 2,
error -110
May 26 10:45:45 za kernel: scsi: Device offlined - not ready after
error recovery: host 0 channel 0 id 0 lun 0
May 26 10:45:45 za kernel: SCSI error : <0 0 0 0> return code = 0x50000
May 26 10:45:45 za kernel: end_request: I/O error, dev sda, sector 256000
May 26 10:45:45 za kernel: Buffer I/O error on device sda, logical
block 256000
May 26 10:45:45 za kernel: scsi0 (0:0): rejecting I/O to offline device
May 26 10:45:45 za kernel:  sda1
May 26 10:45:45 za kernel: SCSI error: host 0 id 0 lun 0 return code =
4000000
May 26 10:45:45 za kernel: ^ISense class 0, sense error 0, extended
sense 0
May 26 10:45:45 za kernel: Attached scsi removable disk sda at scsi0,
channel 0, id 0, lun 0
May 26 10:45:52 za kernel: inserting floppy driver for 2.6.6-1.383
May 26 10:45:55 za kernel: floppy0: no floppy controllers found
May 26 10:45:55 za modprobe: FATAL: Error inserting floppy
(/lib/modules/2.6.6-1.383/kernel/drivers/block/floppy.ko): No such device 
May 26 10:48:47 za kernel: usb 1-1: USB disconnect, address -1
May 26 10:48:47 za kernel: sd 0:0:0:0: Illegal state transition
offline->cancel
May 26 10:48:47 za kernel: Badness in scsi_device_set_state at
drivers/scsi/scsi_lib.c:1640
May 26 10:48:47 za kernel:  [<0e93804b>]
scsi_device_set_state+0xbe/0xc9 [scsi_mod]
May 26 10:48:47 za kernel:  [<0e933c2c>] scsi_device_cancel+0x26/0xda
[scsi_mod]
May 26 10:48:47 za kernel:  [<021daf13>] device_for_each_child+0x48/0x70
May 26 10:48:47 za kernel:  [<0e933d1e>] scsi_device_cancel_cb+0x0/0xc
[scsi_mod]
May 26 10:48:47 za kernel:  [<0e933d4d>] scsi_host_cancel+0x23/0x8f
[scsi_mod]
May 26 10:48:47 za kernel:  [<022146bf>] usb_buffer_free+0x23/0x26
May 26 10:48:47 za kernel:  [<0e933dc3>] scsi_remove_host+0xa/0x3d
[scsi_mod]
May 26 10:48:47 za kernel:  [<0ea03316>] storage_disconnect+0x29/0x31
[usb_storage]
May 26 10:48:47 za kernel:  [<022139f9>] usb_unbind_interface+0x2c/0x50
May 26 10:48:47 za kernel:  [<021dba30>] device_release_driver+0x3c/0x46
May 26 10:48:47 za kernel:  [<021dbb30>] bus_remove_device+0x47/0x80
May 26 10:48:47 za kernel:  [<021dae9a>] device_del+0x66/0x87
May 26 10:48:47 za kernel:  [<02218477>] usb_disable_device+0x62/0xc1
May 26 10:48:47 za kernel:  [<02214338>] usb_disconnect+0xa7/0xdc
May 26 10:48:47 za kernel:  [<02215cd1>]
hub_port_connect_change+0x6a/0x28d
May 26 10:48:47 za kernel:  [<022155d8>] hub_port_status+0x2b/0x86
May 26 10:48:47 za kernel:  [<02215fca>] hub_events+0xd6/0x248
May 26 10:48:47 za kernel:  [<0221615a>] hub_thread+0x1e/0xd0
May 26 10:48:47 za kernel:  [<02116dce>] default_wake_function+0x0/0xc
May 26 10:48:47 za kernel:  [<0221613c>] hub_thread+0x0/0xd0
May 26 10:48:47 za kernel:  [<021041d9>] kernel_thread_helper+0x5/0xb
May 26 10:48:47 za kernel: 
May 26 10:48:47 za kernel: sd 0:0:0:0: Illegal state transition
offline->cancel
May 26 10:48:47 za kernel: Badness in scsi_device_set_state at
drivers/scsi/scsi_lib.c:1640
May 26 10:48:47 za kernel:  [<0e93804b>]
scsi_device_set_state+0xbe/0xc9 [scsi_mod]
May 26 10:48:47 za kernel:  [<0e939a71>] scsi_remove_device+0xe/0x76
[scsi_mod]
May 26 10:48:47 za kernel:  [<0e93930a>] scsi_forget_host+0x1f/0x36
[scsi_mod]
May 26 10:48:47 za kernel:  [<0e933dd1>] scsi_remove_host+0x18/0x3d
[scsi_mod]
May 26 10:48:47 za kernel:  [<0ea03316>] storage_disconnect+0x29/0x31
[usb_storage]
May 26 10:48:47 za kernel:  [<022139f9>] usb_unbind_interface+0x2c/0x50
May 26 10:48:47 za kernel:  [<021dba30>] device_release_driver+0x3c/0x46
May 26 10:48:47 za kernel:  [<021dbb30>] bus_remove_device+0x47/0x80
May 26 10:48:47 za kernel:  [<021dae9a>] device_del+0x66/0x87
May 26 10:48:47 za kernel:  [<02218477>] usb_disable_device+0x62/0xc1
May 26 10:48:47 za kernel:  [<02214338>] usb_disconnect+0xa7/0xdc
May 26 10:48:47 za kernel:  [<02215cd1>]
hub_port_connect_change+0x6a/0x28d
May 26 10:48:47 za kernel:  [<022155d8>] hub_port_status+0x2b/0x86
May 26 10:48:47 za kernel:  [<02215fca>] hub_events+0xd6/0x248
May 26 10:48:47 za kernel:  [<0221615a>] hub_thread+0x1e/0xd0
May 26 10:48:47 za kernel:  [<02116dce>] default_wake_function+0x0/0xc
May 26 10:48:47 za kernel:  [<0221613c>] hub_thread+0x0/0xd0
May 26 10:48:47 za kernel:  [<021041d9>] kernel_thread_helper+0x5/0xb
May 26 10:48:47 za kernel: 
Comment 7 Ed Holden 2004-05-26 18:38:24 EDT
> There seem to be a large-ish number of USB fixes going into
> the 2.6.6 kernel. Maybe they might fix the problem?

Somehow I don't think so.  2.6.6 is the kernel version I downloaded on
Monday night (comment above), and it exhibited the same problem with
my CF VFAT filesystem (but otherwise works fine).  However, it's
possible that it's not the CF that is the issue, but rather the
filesystem or the partition table on the card.  The only thing that
indicates that it's the type of media or the USB is that parted
crashes when I try to print the partition table of /dev/sda.  And I
mean CRASHES, like kill-9 doesn't dent it.
Comment 8 Thomas Kirby 2004-05-27 06:15:18 EDT
See http://lwn.net/Articles/86437/
Sorry, this is actually for 2.6.7-rc1.
Does anyone know whether it fixes this issue?
Comment 9 Ed Holden 2004-06-01 19:31:39 EDT
Unfortunately 2.6.7-rc1 does not seem to fix the issue.  I just
patched my 2.6.6 to the above version and recompiled.  The issue
persists, and I get the "invalid superblock" error when I try to mount
the camera.  One nice test would be to see if this problem is
Fedora-specific by trying it on another 2.6-based distro.  I may try
with Knoppix 3.4 ...
Comment 10 Thomas Kirby 2004-06-02 13:22:35 EDT
Are Red Hat / Kernel maintainers likely to issue some kind of 
resolution for this? What kind of time-span should I expect? This is 
a very annoying bug for me, and probably others too.
Comment 11 jonas 2004-06-03 02:19:47 EDT
I have a muvo 64mb that I'm having very similar problems with. Used to
work in Fedora 1. Tried it with Knoppix (kernel 2.6.5) and it worked
perfectly, so it seems to be a Fedora 2 specific bug, or?
Comment 12 Ed Holden 2004-06-04 22:49:41 EDT
I can confirm this.  I had some problems with Knoppix on this machine
and downloaded the latest 3.4 (5-17), which has the 2.6.6 kernel.  My
CF card mounted as /dev/sda1 just fine.  So yes, this problem is
specific to FC2, despite working on FC1.  And it's not related to the
kernel version change directly.  It might be a problem with the mount
command, or perhaps an issue with the kernel .config that comes with
FC2.  A recompile with a fresh .config might confirm this.

I'd consider this a high-priority issue, since anyone with a camera,
pen storage or other such device will be unable to mount their
filesystem.  I suggest that the priority be changed to high, but only
mmorales@williams.edu can do this.  Correct me if this is wrong, but
this is a pretty high priority because lack of support for cameras and
other USB mass storage could hurt Fedora's acceptance if it causes
enough problems.
Comment 13 Thomas Kirby 2004-06-05 06:16:29 EDT
I would suggest that it is a problem with the kernel, rather then mount, 
considering my output from dmesg and syslog (see above). I really wish 
someone would find time to fix this...
Comment 14 jonas 2004-06-12 03:27:45 EDT
I'm getting the same error with 2.6.6-1.427.
Comment 15 Ed Holden 2004-06-14 19:55:07 EDT
I'm now getting the error with the newly-released 2.6.6-1.435, so it's
not fixed yet as of 6/14.

There are a lot of similar USB storage bugs out there - in particular
24139.  Each is distinctly different, but the general idea of all of
them is an inability to mount /dev/sda.  Perhaps it's one big problem.

I don't know if these are all the same issue or not, but none seem to
be resolved yet.  Does anyone know if a fix for this has been found? 
I've been using Knoppix with its 2.6 kernel and it works fine, so I'm
using that to get my photos and then rebooting - but I'd rather do it
in FC2 and save some time ... :)
Comment 16 Tim Becker 2004-06-17 09:46:27 EDT
I've found a solution to the original problem of the Lexar Jumpshot CF
reader not being recognized correctly. Here's the patch for
drivers/usb/storage/unusual_devs.h that fixes the Jumpshot issue:

=== BEGIN
--- linux-2.6.5-60300cl/drivers/usb/storage/unusual_devs.h.orig
2004-05-19 22:44:23.572074168 -0300
+++ linux-2.6.5-60300cl/drivers/usb/storage/unusual_devs.h  2004-05-19
22:44:50.067046320 -0300
@@ -376,8 +376,8 @@
 UNUSUAL_DEV(  0x05dc, 0x0001, 0x0000, 0x0001,
                "Lexar",
                "Jumpshot USB CF Reader",
-               US_SC_DEVICE, US_PR_JUMPSHOT, NULL,
-               US_FL_MODE_XLATE ),
+               US_SC_SCSI, US_PR_JUMPSHOT, NULL,
+               US_FL_FIX_CAPACITY ),
 #endif
 
 /* Reported by Blake Matheny <bmatheny@purdue.edu> */
=== END

After applying this patch my Lexar Jumpshot CF reader works perfectly.

There's a thread on the linux-usb-devel list on sourceforge with the
subject of "Lexar Jumpshot CF reader not working" that details this
issue and the fix.

Thanks to all the people on this list that helped out with this problem.
Comment 17 Manuel Morales 2004-06-17 21:15:41 EDT
I applied the above patch (modifying it for kernel 2.6.6-1.435) and
still have the error message I originally reported. Is it possible I
applied the patch wrong? Here's the patch I applied:

=== BEGIN
--- 2.6.6-1.435/build/drivers/usb/storage/unusual_devs.h.orig
2004-05-19 22:44:23.572074168 -0300
+++ 2.6.6-1.435/build/drivers/usb/storage/unusual_devs.h  2004-05-19
22:44:50.067046320 -0300
@@ -399,8 +399,8 @@
 UNUSUAL_DEV(  0x05dc, 0x0001, 0x0000, 0x0001,
 		"Lexar",
 		"Jumpshot USB CF Reader",
-		US_SC_DEVICE, US_PR_JUMPSHOT, NULL,
-		US_FL_MODE_XLATE ),
+		US_SC_SCSI, US_PR_JUMPSHOT, NULL,
+		US_FL_FIX_CAPACITY ),
 #endif
 
 /* Reported by Blake Matheny <bmatheny@purdue.edu> */
=== END

I saved this to the file usb.patch and used the command:

patch -p0 < usb.patch

The output indicated the patch was successful. Is there anything else
I need to do? This doesn't seem to fix the problem for me, even after
rebooting?
Comment 18 Manuel Morales 2004-06-17 21:19:41 EDT
Oops!

The first line in the patch above should have read:

linux-2.6.6-1.435/drivers/usb/storage/

Which was applied from the /usr/src directory.
Comment 19 Tim Becker 2004-06-18 09:19:32 EDT
A different and better patch for this issue was submitted by Alan
Stern from the usb-devel list on sourceforge.  Here's his comments and
the new patch.  I've applied this to my system the the JS CF reader
works perfectly.

----
Alan Stern wrote:

Thanks for reporting this.  It turns out that the FIX_CAPACITY flag
shouldn't have to be there -- it's a bug in the jumpshot driver.  Oddly
enough, exactly the same bug was present and was fixed in the datafab
driver, which is extremely similar to the jumpshot version.

Also, it's clear that Lexar is up to the same sort of tricks as Casio.  
Although your devices definitely need the US_SC_SCSI override in the
unusual_devs entry, I've got an old email from someone with an otherwise
identical device which _doesn't_ need the override.

Anyway, the patch below (which applies to a vanilla 2.6 kernel) should
fix 
things up.  Let me know if it works okay.

Alan Stern



===== drivers/usb/storage/jumpshot.c 1.34 vs edited =====
--- 1.34/drivers/usb/storage/jumpshot.c Wed May 19 13:42:23 2004
+++ edited/drivers/usb/storage/jumpshot.c       Thu Jun 17 15:51:10 2004
@@ -471,7 +471,7 @@
 
                // build the reply
                //
-               ((u32 *) ptr)[0] = cpu_to_be32(info->sectors);
+               ((u32 *) ptr)[0] = cpu_to_be32(info->sectors - 1);
                ((u32 *) ptr)[1] = cpu_to_be32(info->ssize);
                usb_stor_set_xfer_buf(ptr, 8, srb);
 
===== drivers/usb/storage/unusual_devs.h 1.131 vs edited =====
--- 1.131/drivers/usb/storage/unusual_devs.h    Tue Jun  1 08:46:58 2004
+++ edited/drivers/usb/storage/unusual_devs.h   Thu Jun 17 15:57:07 2004
@@ -402,8 +402,8 @@
 UNUSUAL_DEV(  0x05dc, 0x0001, 0x0000, 0x0001,
                "Lexar",
                "Jumpshot USB CF Reader",
-               US_SC_DEVICE, US_PR_JUMPSHOT, NULL,
-               US_FL_MODE_XLATE ),
+               US_SC_SCSI, US_PR_JUMPSHOT, NULL,
+               US_FL_NEED_OVERRIDE | US_FL_MODE_XLATE ),
 #endif
 
 /* Reported by Blake Matheny <bmatheny@purdue.edu> */



Comment 20 Manuel Morales 2004-06-18 15:02:16 EDT
Any pointers for how these patches are applied? I can use the patch
command to update the sources, but wouldn't the kernel need to be
recompiled afterwards? Is there an easy way to do this?
Comment 21 Tim Becker 2004-06-18 16:53:56 EDT
Yeah, if you're running the stock kernel then you'll need to compile a
custom one with this patch applied.  (Anyone know how to complile a
single module for use in the stock kernel?)  I run a custom kernel
anyway so doing a 

make modules modules_install 

from the source dir after applying the patch worked for me.

AFA applying the patch I put the above pathc into a file
(jumpshot.patch) and did this:

cd /usr/src/linux-2.6.6-1.435/drivers/usb/storage
patch -p4 -l < ~tbecker/jumpshot.patch

I had to use the -l (ignore-whitespace) flag to get the patch to
apply.  My cut and paste must have done something funky w/ tabs or
spaces.  

If all else fails the patch is simple enough that you could edit
jumpshot.c and unusual_devs.h by hand just to get it to work.

Lastly, it seems that this patch has been applied to the 2.6.7 kernel
tree as of today.  Here's the text of a post to the linux-usb-devel
list by Greg KH <greg@kroah.com>

-------------
ChangeSet 1.1722.97.79, 2004/06/17 15:22:34-07:00,
mdharm-usb@one-eyed-alien.net

[PATCH] USB Storage: Lexar Jumpshot CF reader

This patch is required to fix up the jumpshot driver, and to supress
the 'unneeded entry' message for another device which uses the same
VID/PID/rev for multiple different versions of the device.

Alan Stern cooked this patch up, originally.

Signed-off-by: Matthew Dharm <mdharm-usb@one-eyed-alien.net>
Signed-off-by: Greg Kroah-Hartman <greg@kroah.com>


 drivers/usb/storage/jumpshot.c     |    2 +-
 drivers/usb/storage/unusual_devs.h |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)


diff -Nru a/drivers/usb/storage/jumpshot.c
b/drivers/usb/storage/jumpshot.c
--- a/drivers/usb/storage/jumpshot.c    Fri Jun 18 10:52:23 2004
+++ b/drivers/usb/storage/jumpshot.c    Fri Jun 18 10:52:23 2004
@@ -471,7 +471,7 @@
 
                // build the reply
                //
-               ((u32 *) ptr)[0] = cpu_to_be32(info->sectors);
+               ((u32 *) ptr)[0] = cpu_to_be32(info->sectors - 1);
                ((u32 *) ptr)[1] = cpu_to_be32(info->ssize);
                usb_stor_set_xfer_buf(ptr, 8, srb);
 
diff -Nru a/drivers/usb/storage/unusual_devs.h
b/drivers/usb/storage/unusual_devs.h
--- a/drivers/usb/storage/unusual_devs.h        Fri Jun 18 10:52:23 2004
+++ b/drivers/usb/storage/unusual_devs.h        Fri Jun 18 10:52:23 2004
@@ -402,8 +402,8 @@
 UNUSUAL_DEV(  0x05dc, 0x0001, 0x0000, 0x0001,
                "Lexar",
                "Jumpshot USB CF Reader",
-               US_SC_DEVICE, US_PR_JUMPSHOT, NULL,
-               US_FL_MODE_XLATE ),
+               US_SC_SCSI, US_PR_JUMPSHOT, NULL,
+               US_FL_NEED_OVERRIDE | US_FL_MODE_XLATE ),
 #endif
 
 /* Reported by Blake Matheny <bmatheny@purdue.edu> */


Comment 22 Manuel Morales 2004-06-19 13:44:11 EDT
Success!

I applied the patches in comment #21 and recompiled my kernel using
the link below as a guide:

http://fedoranews.org/contributors/vitor_domingos/ntfs/

Thanks to everyone for all their help!
Comment 23 Dave Jones 2004-06-19 20:16:53 EDT
Please leave open until the Fedora kernel is fixed.
Otherwise things like this tend to get lost.
Comment 24 Ed Holden 2004-06-24 22:41:07 EDT
I'm sad to say this didn't solve my problem.  I'm using Lexar media. 
I applied the patch against 2.6.6-1.435 and compiled.  Then this
happens in /var/log/messages:

--------
Jun 24 22:33:14 localhost kernel: usb 1-2: new full speed USB device
using address 2
Jun 24 22:33:21 localhost kernel: Initializing USB Mass Storage driver...
Jun 24 22:33:21 localhost kernel: scsi0 : SCSI emulation for USB Mass
Storage devices
Jun 24 22:33:21 localhost kernel:   Vendor:  HP       Model:
PhotoSmart 318    Rev: 100
Jun 24 22:33:21 localhost kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 02
Jun 24 22:33:21 localhost kernel: Attached scsi generic sg0 at scsi0,
channel 0, id 0, lun 0,  type 0
Jun 24 22:33:21 localhost kernel: usbcore: registered new driver
usb-storage
Jun 24 22:33:21 localhost kernel: USB Mass Storage support registered.
Jun 24 22:33:21 localhost scsi.agent[2139]: disk at
/devices/pci0000:00/0000:00:07.2/usb1/1-2/1-2:1.0/host0/0:0:0:0
Jun 24 22:33:21 localhost kernel: SCSI device sda: 125953 512-byte
hdwr sectors (64 MB)
Jun 24 22:33:21 localhost kernel: sda: assuming Write Enabled
Jun 24 22:33:21 localhost kernel: sda: assuming drive cache: write through
Jun 24 22:33:21 localhost kernel:  sda:SCSI error : <0 0 0 0> return
code = 0x8000002
Jun 24 22:33:21 localhost kernel: Current sda: sense key No Sense
Jun 24 22:33:21 localhost kernel: end_request: I/O error, dev sda,
sector 125952
Jun 24 22:33:21 localhost kernel: Buffer I/O error on device sda,
logical block 125952
Jun 24 22:33:21 localhost kernel: SCSI error : <0 0 0 0> return code =
0x8000002
Jun 24 22:33:21 localhost kernel: Current sda: sense key No Sense
Jun 24 22:33:21 localhost kernel: end_request: I/O error, dev sda,
sector 125952
Jun 24 22:33:21 localhost kernel: Buffer I/O error on device sda,
logical block 125952
Jun 24 22:33:21 localhost kernel:  sda1
Jun 24 22:33:21 localhost kernel: Attached scsi removable disk sda at
scsi0, channel 0, id 0, lun 0
Jun 24 22:33:22 localhost kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
--------

And the old "FAT: unable to read boot sector" whenever I try to mount.
 The command output is "can't read superblock."  I'm wondering if,
despite this being a CF USB storage issue, this might be a different
bug.  Any input or other suggestions are much appreciated.

-Ed
Comment 25 Rasmus Back 2004-08-13 04:20:27 EDT
I have Creative Muvo 128MB and I'm getting the "Buffer I/O error on
device sda" as well:

Aug 13 10:57:48 localhost kernel: usb 2-1: new full speed USB device
using address 2
Aug 13 10:57:48 localhost kernel: scsi2 : SCSI emulation for USB Mass
Storage devices
Aug 13 10:57:48 localhost kernel:   Vendor: CREATIVE  Model: NOMAD_MUVO
     Rev: 0001
Aug 13 10:57:48 localhost kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 02
Aug 13 10:57:48 localhost kernel: SCSI device sda: 256001 512-byte
hdwr sectors (131 MB)
Aug 13 10:57:48 localhost kernel: sda: Write Protect is off
Aug 13 10:57:48 localhost kernel: sda: assuming drive cache: write through
Aug 13 10:57:48 localhost kernel:  sda:end_request: I/O error, dev
sda, sector 256000
Aug 13 10:57:48 localhost kernel: Buffer I/O error on device sda,
logical block 256000
Aug 13 10:57:58 localhost scsi.agent[2094]: Attribute
/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/host2/2:0:0:0/type
does not exist
Aug 13 10:57:58 localhost udev[2150]: creating device node '/udev/sda'

Trying to mount /dev/sda hangs mount. Running kudzu -s -p -c HD also
hangs.

My kernel version is 2.6.7-1.494.2.2.
Comment 26 Mace Moneta 2004-08-26 11:38:15 EDT
I have an Apple iPod 20GB (4th generation), and am seeing the same
problem.  It works fine in Knoppix 2.6, but in Fedora, I get:

Aug 26 11:30:43 buggsb kernel: usb 1-2: new full speed USB device
using address 3
Aug 26 11:30:44 buggsb kernel: Initializing USB Mass Storage driver...
Aug 26 11:30:44 buggsb kernel: scsi0 : SCSI emulation for USB Mass
Storage devices
Aug 26 11:30:44 buggsb kernel:   Vendor: Apple     Model: iPod       
      Rev: 1.62
Aug 26 11:30:44 buggsb kernel:   Type:   Direct-Access               
      ANSI SCSI revision: 02
Aug 26 11:30:47 buggsb kernel: sda: Spinning up disk......ready
Aug 26 11:30:47 buggsb kernel: SCSI device sda: 39063024 512-byte hdwr
sectors (20000 MB)
Aug 26 11:30:47 buggsb kernel: sda: Write Protect is off
Aug 26 11:30:47 buggsb kernel: sda: assuming drive cache: write through
Aug 26 11:30:47 buggsb kernel:  sda:end_request: I/O error, dev sda,
sector 39063016
Aug 26 11:30:47 buggsb kernel: Buffer I/O error on device sda, logical
block 4882877
Aug 26 11:30:47 buggsb kernel: end_request: I/O error, dev sda, sector
39063016
Aug 26 11:30:47 buggsb kernel: Buffer I/O error on device sda, logical
block 4882877
Aug 26 11:30:47 buggsb kernel:  sda1 sda2
Aug 26 11:30:47 buggsb kernel: Attached scsi removable disk sda at
scsi0, channel 0, id 0, lun 0
Aug 26 11:30:47 buggsb kernel: usbcore: registered new driver usb-storage
Aug 26 11:30:47 buggsb kernel: USB Mass Storage support registered.
Aug 26 11:30:47 buggsb kernel: Attached scsi generic sg0 at scsi0,
channel 0, id 0, lun 0,  type 0


and

# mount -t vfat /dev/sda /mnt/ipod/
mount: /dev/sda: can't read superblock

This appears to be a generic problem with VFAT formated devices, and a
device specific fix is not going to address the general case.

I think the priority of this bug should be raised; it makes the use of
external devices (USB, IEEE1394) unpredictable.  The platform should
be expanded as well.  I'm seeing this on x86_64 as well as i686 machines.
Comment 27 Alexandre Romariz 2004-09-30 20:50:28 EDT
I am also having the USB Memory Stick problem. It used to work
flawlessly on FC1, and stopped working on upgrading to FC2, in either
kernels 2.6.5-1.358 or 2.6.8-1.521. 

The correct entries in /etc/fstab are generated on inserting the
Memory stick, but an attempt to mount causes a "can't read superblock"
error, and a "FAT: unable to read boot sector  entry is generated in
/var/log/messages. I am not attaching the log files, as the problem
(or very similar ones) has been reported here. 

USB connection to my camera keeps working fine.

Can anyone indicate whether this issue persists on FC3 test versions? 
Comment 28 David Fraser 2004-10-13 05:15:53 EDT
I have a similar bug with an Acrox USB2.0 8in1 card reader.
When I connect it to the system I get the following messages:
Oct 13 09:54:39 scir kernel: usb 1-4: new high speed USB device using
address 2
Oct 13 09:54:39 scir kernel: usb 1-4: device not accepting address 2,
error -71
Oct 13 09:54:39 scir kernel: usb 1-4: new high speed USB device using
address 3
Oct 13 09:54:39 scir kernel: usb 1-4: device not accepting address 3,
error -71

This seems to be related to USB2 because if I rmmod ehci_hcd, then I
get the following:

Oct 13 11:15:02 scir kernel: usb 3-2: new full speed USB device using
address 3
Oct 13 11:15:02 scir kernel: scsi0 : SCSI emulation for USB Mass
Storage devices
Oct 13 11:15:07 scir wait_for_sysfs[9070]: error: wait_for_sysfs needs
an update to handle the device
'/devices/pci0000:00/0000:00:02.1/usb3/3-2/3-2:1.0' properly, please
report to <linux-hotplug-devel@lists.sourceforge.net>
Oct 13 11:15:14 scir kernel:   Vendor: SMSC      Model: 223 U HS-CF  
    Rev: 1.95
Oct 13 11:15:14 scir kernel:   Type:   Direct-Access                 
    ANSI SCSI revision: 02
Oct 13 11:15:14 scir scsi.agent[9106]: disk at
/devices/pci0000:00/0000:00:02.1/usb3/3-2/3-2:1.0/host0/0:0:0:0
Oct 13 11:15:50 scir kernel: Attached scsi removable disk sda at
scsi0, channel 0, id 0, lun 0
Oct 13 11:15:50 scir udev: creating device node '/dev/sda'
Oct 13 11:15:51 scir kernel: Device not ready.  Make sure there is a
disc in the drive.
Oct 13 11:15:51 scir kernel: Device not ready.  Make sure there is a
disc in the drive.

Then I cannot mount the drive because I get:
[root@scir ~]# mount -t vfat /dev/sda /mnt/testcdrom/
mount: No medium found

As in comment #27, connecting via my camera works fine. This is with
an SD card.

This is using latest Fedora devel packages:
kernel-2.6.8-1.607
udev-034-2

Is this the same bug or should I report this elsewhere?
Comment 29 Manuel Morales 2004-10-13 09:33:41 EDT
The original bug regarding the Lexar Jumpsht Card Reader had a patch
for it (see comment # 19) that seems to be incorporated in the current
kernel (2.6.8-1.521). It looks to me like the other problems reported
in this bug are probably a separate issue.

Note You need to log in before you can comment on or make changes to this bug.