Bug 124035 - sysstat installed to /usr but init script runs before network
Summary: sysstat installed to /usr but init script runs before network
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sysstat   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Charlie Bennett
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-23 02:24 UTC by Paul Jakma
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 01:13:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Jakma 2004-05-23 02:24:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
The sysstat package contains binaries which are installed to /usr:

/usr/bin/iostat
/usr/bin/mpstat

The init script for sysstat has the following chkconfig line:

# chkconfig: 12345 01 99

The init script references above binaries. This is wrong, as netfs and
autofs do not run until much later:

netfs:
# chkconfig: 345 25 75

autofs:
# chkconfig: 345 28 72

Either sysstat binaries should be installed to /bin or else the
chkconfig line for sysstat init script should be changed to start/stop
after/before autofs.

/usr should not be referenced until after netfs has run.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install sysstat
2. Look at chkconfig line
3. Look at netfs chkconfig line
    

Actual Results:  sysstat init gives errors because /usr is not mounted.


Expected Results:  sysstat init should not fail due to /usr not being
mounted.

Additional info:

Comment 1 Alan Cox 2004-06-16 17:52:27 UTC
Fixed, waiting permission from ccb to commit



Note You need to log in before you can comment on or make changes to this bug.