Bug 124048 - Multiple flash card reader only shows first slot
Multiple flash card reader only shows first slot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 06:32 EDT by Klaus-Peter Schrage
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:23:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for Comsol 4 slot usb reader with CF and SD cards in (14.99 KB, text/plain)
2004-06-15 08:01 EDT, John Sheahan
no flags Details

  None (edit)
Description Klaus-Peter Schrage 2004-05-23 06:32:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have a usb flash reader with 4 slots (SD, SM, CF, MS), but only SD
slot is recognized.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.plug in reader
2.cat /proc/scsi/scsi
3.
    

Actual Results:  
Attached devices:
Host: scsi4 Channel: 00 Id: 00 Lun: 00
  Vendor: Generic  Model: USB SD Reader    Rev: 1.00
  Type:   Direct-Access                    ANSI SCSI revision: 02


Expected Results:  all 4 devices should show up, not just SD slot

Additional info:

This seems to be due to the following standard kernel setting from
config-2.6.5-1.358:

# CONFIG_SCSI_MULTI_LUN is not set

Setting this and recompiling the kernel should fix it.
Comment 1 Dave Jones 2004-05-23 07:10:58 EDT
you can also modprobe the scsi_mod module with the parameter
'max_luns=4' which should work.
I'll also add your device to the whitelist so that in a future update
kernel you won't need to add this.
Comment 2 Klaus-Peter Schrage 2004-05-23 08:11:26 EDT
Thanks, yes adding the line
options scsi_mod max_luns=4
to /etc/modprobe.conf fixed it.

Now cat /proc/scsi/scsi shows:

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: Generic  Model: USB SD Reader    Rev: 1.00
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 00 Lun: 01
  Vendor: Generic  Model: USB CF Reader    Rev: 1.01
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 00 Lun: 02
  Vendor: Generic  Model: USB SM Reader    Rev: 1.02
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 00 Lun: 03
  Vendor: Generic  Model: USB MS Reader    Rev: 1.03
  Type:   Direct-Access                    ANSI SCSI revision: 02
Comment 3 John Sheahan 2004-06-13 00:58:45 EDT
I have a comsol 4 slot card reader
P:  Vendor=07cc ProdID=0300 Rev= 0.05
S:  Manufacturer=        Ltd
S:  Product=Winter Ver1.3   
S:  SerialNumber=058150594954

the CF slot is the only one that works with the ship kernel.
If I recompile with CONFIG_SCSI_MULTI_LUN=y
then the SD slot (at least) also works.

Is this similar?
Comment 4 Klaus-Peter Schrage 2004-06-13 05:15:36 EDT
Yes, that seems to be same issue.
Comment 5 Dave Jones 2004-06-14 12:17:35 EDT
John, if you attach the dmesg output, we can add your device to the
whitelist.
Comment 6 John Sheahan 2004-06-15 08:01:28 EDT
Created attachment 101142 [details]
dmesg for Comsol 4 slot usb reader with CF and SD cards in

dmesg attached. This is 2.6.7-rc1-mm1 (root@wattle) (gcc version 3.3.3 20040412
on fc2, with CONFIG_SCSI_MULTI_LUN=y
(for UDF reasons) but usb card reader behaviour seemed the same on 2.6.5
Comment 7 Dave Jones 2004-11-02 23:24:35 EST
added to whitelist for the next build.

Note You need to log in before you can comment on or make changes to this bug.