Bug 124063 - X won't load with Radeon 9200
X won't load with Radeon 9200
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://freedesktop.org/bugzilla/show_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 13:31 EDT by Alan McMahon
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 00:42:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan McMahon 2004-05-23 13:31:53 EDT
Description of problem:

There seems to be a problem with Xorg and (ATI) Radeon graphics cards.
FC2 installs without error message. I can't find my TFT monitor in the
list offered (I've tried an IBM, an Iiyama and a Samsung!), but I
choose generic and specify the corrrect resolution and HSync/VSync's.
After install completes and I reboot, X loads to a screen of
horizontally-smeared pixels. I can just about make out the Fedora
logo. The processor hangs and I need to cold boot.

I read on a forum that Xorg handles 2-D graphics with ATI Radeon
(maybe not with AMD 64), but that's not my experience. 





Version-Release number of selected component (if applicable):
6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 on a AMD-64 machine with a ATI Radeon 9200 g/card and a
TFT monitor.
2. Reboot.
3.
    

Actual Results:  Smeared screen. Computer freezes.

Expected Results:  X running!

Additional info:

n/a
Comment 1 Steven Blake 2004-05-24 21:58:56 EDT
I have encountered the same problem.  Installed FC2 on a ASUS K8V
Deluxe motherboard, Athlon 64 3000+, ATI Radeon 9200.  Installation
was a success, firstboot results in a "smeared screen" during boot
(when rhgb starts), although the mouse cursor still works.  Changed
kernel boot options to "3 nogb" in grub, boot now completes.  If I
then startx, the same smeared screen occurs.  The mouse cursor works,
but Ctl-Alt-Backspace doesn't kill X, and none of the virtual consoles
work, so I have to reboot. 

I changed the driver from "radeon" to "vesa" in /etc/X11/xorg.conf. X
now works, although it hangs whenever I try to change the screen
resolution (e.g., Ctl-Atl-+).
Comment 2 Steven Blake 2004-05-24 23:05:15 EDT
I have encountered the same problem.  Installed FC2 on a ASUS K8V
Deluxe motherboard, Athlon 64 3000+, ATI Radeon 9200.  Installation
was a success, firstboot results in a "smeared screen" during boot
(when rhgb starts), although the mouse cursor still works.  Changed
kernel boot options to "3 nogb" in grub, boot now completes.  If I
then startx, the same smeared screen occurs.  The mouse cursor works,
but Ctl-Alt-Backspace doesn't kill X, and none of the virtual consoles
work, so I have to reboot. 

I changed the driver from "radeon" to "vesa" in /etc/X11/xorg.conf. X
now works, although it hangs whenever I try to change the screen
resolution (e.g., Ctl-Atl-+).
Comment 3 Don Lindsay 2004-07-13 01:12:56 EDT
I have the same problem.

If you boot a rescue disk, and go in and edit /etx/X11/xorg.conf, and
change Depth to 8 (ie 8 bits per pixel), then reboot, it will work.
Well, with bad visuals, but that's better than none.

Comment 4 Don Lindsay 2004-07-14 00:12:55 EDT
At the suggestion of mharris@redhat.com, this bug should be tracked
via the x.org Bugzilla, not the Red Hat Bugzilla. I opened bug #797 there:

http://freedesktop.org/bugzilla/show_bug.cgi?id=797

and will post a back-reference there to this entry.
Comment 5 Don Lindsay 2004-11-14 14:09:22 EST
I upgraded my FC2-x86_64 to FC3-x86_64, ie
xorg-x11-6.7.0-2.x86_64.rpm
to
xorg-x11-6.8.1-12.x86_64.rpm

It's not fixed. This is getting old (literally). C'mon people.


Comment 6 Mike A. Harris 2004-11-16 00:42:31 EST
Thanks for providing a link to the upstream bug report Don.  We
will be tracking this issue in the freedesktop.org bugzilla going
forward.  Once a fix for this issue is available from X.Org, we
will review it for consideration in future updates.

Setting status to "UPSTREAM" for tracking in freedesktop's bugzilla.
Comment 7 Don Lindsay 2004-11-19 17:19:23 EST
I configured my BIOS to run the Radeon's AGP bus at 4x instead of at
8x, and the problem went away.

I assume that this is a workaround, not a fix, since the card works at
8x at 8bpp. I hear (but haven't confirmed) that Suse 9 has no problem
using this card at 8x.

I will place this into freedesktop's bugzilla once they come back from
their current multi-day outage.
Comment 8 Mike A. Harris 2004-11-19 18:45:16 EST
The stock X.Org radeon driver does not support AGP 8x.  It's
possible SuSE has patches to add AGP 8x support to the driver,
and if so, hopefully they (or someone) will contribute the work
to X.Org via X.Org bugzilla, so it will become integrated
into future X.org releases.

In the mean time, it is recommended to use AGP 4x.  The open
source drivers do not really use AGP very much anyway, so there
is not likely much if any gain between using AGP 4x and AGP 8x.

You may also want to join the dri-devel mailing list and
search the archives for this problem.  There may have been
discussion previously about it.

I do not believe the AGP 8x issue is related to the initial
bug report however.  Can the initial reporter please confirm
wether setting AGP 4x resolves the problem?
Comment 9 Steven Blake 2004-11-19 19:03:14 EST
I was one of the original submitters.  Switching AGP to 4x fixed the
problem I experienced for the original xorg release in FC2/x86_64.
It is also working fine for xorg-x11-6.8.1-12.FC3.1 in FC3/x86_64.
I haven't attempted to test it at AGP 8x.

Note that this same system worked fine at AGP 8X with Xfree in FC1.
Comment 10 enricog 2005-08-08 17:29:06 EDT
... and in FC4/x86_64 the bug still lives!

Nobody's found a proper fix yet?

Note You need to log in before you can comment on or make changes to this bug.