Bug 124075 - do not modify /etc/ld.so.conf, use /etc/ld.so.conf.d
do not modify /etc/ld.so.conf, use /etc/ld.so.conf.d
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
: 124079 (view as bug list)
Depends On: 124076 124077 124078 124080
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 16:35 EDT by Florian La Roche
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 12:41:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2004-05-23 16:35:44 EDT
Description of problem:
rpm packages should not modify ld.so.conf in their
post script, but use this subdir to add new dirs
to the standard search path for libs


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2004-05-23 16:40:10 EDT
*** Bug 124079 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-05-25 12:37:17 EDT
Does this functionality already exist in glibc?
Comment 3 Barry K. Nathan 2004-06-08 23:16:06 EDT
Yes, since glibc-2.3.3-18
Comment 4 Thomas Woerner 2004-07-01 12:08:27 EDT
This should look like this:

/etc/ld.so.conf.d/
                  <package>-<arch>.conf
                  ...

Or like this

/etc/ld.so.conf.d/
                  <arch>/
                         <package>.conf
                  ...
Comment 5 Thomas Woerner 2005-01-26 12:41:27 EST
I think this is done.
Closing as currentrelease.

Note You need to log in before you can comment on or make changes to this bug.