Bug 124097 - Workspace Switcher eats first character or mouse-click after switching
Workspace Switcher eats first character or mouse-click after switching
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-23 22:25 EDT by Paul Dickson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 23:55:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2004-05-23 22:25:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2)
Gecko/20040522 Firefox/0.8.0+

Description of problem:
After using the Keyboard short-cut to switch workspaces, the Workspace
Switcher leaves its diagram on the screen after the keyboard keys are
released.  I'm guessing this is done to the arrow-keys (only) can be
used to further navigate the workspaces.  Any other keypress causes
the diagram to disappear.  The problem is:  the "any other keypress"
is usually intended for what's on the work space.

For example:  If I have yum running in a terminal on a workspace, it
usually takes a while to process so I switch to another workspace to
do something else.  When I return, yum has a [y/N] prompt.  If I press
y<cr>, the y is eaten by the Workspace Switcher and yum only get the
<cr> and takes the N path.

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-9

How reproducible:
Always

Steps to Reproduce:
1. Under Preferences->"Keyboard Shortcuts" I have "Window Management"
-> "Switch to workspace on the left" set to <Mod4>Left which is the
WindowsKey and Left Arrow (my keyboard uses diamonds on this key). 
Also set the "on the right, above and below to corresponding
arrow-keys too.

It's likely there's some other default values for these keys, but I
had to change these in FC1 due my keyboard not having the keys in
right place to do the switching one-handed (the control-key is on the
opposite side of the keyboard from the arrow-keys).

2. Have terminal windows and other applications open in different
workspaces.  The same workspace is fine too.

3. Press and hold the WindowsKey and press an arrow key to switch
workspaces.


Actual Results:  The screen is switched to the requested workspace (if
it existed), but the Workspace Switcher diagram remains on the screen
even after releasing the keyboard keys.  New input is required (either
key press or mouse click) before input is accepted by the programs in
the workspace.

Expected Results:  Once the key-up occurs for all the pressed keys,
the Workspace Switcher diagram should disappear and the next input
(key stroke or mouse click) should go to the focused application on
the workspace.

Additional info:

I chose Severity:High because the disappearing keystrokes and missing
mouse-clicks make the system difficult to use.  Yum aborts because of
the missing y, the web browser and mail programs don't work correctly
because the mouse-clicks disappear.
Comment 1 Mark McLoughlin 2004-08-09 13:07:50 EDT
The shortcut is actually implemented by metacity, moving there
Comment 2 Elijah Newren 2004-10-31 01:42:29 EST
This is a duplicate of bug 122752.  It was fixed manually for the
Fedora 3 metacity 2.8.6 package by Soeren and submitted upstream in
http://bugzilla.gnome.org/show_bug.cgi?id=151554.
Comment 3 Havoc Pennington 2004-11-09 23:55:21 EST
Fixed now

Note You need to log in before you can comment on or make changes to this bug.