Bug 124109 - Simultaneous sounds are not mixed or dropped based on priority
Simultaneous sounds are not mixed or dropped based on priority
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Reed
http://sourceforge.net/tracker/index....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 01:08 EDT by Brian "netdragon" Bober
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 21:47:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2004-05-24 01:08:28 EDT
Description of problem:

Playing two sounds simultaneously causes the sounds to be queued,
which is incredibly silly in almost all cases because sounds are
usually related to events that you want to hear immediately or drop. I
have no problem with this when I installed Alsa on my own on Rehdat 8
but in Fedora Core 2, sound is not mixed or dropped.

I have an AC97 sound card (i810 audio) from an i845G chipset board.

How reproducible:

Always


Steps to Reproduce:
This is an example -- 
1. Use a sound card without hardware mixing
2. Play a song in XMMS
3. Start recieving messages on Gaim (you can send them to yourself)
4. When the song finishes playing you hear a long string of IM sounds,
which should have been dropped.
  
Actual results:

Sounds are queued when another sound is playing.

Expected results:

Sounds are generally dropped, or software mixed.

Additional info:

The FC2 list during the release of test2 did not not have any
solutions to this issue.
Comment 1 Bill Nottingham 2004-05-25 15:58:11 EDT
Does this happen with all apps, or just things like GAIM?
Comment 2 Brian "netdragon" Bober 2004-05-25 20:00:51 EDT
Any applications that try to play sounds simultaneously.
Comment 3 Brian "netdragon" Bober 2004-05-25 20:09:25 EDT
Sorry, any two applications, that is. I did notice, though, that there
are cases where this doesn't happen, like if I play flash in the
browser, and XMMS at the same time, mixing occurs. Same with the
system  sound for clicking a launcher icon. It seems to happen
inconsistantly.
Comment 4 Brian "netdragon" Bober 2004-05-25 20:10:20 EDT
Sorry, inconsistantly as in some applications cause it, some don't.
I've seen it happen in other cases, I just can't remember which other
than GAIM.
Comment 5 Brian "netdragon" Bober 2004-05-27 15:27:17 EDT
I figured out a solution. When I changed in GAIM preferences under
sound from Automatic to ESD, the problem went away.
Comment 6 Brian "netdragon" Bober 2004-05-27 21:47:18 EDT
I filed a bug on GAIM's bugtracker

http://sourceforge.net/tracker/index.php?func=detail&aid=961783&group_id=235&atid=100235

Note You need to log in before you can comment on or make changes to this bug.