Bug 1241688 (MODE-2482) - Support multi-valued properties in document view export - Modeshape
Summary: Support multi-valued properties in document view export - Modeshape
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: MODE-2482
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Horia Chiorean
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 19:44 UTC by dsteigne
Modified: 2019-07-11 09:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-29 14:15:32 UTC
Type: Feature Request


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker MODE-2482 Major Closed Support multi-valued properties in document view export 2016-08-29 14:15:02 UTC

Description dsteigne 2015-07-09 19:44:15 UTC
Describe the issue: 
See https://issues.jboss.org/browse/MODE-2482

Suggestions for improvement: 

Additional information:

Comment 2 Horia Chiorean 2015-07-10 05:56:00 UTC
This is an enhancement i.e. feature request, not a bug.
The workaround is described in the JIRA issue and that is to use system view export.

Comment 3 Horia Chiorean 2015-07-10 06:00:41 UTC
As per the JCR spec:

7.3.3 Multi-Value Properties
If a multi-value property P is encountered on export, the repository may  either ignore the multi-value property or serialize it as an attribute whose value is an XML Schema list type14 (i.e., a whitespace-delimited list of strings).

So the current behavior is perfectly acceptable. 

This can be backported for DV 6.2, but as a feature request - and handled as such - not a bug. See above comment for workaround.

Comment 4 JBoss JIRA Server 2015-11-16 14:42:51 UTC
Horia Chiorean <hchiorea@redhat.com> updated the status of jira MODE-2482 to Reopened

Comment 6 JBoss JIRA Server 2015-11-17 14:39:25 UTC
Horia Chiorean <hchiorea@redhat.com> updated the status of jira MODE-2482 to Closed

Comment 7 Horia Chiorean 2015-11-17 14:42:21 UTC
This has been backported to the 3.8.x-prod-ip6.3 branch (86e5cbfb98e9184adc6a7e94ee880f859d374c7e)


Note You need to log in before you can comment on or make changes to this bug.