Bug 124187 - Network devices named "dev2552", etc
Network devices named "dev2552", etc
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-network (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 12:43 EDT by Bjorn Helgaas
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjorn Helgaas 2004-05-24 12:43:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
This is from HP internal defect report, PS3206, reported by Luke
Mentzer.  The problem was observed in a 16-CPU HP olympia
with two I/O chassis.  I believe the tulip cards referenced
below are four-port cards.


In a two-chassis partition once a second tulip card is added, then the problems 
start. The data below shows the erroneous interfaces. This happens regardless 
of what chassis the card is added to. Trying to add addtional Broadcom or tuilp 
cards once the networking is in this state produces similar resu 
lts.

The system is in acpiconfig single-pci-domain(2 chassis) partition configuration

>From redhat-config-network from gui hardware tab


Description                         Type         Device   Status
-----------------------------------------------------------------
NetXtreme BCM5701 Gigabit Ethernet  Ethernet     eth0      ok
NetXtreme BCM5701 Gigabit Ethernet  Ethernet     eth1      ok
DECchip 21142/43                    Unknown      dev2552   ok
DECchip 21142/43                    Unknown      dev7404   ok
DECchip 21142/43                    Ethernet     eth5      ok
DECchip 21142/43                    Unknown      dev30235  ok
DECchip 21142/43                    Ethernet     eth2      ok
DECchip 21142/43                    Ethernet     eth3      ok
DECchip 21142/43                    Ethernet     eth4      ok
DECchip 21142/43                    Ethernet     eth9      ok


ifconfig -a

dev2552   Link encap:Ethernet  HWaddr 00:30:6E:04:38:10
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:55

dev7404   Link encap:Ethernet  HWaddr 00:30:6E:04:38:12
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:57 Base address:0x2000

dev30235  Link encap:Ethernet  HWaddr 00:30:6E:04:38:13
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:58 Base address:0x3000

eth0      Link encap:Ethernet  HWaddr 00:30:6E:4B:1A:7F
          inet addr:15.11.135.193  Bcast:15.11.135.255  Mask:255.255.248.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23904 errors:1 dropped:0 overruns:0 frame:0
          TX packets:5502 errors:0 dropped:0 overruns:0 carrier:0
          collisions:31 txqueuelen:1000
          RX bytes:4693728 (4.4 Mb)  TX bytes:3400192 (3.2 Mb)
          Interrupt:50

eth1      Link encap:Ethernet  HWaddr 00:30:6E:4B:1A:20
          inet addr:10.10.10.1  Bcast:10.10.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20302 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1984829 (1.8 Mb)  TX bytes:384 (384.0 b)
          Interrupt:62

eth2      Link encap:Ethernet  HWaddr 00:30:6E:04:D4:AC
          inet addr:100.100.105.5  Bcast:100.100.105.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:70

eth3      Link encap:Ethernet  HWaddr 00:30:6E:04:D4:AD
          inet addr:100.100.106.6  Bcast:100.100.106.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:71 Base address:0x1000

eth4      Link encap:Ethernet  HWaddr 00:30:6E:04:D4:AE
          inet addr:100.100.107.7  Bcast:100.100.107.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:72 Base address:0x2000

eth5      Link encap:Ethernet  HWaddr 00:30:6E:04:38:11
          inet addr:100.100.108.8  Bcast:100.100.108.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:56 Base address:0x1000

eth9      Link encap:Ethernet  HWaddr 00:30:6E:04:D4:AF
          inet addr:100.100.103.3  Bcast:100.100.103.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:73 Base address:0x3000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:700 (700.0 b)  TX bytes:700 (700.0 b)

-------------------------------------------------------
CONDITIONS WHICH RELIABLY REPRODUCE BUG SYMPTOMS:

Setup a two-chassis partition. Add two tulip (5506) cards to the system and 
attempt to configure the network interfaces. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Harald Hoyer 2004-05-25 05:42:33 EDT
what exactly is the problem??
Comment 2 Luke Mentzer 2004-06-01 11:57:54 EDT
The real problem is that the interfaces in the tulip card cannot be 
used, because they are mis-identified. The name "dev2552" can be any 
number after the "dev".

When a second tulip card is installed in a two-chassis single-pci-
domain, it causes some of the interfaces to become un-usable. 
Sometimes it will only see two interfaces on the original card when 
they were all working before the second card was installed. Other 
times it may see them all correctly and work properly, but none of 
the interfaces in the second (newly installed) card will work. Once 
this happens, the only way to resolve it is to remove all tulip cards 
except for one. Remove all the eth* files in network-script, 
networking/* and clean up hwconf and /etc/modules.conf. Then the 
single tulip can be administered.

Any broadcom cards that were already configured before the second 
tulip card was installed, are unaffected and will function properly. 
Any cards that are added after, may or may not work. It just depends 
on how the system is feeling that day.  :)

The hwconf and network-script files will have an entry with "dev" 
followed by some number. An ifconfig all will also show the 
interface, but because the system does not know what kind of device 
it is, the interface cannot be used.

The /proc/pci entries for the tulip are fine.
Comment 3 Harald Hoyer 2004-06-02 04:26:09 EDT
try adding:
TYPE=Ethernet 
to the ifcfg-dev* files.
Are they not functioning from within the GUI? or does manually setting
up the ifcfg-dev* files not function with the initscripts (ifup/ifdown)??
Comment 5 Bruce-Robert Pocock 2005-08-26 22:12:47 EDT
Seeing this same on an iBook G3 with FC4. The eth0 (hardline Ethernet) always
comes up at eth0. The would-be eth1 (Airport WiFi) however, chooses a different
random number after "dev" on each reboot. This makes the ifcfg-dev* files
useless since the device number is different each time.

This has been happening on FC4 for the past 2-3 weeks, using nightly yum updates
on the "stable" series (not Rawhide/developer series)

Work-around is to open a terminal, discover today's interface name with
"ifconfig -a", and then manually "iwconfig" (if needed) and start "dhclient
devXXXX." But, that is definitely Not How It Should Work.

NetworkManager also seems confused, as it doesn't seem to identify the interface
or make any efforts to bring it up.
Comment 6 Harald Hoyer 2005-08-29 07:01:42 EDT
if the names are dynamic, why don't you use the HWADDR option or "bind to MAC
address" feature in the gui.
Comment 7 RHEL Product and Program Management 2007-10-19 15:25:52 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.